aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2021-03-24 13:34:35 +0000
committerRene Ladan <rene@FreeBSD.org>2021-03-24 13:34:35 +0000
commitb217c7fc9cc4e56e26f88b17551499a17c4c6d24 (patch)
tree927d28feccb5a8860ed230fbec099ccb4255ada8 /games
parent80fa663d16236be2c6d5165f92327ed60b6a4b42 (diff)
downloadports-b217c7fc9cc4e56e26f88b17551499a17c4c6d24.tar.gz
ports-b217c7fc9cc4e56e26f88b17551499a17c4c6d24.zip
Mark ports recursively depending on Python 2.7 for expiration on June 23.
For ports optionally dependending on Python 2.7, just mark those options as expired. Remove konquerer from the x11/kde-baseapps metaport and bump its PORTREVISION. Submitted by: rene Reviewed by: portmgr, adridg, ehaupt, lme, madpilot, pizzamig, se, sunpoet, yuri Approved by: portmgr Differential Revision: https://reviews.freebsd.org/D28665
Notes
Notes: svn path=/head/; revision=569118
Diffstat (limited to 'games')
-rw-r--r--games/anki/Makefile3
-rw-r--r--games/minilens/Makefile3
-rw-r--r--games/py-mnemosyne/Makefile3
-rw-r--r--games/stratagus/Makefile3
-rw-r--r--games/tanks-of-freedom/Makefile3
-rw-r--r--games/wargus/Makefile3
-rw-r--r--games/wyrmgus/Makefile3
-rw-r--r--games/wyrmsun/Makefile3
8 files changed, 24 insertions, 0 deletions
diff --git a/games/anki/Makefile b/games/anki/Makefile
index c05e0b1203c5..8f257cd36621 100644
--- a/games/anki/Makefile
+++ b/games/anki/Makefile
@@ -16,6 +16,9 @@ COMMENT= Flashcard trainer with spaced repetition
LICENSE= AGPLv3+
LICENSE_FILE= ${WRKSRC}/LICENSE
+DEPRECATED= Uses EOL Python 2.7 via www/py-qt5-webengine
+EXPIRATION_DATE=2021-06-23
+
BUILD_DEPENDS= bash:shells/bash \
maturin:devel/py-maturin@${PY_FLAVOR} \
protoc:devel/protobuf \
diff --git a/games/minilens/Makefile b/games/minilens/Makefile
index ab33ae93336d..cec3908fe546 100644
--- a/games/minilens/Makefile
+++ b/games/minilens/Makefile
@@ -14,6 +14,9 @@ LICENSE= GPLv3+ CC-BY-SA-4.0
LICENSE_COMB= multi
LICENSE_FILE_GPLv3+ = ${WRKSRC}/LICENSE.txt
+DEPRECATED= Uses EOL Python 2.7 via devel/godot2
+EXPIRATION_DATE=2021-06-23
+
RUN_DEPENDS= godot2:devel/godot2
USE_GITHUB= yes
diff --git a/games/py-mnemosyne/Makefile b/games/py-mnemosyne/Makefile
index 9a99bc19ffda..52e7eac162cf 100644
--- a/games/py-mnemosyne/Makefile
+++ b/games/py-mnemosyne/Makefile
@@ -15,6 +15,9 @@ COMMENT= Flash-card tool which optimises your learning process
LICENSE= LGPL3
+DEPRECATED= Uses EOL Python 2.7 via www/py-qt5-webengine
+EXPIRATION_DATE=2021-06-23
+
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR} \
${PYTHON_PKGNAMEPREFIX}PyOpenGL>=0:graphics/py-PyOpenGL@${PY_FLAVOR} \
${PY_PILLOW} \
diff --git a/games/stratagus/Makefile b/games/stratagus/Makefile
index 609c2a0780ef..de0920f370bc 100644
--- a/games/stratagus/Makefile
+++ b/games/stratagus/Makefile
@@ -12,6 +12,9 @@ COMMENT= Free cross-platform real-time strategy gaming engine
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+DEPRECATED= Uses EOL Python 2.7 via lang/tolua++
+EXPIRATION_DATE=2021-06-23
+
LIB_DEPENDS= libpng.so:graphics/png \
libtolua++-${LUA_VER}.so:lang/tolua++
diff --git a/games/tanks-of-freedom/Makefile b/games/tanks-of-freedom/Makefile
index 502acefc5750..734b44822226 100644
--- a/games/tanks-of-freedom/Makefile
+++ b/games/tanks-of-freedom/Makefile
@@ -14,6 +14,9 @@ LICENSE_FILE= ${WRKSRC}/LICENSE.md
RUN_DEPENDS= godot2:devel/godot2
+DEPRECATED= Uses EOL Python 2.7 via devel/godot2
+EXPIRATION_DATE=2021-06-23
+
USE_GITHUB= yes
GH_ACCOUNT= w84death
GH_PROJECT= Tanks-of-Freedom
diff --git a/games/wargus/Makefile b/games/wargus/Makefile
index 57dc1a978b1e..ca3f059fca4d 100644
--- a/games/wargus/Makefile
+++ b/games/wargus/Makefile
@@ -12,6 +12,9 @@ COMMENT= Warcraft 2 mod that allows you to play Warcraft 2 with Stratagus
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
+DEPRECATED= Uses EOL Python 2.7 via games/stratagus
+EXPIRATION_DATE=2021-06-23
+
RUN_DEPENDS= stratagus:games/stratagus \
ffmpeg2theora:multimedia/ffmpeg2theora \
cdparanoia:audio/cdparanoia
diff --git a/games/wyrmgus/Makefile b/games/wyrmgus/Makefile
index cc606c9f959d..38951b72a151 100644
--- a/games/wyrmgus/Makefile
+++ b/games/wyrmgus/Makefile
@@ -12,6 +12,9 @@ COMMENT= Modified Stratagus engine for Wyrmsun
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
+DEPRECATED= Uses EOL Python 2.7 via lang/tolua++
+EXPIRATION_DATE=2021-06-23
+
LIB_DEPENDS= libtolua++-${LUA_VER}.so:lang/tolua++
BUILD_DEPENDS= ${LOCALBASE}/include/boost/tokenizer.hpp:devel/boost-libs
diff --git a/games/wyrmsun/Makefile b/games/wyrmsun/Makefile
index 4d684dfc60f5..12b4451ab6f3 100644
--- a/games/wyrmsun/Makefile
+++ b/games/wyrmsun/Makefile
@@ -12,6 +12,9 @@ COMMENT= Strategy game based on history, mythology and fiction
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/license.txt
+DEPRECATED= Uses EOL Python 2.7 via games/wyrmgus
+EXPIRATION_DATE=2021-06-23
+
RUN_DEPENDS= wyrmgus:games/wyrmgus
USE_GITHUB= yes