aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2023-12-03 21:44:37 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2023-12-03 22:17:33 +0000
commitb2a438e1ba2f1f806519a925c2f241d2f4675c65 (patch)
tree5f69bdec864a286a791a1f694f3aabd4a6b97b70 /games
parent067a18449b4160d67a5e903ace93cfcf3086694a (diff)
downloadports-b2a438e1ba2f1f806519a925c2f241d2f4675c65.tar.gz
ports-b2a438e1ba2f1f806519a925c2f241d2f4675c65.zip
Diffstat (limited to 'games')
-rw-r--r--games/auralquiz/Makefile5
-rw-r--r--games/blinken/Makefile4
-rw-r--r--games/bomber/Makefile4
-rw-r--r--games/kblocks/Makefile4
-rw-r--r--games/kbounce/Makefile4
-rw-r--r--games/kolf/Makefile4
-rw-r--r--games/kollision/Makefile4
-rw-r--r--games/kpat/Makefile4
-rw-r--r--games/ksirk/Makefile4
-rw-r--r--games/ktuberling/Makefile4
10 files changed, 21 insertions, 20 deletions
diff --git a/games/auralquiz/Makefile b/games/auralquiz/Makefile
index 3d9ec558f5a7..cf2e7f79c793 100644
--- a/games/auralquiz/Makefile
+++ b/games/auralquiz/Makefile
@@ -14,9 +14,10 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libtag.so:audio/taglib
-USES= compiler:c++11-lang gl qmake qt:5
+USES= compiler:c++11-lang gl kde:5 qmake qt:5
USE_GL= gl
-USE_QT= core gui widgets phonon4 qmake:build buildtools:build
+USE_KDE= phonon
+USE_QT= core gui widgets qmake:build buildtools:build
PORTDOCS= CHANGELOG README TODO
diff --git a/games/blinken/Makefile b/games/blinken/Makefile
index b4fa41daef39..c5c427bef4b7 100644
--- a/games/blinken/Makefile
+++ b/games/blinken/Makefile
@@ -8,9 +8,9 @@ WWW= https://edu.kde.org/blinken/
USES= cmake compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs config configwidgets coreaddons crash dbusaddons \
- doctools guiaddons i18n widgetsaddons xmlgui \
+ doctools guiaddons i18n phonon widgetsaddons xmlgui \
ecm:build
-USE_QT= core dbus gui phonon4 svg widgets xml \
+USE_QT= core dbus gui svg widgets xml \
buildtools:build qmake:build
OPTIONS_DEFINE= DOCS
diff --git a/games/bomber/Makefile b/games/bomber/Makefile
index aee53e159b23..7259ca34bade 100644
--- a/games/bomber/Makefile
+++ b/games/bomber/Makefile
@@ -8,9 +8,9 @@ WWW= https://www.kde.org/applications/games/bomber/
USES= cmake compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs config configwidgets coreaddons crash dbusaddons \
- i18n kio libkdegames widgetsaddons xmlgui \
+ i18n kio libkdegames phonon widgetsaddons xmlgui \
ecm:build
-USE_QT= core dbus declarative gui network widgets phonon4 xml \
+USE_QT= core dbus declarative gui network widgets xml \
buildtools:build qmake:build
OPTIONS_DEFINE= DOCS
diff --git a/games/kblocks/Makefile b/games/kblocks/Makefile
index dfec27a34676..e15d637308d2 100644
--- a/games/kblocks/Makefile
+++ b/games/kblocks/Makefile
@@ -9,9 +9,9 @@ WWW= https://www.kde.org/applications/games/kblocks/
USES= cmake compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs completion config configwidgets coreaddons crash \
dbusaddons i18n itemmodels kio libkdegames newstuff \
- notifyconfig textwidgets widgetsaddons windowsystem xmlgui \
+ notifyconfig phonon textwidgets widgetsaddons windowsystem xmlgui \
ecm:build
-USE_QT= core dbus declarative gui network phonon4 svg testlib widgets \
+USE_QT= core dbus declarative gui network svg testlib widgets \
xml \
buildtools:build qmake:build
diff --git a/games/kbounce/Makefile b/games/kbounce/Makefile
index 86b5b68b9bde..f04dba1aa7e0 100644
--- a/games/kbounce/Makefile
+++ b/games/kbounce/Makefile
@@ -9,10 +9,10 @@ WWW= https://www.kde.org/applications/games/kbounce/
USES= cmake compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs completion config configwidgets coreaddons crash \
dbusaddons guiaddons i18n iconthemes jobwidgets kio \
- libkdegames notifyconfig service solid textwidgets widgetsaddons \
+ libkdegames notifyconfig phonon service solid textwidgets widgetsaddons \
windowsystem xmlgui \
ecm:build
-USE_QT= concurrent core dbus declarative gui network phonon4 svg \
+USE_QT= concurrent core dbus declarative gui network svg \
testlib widgets xml \
buildtools:build qmake:build
diff --git a/games/kolf/Makefile b/games/kolf/Makefile
index d5d07f9fd9ab..e245627481cb 100644
--- a/games/kolf/Makefile
+++ b/games/kolf/Makefile
@@ -10,10 +10,10 @@ USES= cmake compiler:c++11-lang desktop-file-utils kde:5 qt:5 tar:xz
USE_KDE= auth bookmarks codecs completion config configwidgets \
coreaddons crash dbusaddons guiaddons i18n iconthemes \
itemviews jobwidgets kdelibs4support kio libkdegames \
- notifications parts service solid sonnet textwidgets \
+ notifications parts phonon service solid sonnet textwidgets \
unitconversion widgetsaddons windowsystem xmlgui \
ecm:build
-USE_QT= concurrent core dbus declarative gui network phonon4 printsupport \
+USE_QT= concurrent core dbus declarative gui network printsupport \
widgets xml \
buildtools:build qmake:build
diff --git a/games/kollision/Makefile b/games/kollision/Makefile
index 2dabe0906bad..2fbd6c25b89b 100644
--- a/games/kollision/Makefile
+++ b/games/kollision/Makefile
@@ -8,10 +8,10 @@ WWW= https://www.kde.org/applications/games/kollision/
USES= cmake compiler:c++11-lang gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs config configwidgets coreaddons crash dbusaddons \
- i18n kio libkdegames newstuff notifyconfig textwidgets \
+ i18n kio libkdegames newstuff notifyconfig phonon textwidgets \
widgetsaddons xmlgui \
ecm:build
-USE_QT= core dbus declarative gui network phonon4 svg widgets xml \
+USE_QT= core dbus declarative gui network svg widgets xml \
buildtools:build qmake:build
OPTIONS_DEFINE= DOCS
diff --git a/games/kpat/Makefile b/games/kpat/Makefile
index 805fba963f39..8b34a0f49305 100644
--- a/games/kpat/Makefile
+++ b/games/kpat/Makefile
@@ -13,10 +13,10 @@ USES= cmake compiler:c++11-lang desktop-file-utils gettext kde:5 pkgconfig \
qt:5 shared-mime-info tar:xz
USE_KDE= attica auth codecs completion config configwidgets coreaddons \
crash dbusaddons guiaddons i18n iconthemes itemviews \
- kdeclarative kio libkdegames newstuff notifyconfig service \
+ kdeclarative kio libkdegames newstuff notifyconfig phonon service \
textwidgets widgetsaddons xmlgui \
ecm:build
-USE_QT= concurrent core dbus declarative gui network phonon4 svg widgets xml \
+USE_QT= concurrent core dbus declarative gui network svg widgets xml \
buildtools:build qmake:build testlib:build
CMAKE_ON= WITH_BH_SOLVER
diff --git a/games/ksirk/Makefile b/games/ksirk/Makefile
index fc284c406d73..714b9721d9bf 100644
--- a/games/ksirk/Makefile
+++ b/games/ksirk/Makefile
@@ -8,10 +8,10 @@ WWW= https://www.kde.org/applications/games/ksirk/
USES= cmake compiler:c++11-lang kde:5 qca qt:5 tar:xz
USE_KDE= attica auth codecs completion config configwidgets coreaddons \
- crash i18n iconthemes kio libkdegames newstuff service wallet \
+ crash i18n iconthemes kio libkdegames newstuff phonon service wallet \
widgetsaddons xmlgui \
ecm:build
-USE_QT= concurrent core dbus declarative gui network phonon4 svg \
+USE_QT= concurrent core dbus declarative gui network svg \
widgets xml \
buildtools:build qmake:build testlib:build
USE_LDCONFIG= yes
diff --git a/games/ktuberling/Makefile b/games/ktuberling/Makefile
index 51b9a6a675dd..35d938944f1a 100644
--- a/games/ktuberling/Makefile
+++ b/games/ktuberling/Makefile
@@ -11,11 +11,11 @@ USE_KDE= auth bookmarks codecs completion config configwidgets \
coreaddons crash dbusaddons emoticons guiaddons i18n \
iconthemes init itemmodels itemviews jobwidgets \
kdelibs4support kio libkdegames newstuff notifications \
- notifyconfig parts service solid sonnet textwidgets \
+ notifyconfig parts phonon service solid sonnet textwidgets \
unitconversion widgetsaddons windowsystem xmlgui \
ecm:build
USE_QT= concurrent core dbus declarative gui multimedia network \
- phonon4 printsupport svg testlib widgets xml \
+ printsupport svg testlib widgets xml \
buildtools:build qmake:build
OPTIONS_DEFINE= DOCS