aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-07-06 13:35:21 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-07-06 13:35:21 +0000
commitb6d50ba97ecb314df107d7811aba24eb2b48f106 (patch)
treed3df9245b391e48f5e0b87a8894e496ec425cb30 /games
parentd0bf21ba1d9d8c8270615f788349a51586c1e8db (diff)
downloadports-b6d50ba97ecb314df107d7811aba24eb2b48f106.tar.gz
ports-b6d50ba97ecb314df107d7811aba24eb2b48f106.zip
games/sdlpop: update to 1.22
Diffstat (limited to 'games')
-rw-r--r--games/sdlpop/Makefile8
-rw-r--r--games/sdlpop/distinfo6
-rw-r--r--games/sdlpop/files/patch-seg009.c23
-rw-r--r--games/sdlpop/pkg-plist26
4 files changed, 14 insertions, 49 deletions
diff --git a/games/sdlpop/Makefile b/games/sdlpop/Makefile
index 8218f231f567..a0cfc51338a7 100644
--- a/games/sdlpop/Makefile
+++ b/games/sdlpop/Makefile
@@ -2,8 +2,7 @@
PORTNAME= sdlpop
DISTVERSIONPREFIX= v
-DISTVERSION= 1.21
-PORTREVISION= 1
+DISTVERSION= 1.22
CATEGORIES= games
MAINTAINER= pkubaj@FreeBSD.org
@@ -22,9 +21,11 @@ GH_ACCOUNT= NagyD
GH_PROJECT= SDLPoP
WRKSRC_SUBDIR= src
-USE_SDL= sdl2 image2 mixer2
+USE_SDL= image2 mixer2 sdl2
PORTDOCS= *
+CFLAGS+= -I${LOCALBASE}/include/SDL2
+
DESKTOP_ENTRIES= "Prince" "Open-Source port of Prince of Persia" \
"${DATADIR}/icon.png" "prince" "Game;" false
@@ -38,7 +39,6 @@ do-install:
${MKDIR} ${STAGEDIR}${DOCSDIR} ${STAGEDIR}${DATADIR}
cd ${WRKSRC}/../data ; ${COPYTREE_SHARE} . ${STAGEDIR}${DATADIR}
${INSTALL_DATA} \
- ${WRKSRC}/../doc/bugs.txt \
${WRKSRC}/../doc/ChangeLog.txt \
${WRKSRC}/../doc/mod.ini \
${WRKSRC}/../doc/Readme.txt \
diff --git a/games/sdlpop/distinfo b/games/sdlpop/distinfo
index 5bc3de676d91..6ac94b0129b9 100644
--- a/games/sdlpop/distinfo
+++ b/games/sdlpop/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1598089373
-SHA256 (NagyD-SDLPoP-v1.21_GH0.tar.gz) = 2d3111bd92f39a6ee203194cf058f59c9774b5cb38437ff245dfc876930d0f95
-SIZE (NagyD-SDLPoP-v1.21_GH0.tar.gz) = 627853
+TIMESTAMP = 1625576911
+SHA256 (NagyD-SDLPoP-v1.22_GH0.tar.gz) = 1af170f7f6def61b2ab9c3a9227feca335461d224faa99f3578fc09115ac505c
+SIZE (NagyD-SDLPoP-v1.22_GH0.tar.gz) = 633128
diff --git a/games/sdlpop/files/patch-seg009.c b/games/sdlpop/files/patch-seg009.c
index 5eeaa4a4bb9a..1c6c504014a8 100644
--- a/games/sdlpop/files/patch-seg009.c
+++ b/games/sdlpop/files/patch-seg009.c
@@ -1,6 +1,6 @@
---- seg009.c.orig 2020-08-20 18:22:40 UTC
+--- seg009.c.orig 2021-07-06 13:10:16 UTC
+++ seg009.c
-@@ -327,7 +327,7 @@ static FILE* open_dat_from_root_or_data_dir(const char
+@@ -343,7 +343,7 @@ static FILE* open_dat_from_root_or_data_dir(const char
// if failed, try if the DAT file can be opened in the data/ directory, instead of the main folder
if (fp == NULL) {
char data_path[POP_MAX_PATH];
@@ -9,7 +9,7 @@
if (!file_exists(data_path)) {
find_exe_dir();
-@@ -1949,7 +1949,7 @@ const int sound_channel = 0;
+@@ -2078,7 +2078,7 @@ const int sound_channel = 0;
const int max_sound_id = 58;
void load_sound_names() {
@@ -18,7 +18,7 @@
if (sound_names != NULL) return;
FILE* fp = fopen(names_path,"rt");
if (fp==NULL) return;
-@@ -1999,7 +1999,7 @@ sound_buffer_type* load_sound(int index) {
+@@ -2128,7 +2128,7 @@ sound_buffer_type* load_sound(int index) {
fp = fopen(filename, "rb");
}
if (fp == NULL && !skip_normal_data_files) {
@@ -27,25 +27,16 @@
fp = fopen(locate_file(filename), "rb");
}
if (fp == NULL) {
-@@ -2304,7 +2304,7 @@ void __pascal far set_gr_mode(byte grmode) {
- SDL_SetHint(SDL_HINT_WINDOWS_DISABLE_THREAD_NAMING, "1");
- #endif
- if (SDL_Init(SDL_INIT_VIDEO | SDL_INIT_TIMER | SDL_INIT_NOPARACHUTE |
-- SDL_INIT_GAMECONTROLLER | SDL_INIT_HAPTIC ) != 0) {
-+ SDL_INIT_GAMECONTROLLER) != 0) {
- sdlperror("SDL_Init");
- quit(1);
- }
-@@ -2363,7 +2363,7 @@ void __pascal far set_gr_mode(byte grmode) {
+@@ -2495,7 +2495,7 @@ void __pascal far set_gr_mode(byte grmode) {
#endif
}
- SDL_Surface* icon = IMG_Load(locate_file("data/icon.png"));
+ SDL_Surface* icon = IMG_Load(locate_file("%%DATADIR%%/icon.png"));
if (icon == NULL) {
- sdlperror("Could not load icon");
+ sdlperror("set_gr_mode: Could not load icon");
} else {
-@@ -2580,7 +2580,7 @@ void load_from_opendats_metadata(int resource_id, cons
+@@ -2754,7 +2754,7 @@ void load_from_opendats_metadata(int resource_id, cons
if (len >= 5 && filename_no_ext[len-4] == '.') {
filename_no_ext[len-4] = '\0'; // terminate, so ".DAT" is deleted from the filename
}
diff --git a/games/sdlpop/pkg-plist b/games/sdlpop/pkg-plist
index e62ab6def348..6ae2f5a539e9 100644
--- a/games/sdlpop/pkg-plist
+++ b/games/sdlpop/pkg-plist
@@ -1023,31 +1023,5 @@ bin/prince
%%DATADIR%%/font/res1130.png
%%DATADIR%%/font/res1131.png
%%DATADIR%%/icon.png
-%%DATADIR%%/levels-original/res2000.bin
-%%DATADIR%%/levels-original/res2001.bin
-%%DATADIR%%/levels-original/res2002.bin
-%%DATADIR%%/levels-original/res2003.bin
-%%DATADIR%%/levels-original/res2004.bin
-%%DATADIR%%/levels-original/res2005.bin
-%%DATADIR%%/levels-original/res2006.bin
-%%DATADIR%%/levels-original/res2007.bin
-%%DATADIR%%/levels-original/res2008.bin
-%%DATADIR%%/levels-original/res2009.bin
-%%DATADIR%%/levels-original/res2010.bin
-%%DATADIR%%/levels-original/res2011.bin
-%%DATADIR%%/levels-original/res2012.bin
-%%DATADIR%%/levels-original/res2013.bin
-%%DATADIR%%/levels-original/res2014.bin
-%%DATADIR%%/levels-original/res2015.bin
-%%DATADIR%%/levels-test/01-micro-room-change
-%%DATADIR%%/levels-test/01-weird-room-change
-%%DATADIR%%/levels-test/02-bigpillar-climb
-%%DATADIR%%/levels-test/02-guard-following
-%%DATADIR%%/levels-test/02-random-broken
-%%DATADIR%%/levels-test/02-walls
-%%DATADIR%%/levels-test/04-through-tapestry
-%%DATADIR%%/levels-test/05-stacked-gates
-%%DATADIR%%/levels-test/07-jump
-%%DATADIR%%/levels-test/12-shadow
%%DATADIR%%/light.png
%%DATADIR%%/music/names.txt