aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorCharlie Li <vishwin@FreeBSD.org>2021-06-03 16:32:30 +0000
committerCharlie Li <vishwin@FreeBSD.org>2021-06-05 16:03:20 +0000
commitb8394a686a11eb4a6004d3aa98c52b1a7b591f76 (patch)
tree0303db2d9ce04625f2e663f033b7b78734ad486f /games
parentac8840eda6ec5bf027dec9260a2d3ffd75255c45 (diff)
downloadports-b8394a686a11eb4a6004d3aa98c52b1a7b591f76.tar.gz
ports-b8394a686a11eb4a6004d3aa98c52b1a7b591f76.zip
games/libmanette: new port
Simple GObject game controller library This is a new dependency to update games/gnome-games, particularly games/quadrapassel to 40 (required) and www/webkit2-gtk3 to 2.32 (optional, enabled by default) Reviewed by: nc Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D30628
Diffstat (limited to 'games')
-rw-r--r--games/Makefile1
-rw-r--r--games/libmanette/Makefile32
-rw-r--r--games/libmanette/distinfo3
-rw-r--r--games/libmanette/pkg-descr13
-rw-r--r--games/libmanette/pkg-plist35
5 files changed, 84 insertions, 0 deletions
diff --git a/games/Makefile b/games/Makefile
index 7c080e4dc7b9..e25d1c93fb35 100644
--- a/games/Makefile
+++ b/games/Makefile
@@ -472,6 +472,7 @@
SUBDIR += libkmahjongg
SUBDIR += liblcf
SUBDIR += libmaitretarot
+ SUBDIR += libmanette
SUBDIR += libmt_client
SUBDIR += libretro
SUBDIR += libretro-2048
diff --git a/games/libmanette/Makefile b/games/libmanette/Makefile
new file mode 100644
index 000000000000..0acb22c2ebda
--- /dev/null
+++ b/games/libmanette/Makefile
@@ -0,0 +1,32 @@
+PORTNAME= libmanette
+DISTVERSION= 0.2.6
+CATEGORIES= games gnome
+MASTER_SITES= GNOME
+DIST_SUBDIR= gnome
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= Simple GObject game controller library
+
+LICENSE= LGPL21
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+BUILD_DEPENDS= vapigen:lang/vala \
+ evdev-proto>0:devel/evdev-proto
+LIB_DEPENDS= libevdev.so:devel/libevdev \
+ libgudev-1.0.so:devel/libgudev
+
+USES= gnome meson pkgconfig tar:xz
+USE_GNOME= glib20 introspection
+USE_LDCONFIG= yes
+
+MESON_ARGS= -Dgudev=enabled
+
+OPTIONS_DEFINE= DOCS EXAMPLES TEST
+OPTIONS_SUB= yes
+
+DOCS_BUILD_DEPENDS= gtkdocize:textproc/gtk-doc
+DOCS_MESON_TRUE= doc
+EXAMPLES_MESON_TRUE= demos
+TEST_MESON_TRUE= build-tests
+
+.include <bsd.port.mk>
diff --git a/games/libmanette/distinfo b/games/libmanette/distinfo
new file mode 100644
index 000000000000..a493d5e36199
--- /dev/null
+++ b/games/libmanette/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1620989598
+SHA256 (gnome/libmanette-0.2.6.tar.xz) = 63653259a821ec7d90d681e52e757e2219d462828c9d74b056a5f53267636bac
+SIZE (gnome/libmanette-0.2.6.tar.xz) = 43236
diff --git a/games/libmanette/pkg-descr b/games/libmanette/pkg-descr
new file mode 100644
index 000000000000..4f9aafd3780e
--- /dev/null
+++ b/games/libmanette/pkg-descr
@@ -0,0 +1,13 @@
+libmanette offers painless access to game controllers, from any
+programming language and with little dependencies.
+
+It supports the de-facto standard gamepad, as defined by the W3C
+standard gamepad specification or as implemented by the SDL
+GameController. Convertion of raw gamepad events into usable ones
+is handled transparently using an embedded library of mappings in
+the popular SDL mapping string format.
+
+The API is inspired by the device and event handling of GDK, so
+anybody used to GTK should feel right at home.
+
+WWW: https://gnome.pages.gitlab.gnome.org/libmanette/
diff --git a/games/libmanette/pkg-plist b/games/libmanette/pkg-plist
new file mode 100644
index 000000000000..e87dfd7d8005
--- /dev/null
+++ b/games/libmanette/pkg-plist
@@ -0,0 +1,35 @@
+%%EXAMPLES%%bin/manette-test
+include/libmanette/libmanette.h
+include/libmanette/manette-device.h
+include/libmanette/manette-event.h
+include/libmanette/manette-monitor-iter.h
+include/libmanette/manette-monitor.h
+include/libmanette/manette-version.h
+lib/girepository-1.0/Manette-0.2.typelib
+lib/libmanette-0.2.so
+lib/libmanette-0.2.so.0
+libdata/pkgconfig/manette-0.2.pc
+share/gir-1.0/Manette-0.2.gir
+%%DOCS%%share/gtk-doc/html/manette/ManetteDevice.html
+%%DOCS%%share/gtk-doc/html/manette/ManetteEvent.html
+%%DOCS%%share/gtk-doc/html/manette/ManetteMonitor.html
+%%DOCS%%share/gtk-doc/html/manette/ManetteMonitorIter.html
+%%DOCS%%share/gtk-doc/html/manette/annotations-glossary.html
+%%DOCS%%share/gtk-doc/html/manette/api-index-full.html
+%%DOCS%%share/gtk-doc/html/manette/core-api.html
+%%DOCS%%share/gtk-doc/html/manette/deprecated-api-index.html
+%%DOCS%%share/gtk-doc/html/manette/home.png
+%%DOCS%%share/gtk-doc/html/manette/index.html
+%%DOCS%%share/gtk-doc/html/manette/left-insensitive.png
+%%DOCS%%share/gtk-doc/html/manette/left.png
+%%DOCS%%share/gtk-doc/html/manette/manette-Version.html
+%%DOCS%%share/gtk-doc/html/manette/manette.devhelp2
+%%DOCS%%share/gtk-doc/html/manette/object-tree.html
+%%DOCS%%share/gtk-doc/html/manette/overview.html
+%%DOCS%%share/gtk-doc/html/manette/right-insensitive.png
+%%DOCS%%share/gtk-doc/html/manette/right.png
+%%DOCS%%share/gtk-doc/html/manette/style.css
+%%DOCS%%share/gtk-doc/html/manette/up-insensitive.png
+%%DOCS%%share/gtk-doc/html/manette/up.png
+share/vala/vapi/manette-0.2.deps
+share/vala/vapi/manette-0.2.vapi