aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorNeel Chauhan <nc@FreeBSD.org>2021-03-13 18:48:32 +0000
committerNeel Chauhan <nc@FreeBSD.org>2021-03-13 18:48:32 +0000
commitcac34704997c442a034779128ada4e4d5568d755 (patch)
tree96cd7a1b6c0113221e6e7465cfa759882af0d9ad /games
parent714ed99cb0e299aa15f3abf1af0a06e78e9a9cbe (diff)
downloadports-cac34704997c442a034779128ada4e4d5568d755.tar.gz
ports-cac34704997c442a034779128ada4e4d5568d755.zip
games/xqf: Update to 1.0.6.2
Notes
Notes: svn path=/head/; revision=568270
Diffstat (limited to 'games')
-rw-r--r--games/xqf/Makefile10
-rw-r--r--games/xqf/distinfo5
-rw-r--r--games/xqf/files/patch-src-debug.h11
-rw-r--r--games/xqf/files/patch-src__country-filter.h6
-rw-r--r--games/xqf/files/patch-src__trayicon.c39
-rw-r--r--games/xqf/files/patch-src_filter.c4
-rw-r--r--games/xqf/files/patch-src_filter.h6
-rw-r--r--games/xqf/pkg-plist5
8 files changed, 40 insertions, 46 deletions
diff --git a/games/xqf/Makefile b/games/xqf/Makefile
index 507b0d9c4060..d8315b9d03df 100644
--- a/games/xqf/Makefile
+++ b/games/xqf/Makefile
@@ -2,21 +2,23 @@
# $FreeBSD$
PORTNAME= xqf
-PORTVERSION= 1.0.5
-PORTREVISION= 11
+PORTVERSION= 1.0.6.2
+DISTVERSIONPREFIX= ${PORTNAME}-
CATEGORIES= games
-MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${DISTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= Server browser for many popular 3D action games
RUN_DEPENDS= qstat:games/qstat
-USES= gettext gmake gnome pkgconfig xorg
+USES= autoreconf gettext gmake gnome pkgconfig xorg
USE_GNOME= intlhack
USE_XORG= x11
GNU_CONFIGURE= yes
+USE_GITHUB= yes
+GH_ACCOUNT= XQF
+
CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib -lX11
diff --git a/games/xqf/distinfo b/games/xqf/distinfo
index 0820bcab361e..0642f555fa71 100644
--- a/games/xqf/distinfo
+++ b/games/xqf/distinfo
@@ -1,2 +1,3 @@
-SHA256 (xqf-1.0.5.tar.gz) = ee0ab9a40516c55d9f00e65ab06b1c6669f0de858bc8a7416e6993a76c0d9b67
-SIZE (xqf-1.0.5.tar.gz) = 742183
+TIMESTAMP = 1615661122
+SHA256 (XQF-xqf-xqf-1.0.6.2_GH0.tar.gz) = bcfb87c9a452993b13bd1019b0c61459a37cbc37b13b951b73f2a93b2b1c83ad
+SIZE (XQF-xqf-xqf-1.0.6.2_GH0.tar.gz) = 595096
diff --git a/games/xqf/files/patch-src-debug.h b/games/xqf/files/patch-src-debug.h
deleted file mode 100644
index f51ac529a29d..000000000000
--- a/games/xqf/files/patch-src-debug.h
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/debug.h.orig 2004-01-01 15:41:10.000000000 +0300
-+++ src/debug.h 2009-03-25 22:03:41.000000000 +0300
-@@ -37,7 +37,7 @@
- void debug_int(const char* file, int line, const char* function, int level, const char* fmt, ...);
- void debug_cmd(int, char *[], char *, ...);
- void set_debug_level (int);
--inline int get_debug_level (void);
-+int get_debug_level (void);
-
- int debug_increase_indent(void);
- int debug_decrease_indent(void);
diff --git a/games/xqf/files/patch-src__country-filter.h b/games/xqf/files/patch-src__country-filter.h
index e222f14994b6..828dd7db4cd5 100644
--- a/games/xqf/files/patch-src__country-filter.h
+++ b/games/xqf/files/patch-src__country-filter.h
@@ -1,5 +1,5 @@
---- src/country-filter.h.orig Sun Oct 5 21:53:51 2003
-+++ src/country-filter.h Fri Nov 28 11:11:26 2003
+--- src/country-filter.h.orig 2014-11-02 00:43:18 UTC
++++ src/country-filter.h
@@ -22,6 +22,9 @@
#include <glib.h>
@@ -9,4 +9,4 @@
+#include <netinet/in.h>
#include <arpa/inet.h>
- extern const unsigned MaxCountries;
+ extern unsigned MaxCountries;
diff --git a/games/xqf/files/patch-src__trayicon.c b/games/xqf/files/patch-src__trayicon.c
index 2914e135011a..040703fa3c6c 100644
--- a/games/xqf/files/patch-src__trayicon.c
+++ b/games/xqf/files/patch-src__trayicon.c
@@ -1,20 +1,19 @@
---- src/trayicon.c.orig Sun Jun 20 03:30:35 2004
-+++ src/trayicon.c Wed Dec 1 07:16:59 2004
-@@ -792,6 +792,8 @@
- }
- } else {
-
-+ GdkWindow *gdkwin;
-+
- icon->box=gtk_event_box_new ();
- gtk_container_add(GTK_CONTAINER(icon), icon->box);
-
-@@ -801,8 +803,6 @@
-
- gtk_widget_show (icon->image);
- gtk_widget_show(icon->box);
--
-- GdkWindow *gdkwin;
-
- gdkwin = gdk_window_lookup (icon->manager_window);
- gdk_window_add_filter (gdkwin, egg_tray_icon_manager_filter, icon);
+--- src/trayicon.c.orig 2014-11-02 00:43:18 UTC
++++ src/trayicon.c
+@@ -726,6 +726,7 @@ static void egg_tray_icon_update_manager_window (EggTr
+ icon->ready=TRUE;
+ }
+ } else {
++ GdkWindow *gdkwin;
+
+ icon->box=gtk_event_box_new ();
+ gtk_container_add(GTK_CONTAINER(icon), icon->box);
+@@ -736,8 +737,6 @@ static void egg_tray_icon_update_manager_window (EggTr
+
+ gtk_widget_show (icon->image);
+ gtk_widget_show(icon->box);
+-
+- GdkWindow *gdkwin;
+
+ gdkwin = gdk_window_lookup (icon->manager_window);
+ gdk_window_add_filter (gdkwin, egg_tray_icon_manager_filter, icon);
diff --git a/games/xqf/files/patch-src_filter.c b/games/xqf/files/patch-src_filter.c
index 76ca2170b663..81fd064ce7b9 100644
--- a/games/xqf/files/patch-src_filter.c
+++ b/games/xqf/files/patch-src_filter.c
@@ -1,6 +1,6 @@
---- src/filter.c.orig 2005-08-14 11:01:59 UTC
+--- src/filter.c.orig 2014-11-02 00:43:18 UTC
+++ src/filter.c
-@@ -144,6 +144,7 @@ static unsigned filter_current_time = 1;
+@@ -142,6 +142,7 @@ static unsigned filter_current_time = 1;
unsigned server_filter_dialog_current_filter = 0;
diff --git a/games/xqf/files/patch-src_filter.h b/games/xqf/files/patch-src_filter.h
index 48384ee3ab3f..98c28df52651 100644
--- a/games/xqf/files/patch-src_filter.h
+++ b/games/xqf/files/patch-src_filter.h
@@ -1,10 +1,10 @@
---- src/filter.h.orig 2004-07-24 20:32:39 UTC
+--- src/filter.h.orig 2014-11-02 00:43:18 UTC
+++ src/filter.h
-@@ -89,7 +89,6 @@ extern unsigned char cur_filter;
+@@ -89,7 +89,6 @@ extern unsigned char cur_filter;
extern GArray* server_filters;
--unsigned int current_server_filter;
+-unsigned int current_server_filter;
extern unsigned int current_server_filter;
diff --git a/games/xqf/pkg-plist b/games/xqf/pkg-plist
index c23213697108..8185245675dd 100644
--- a/games/xqf/pkg-plist
+++ b/games/xqf/pkg-plist
@@ -9,8 +9,11 @@ share/locale/fr/LC_MESSAGES/xqf.mo
share/locale/pl/LC_MESSAGES/xqf.mo
share/locale/ru/LC_MESSAGES/xqf.mo
share/applications/xqf.desktop
+share/pixmaps/xqf.png
+share/pixmaps/xqf.svg
+share/pixmaps/xqf.xpm
share/pixmaps/xqf_22x22.png
share/pixmaps/xqf_32x32.png
share/pixmaps/xqf_48x48.png
share/pixmaps/xqf_48x48_2.png
-@dir lib/xqf
+@dir libexec/xqf