aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2021-06-04 05:53:21 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2021-06-04 05:53:21 +0000
commitd09ed096c44ca516f3e4922e292b4afabd03ff11 (patch)
tree8472e59ca02578120ca7b8bc5e2af50d2954440e /games
parent31a195fb72446a7d02336b8fa1b9c1e0032f95cb (diff)
downloadports-d09ed096c44ca516f3e4922e292b4afabd03ff11.tar.gz
ports-d09ed096c44ca516f3e4922e292b4afabd03ff11.zip
*/*: Replace USE_GCC=any with USE_GCC=yes
USE_GCC=any has been equivalent to USE_GCC=yes in most cases (such as i386 and amd64 since 12.x and depending on configuration 11.x, most newer installations on other platforms, and 13.x across the board). Since commit 96c17633d90386b5bcf8 Mk/bsd.gcc.mk is treating them as different spellings of the same, so continue the deorbiting of the USE_GCC=any form and simply replace it with USE_GCC=yes. This should not make any functional difference at all. Discussed with: mat, linimon, pkubaj
Diffstat (limited to 'games')
-rw-r--r--games/mirrormagic/Makefile2
-rw-r--r--games/shaaft/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/games/mirrormagic/Makefile b/games/mirrormagic/Makefile
index 925d210251a1..ede639c69356 100644
--- a/games/mirrormagic/Makefile
+++ b/games/mirrormagic/Makefile
@@ -16,7 +16,7 @@ USES= gmake
MAKE_ARGS= CC="${CC}" MAKE="${MAKE_CMD}" OPTIONS="${CFLAGS}" \
RO_GAME_DIR="${DATADIR}" RW_GAME_DIR="${DATADIR}/scores" \
X11_PATH="${LOCALBASE}"
-USE_GCC= any # doesn't start otherwise (UB?)
+USE_GCC= yes # doesn't start otherwise (UB?)
PORTDATA= *
PORTDOCS= *
diff --git a/games/shaaft/Makefile b/games/shaaft/Makefile
index f35903c651c4..574369fdc632 100644
--- a/games/shaaft/Makefile
+++ b/games/shaaft/Makefile
@@ -17,7 +17,7 @@ CONFLICTS= criticalmass-*
USES= gl sdl tar:bzip2
USE_SDL= mixer image sdl
USE_GL= gl
-USE_GCC= any
+USE_GCC= yes
USE_CXXSTD= gnu++98
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-optimize