aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2019-04-26 18:29:40 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2019-04-26 18:29:40 +0000
commitd0b488c23f5083266645a90c6dffe8368f91d445 (patch)
treebe0ec0ee9acb3b75fc788c9f0ffbf6d2321e2313 /games
parentd15e43036bcdcfff4e956f7e95f1112617530237 (diff)
downloadports-d0b488c23f5083266645a90c6dffe8368f91d445.tar.gz
ports-d0b488c23f5083266645a90c6dffe8368f91d445.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/redeclipse/Makefile2
-rw-r--r--games/redeclipse/files/patch-config_setup.cfg29
2 files changed, 31 insertions, 0 deletions
diff --git a/games/redeclipse/Makefile b/games/redeclipse/Makefile
index d3f2f50435ca..fde193763244 100644
--- a/games/redeclipse/Makefile
+++ b/games/redeclipse/Makefile
@@ -4,6 +4,7 @@
PORTNAME= redeclipse
PORTVERSION= 1.6.0
DISTVERSIONPREFIX= v
+PORTREVISION= 1
CATEGORIES= games
MAINTAINER= amdmi3@FreeBSD.org
@@ -34,6 +35,7 @@ OPTIONS_MULTI_COMPONENTS=CLIENT DEDICATED
OPTIONS_DEFAULT= CLIENT DEDICATED OPTIMIZED_CFLAGS
CLIENT_DESC= Build client
+CLIENT_USES= gl sdl
CLIENT_USE= GL=gl SDL=image2,mixer2,sdl2 XORG=x11
CLIENT_ALL_TARGET= client
CLIENT_PLIST_FILES= bin/${PORTNAME} libexec/${PORTNAME} \
diff --git a/games/redeclipse/files/patch-config_setup.cfg b/games/redeclipse/files/patch-config_setup.cfg
new file mode 100644
index 000000000000..4f8ad12418d3
--- /dev/null
+++ b/games/redeclipse/files/patch-config_setup.cfg
@@ -0,0 +1,29 @@
+Upstream commits ec1e32e1410f51c336e893ecfb56f728fdcc1a92,
+bb4b6862f802c040ef67484942e91f7c3d88e649: fix hiding HUD
+permanently when HUDless screenshot is taken.
+diff --git config/setup.cfg config/setup.cfg
+index 4edcf170..e6888f81 100644
+--- config/setup.cfg
++++ config/setup.cfg
+@@ -316,9 +316,19 @@ dobindsearch = [
+ [search@[arg2]binds] $arg1 5 "^f{" "}" (? $textkeyseps (? $textkeyimages "|" ", ") (? $textkeyimages "" " ")) (? $textkeyseps (? $textkeyimages "|" " or ") (? $textkeyimages "" " "))
+ ]
+
++// screenshotnohud: Takes a screenshot without a hud
++// The screenshot and the hud showing are delayed to prevent any issues since
++// the game skips a few frames while taking a screenshot.
++canscreenshotnohud = 1
+ screenshotnohud = [
+- sleep 50 [ screenshot; showhud @showhud ]
+- showhud 0
++ if $canscreenshotnohud [
++ canscreenshotnohud = 0 // Lock screenshotting without a hud for the 50ms duration
++ hudwasshown = $showhud // Previous $showhud state
++ if $hudwasshown [showhud 0] // Hide hud if it was shown
++ sleep 25 [screenshot]
++ // Restore hud if it was shown and restore screenshotting.
++ sleep 50 [showhud $hudwasshown; canscreenshotnohud = 1]
++ ]
+ ]
+
+ listcomplete vdelta [