aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-04-08 11:00:14 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-04-13 05:59:23 +0000
commitd24b0121abfa01d0ba3f0da54b44745b93c08da9 (patch)
tree7c33ea8c537e777e84a06b4936b60eda4bf14da0 /games
parentaae00cbee1cef8d51abff5de932f7cf64c62dc87 (diff)
downloadports-d24b0121abfa01d0ba3f0da54b44745b93c08da9.tar.gz
ports-d24b0121abfa01d0ba3f0da54b44745b93c08da9.zip
games/exult: Update to 1.7.0
Diffstat (limited to 'games')
-rw-r--r--games/exult/Makefile44
-rw-r--r--games/exult/distinfo5
-rw-r--r--games/exult/files/patch-configure.ac20
-rw-r--r--games/exult/files/pkg-message.in1
-rw-r--r--games/exult/pkg-descr2
-rw-r--r--games/exult/pkg-plist63
6 files changed, 65 insertions, 70 deletions
diff --git a/games/exult/Makefile b/games/exult/Makefile
index 1592eae99b2b..29b4f1333a42 100644
--- a/games/exult/Makefile
+++ b/games/exult/Makefile
@@ -1,8 +1,7 @@
# Created by: Igor Pokrovsky <tiamat@telegraph.spb.ru>
PORTNAME= exult
-PORTVERSION= 1.5.0.20160514
-PORTREVISION= 9
+PORTVERSION= 1.7.0.20210405
CATEGORIES= games
MAINTAINER= ports@FreeBSD.org
@@ -12,50 +11,43 @@ LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libvorbis.so:audio/libvorbis \
- libpng.so:graphics/png
+ libpng.so:graphics/png \
+ libogg.so:audio/libogg \
+ libfreetype.so:print/freetype2
+
+USES= autoreconf compiler:c++11-lib gmake libtool localbase pkgconfig \
+ xorg sdl
USE_GITHUB= yes
-GH_TAGNAME= b15afba
+GH_TAGNAME= 6150ae4
-USES= autoreconf compiler:c++11-lib gmake libtool localbase pkgconfig \
- xorg
-USE_CXXSTD= c++98
-USE_XORG= xext
+USE_CXXSTD= c++17
+USE_XORG= x11 xext
+USE_SDL= mixer2
+USE_GNOME= gtk30 cairo gdkpixbuf2
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-alsa \
+CONFIGURE_ARGS= --disable-alsa --with-sdl=sdl2 \
--with-icondir=${PREFIX}/share/pixmaps
SUB_FILES= pkg-message
OPTIONS_DEFINE= DOCS FLUIDSYNTH GIMP STUDIO THUMBNAILER
-OPTIONS_SINGLE= SDL
-OPTIONS_SINGLE_SDL= SDL1 SDL2
-OPTIONS_DEFAULT= SDL1 STUDIO
+OPTIONS_DEFAULT= STUDIO
OPTIONS_SUB= yes
FLUIDSYNTH_LIB_DEPENDS= libfluidsynth.so:audio/fluidsynth
-FLUIDSYNTH_CONFIGURE_ENABLE=\
- fluidsynth
+FLUIDSYNTH_CONFIGURE_ENABLE= fluidsynth
GIMP_DESC= GIMP plugin support
GIMP_LIB_DEPENDS= libgimp-2.0.so:graphics/gimp-app
GIMP_CONFIGURE_ENABLE= gimp-plugin
-SDL1_DESC= Simple Direct Media Layer 1 support
-SDL1_USES= sdl
-SDL1_USE= sdl=mixer
-SDL1_CONFIGURE_ON= --with-sdl=sdl12
-SDL2_DESC= Simple Direct Media Layer 2 support
-SDL2_USES= sdl
-SDL2_USE= sdl=mixer2
-SDL2_CONFIGURE_ON= --with-sdl=sdl2
+
STUDIO_DESC= Install Exult Studio
-STUDIO_CONFIGURE_ENABLE=\
- exult-studio exult-studio-support
+STUDIO_CONFIGURE_ENABLE= exult-studio exult-studio-support
STUDIO_USES= gnome
STUDIO_USE= gnome=libglade2
THUMBNAILER_DESC= Gnome SHP thumbnailer support
THUMBNAILER_USES= gnome shared-mime-info
THUMBNAILER_USE= gnome=libgnomeui
-THUMBNAILER_CONFIGURE_ENABLE=\
- gnome-shp-thumbnailer
+THUMBNAILER_CONFIGURE_ENABLE= gnome-shp-thumbnailer
post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/games/exult/distinfo b/games/exult/distinfo
index 88cd8e643f06..ee5a52407a5e 100644
--- a/games/exult/distinfo
+++ b/games/exult/distinfo
@@ -1,2 +1,3 @@
-SHA256 (exult-exult-1.5.0.20160514-b15afba_GH0.tar.gz) = f517470ff132fbe114c47c996c2f8775693fca8a4a8bc3caf479ed7580d2cc2a
-SIZE (exult-exult-1.5.0.20160514-b15afba_GH0.tar.gz) = 4941781
+TIMESTAMP = 1617640860
+SHA256 (exult-exult-1.7.0.20210405-6150ae4_GH0.tar.gz) = d124a8bc548d62dfbe034496d186b87aea4f29063febe28d92d7cf7be7148bd4
+SIZE (exult-exult-1.7.0.20210405-6150ae4_GH0.tar.gz) = 18460223
diff --git a/games/exult/files/patch-configure.ac b/games/exult/files/patch-configure.ac
deleted file mode 100644
index a3094952482d..000000000000
--- a/games/exult/files/patch-configure.ac
+++ /dev/null
@@ -1,20 +0,0 @@
---- configure.ac.orig 2016-05-14 01:04:00 UTC
-+++ configure.ac
-@@ -71,7 +71,7 @@ case "$host_os" in
- WINDOWING_SYSTEM="-DXWIN"
- AC_DEFINE(NETBSD, 1, [Using NetBSD])
- AC_MSG_RESULT([X11 (FreeBSD)])
-- CXXFLAGS="$CXXFLAGS -I/usr/local/include"
-+ CXXFLAGS="$CXXFLAGS "
- ;;
- netbsd* )
- WINDOWING_SYSTEM="-DXWIN"
-@@ -665,7 +665,7 @@ if test x$enable_debug = xyes; then
- DEBUG_FLAGS="-g"
- else
- AC_MSG_RESULT(no)
-- DEBUG_FLAGS="-O2"
-+ DEBUG_FLAGS=
- fi
-
- # optimized debugging mode
diff --git a/games/exult/files/pkg-message.in b/games/exult/files/pkg-message.in
index a7dd31dd209b..6a5d128a9a77 100644
--- a/games/exult/files/pkg-message.in
+++ b/games/exult/files/pkg-message.in
@@ -1,7 +1,6 @@
[
{ type: install
message: <<EOM
- Run Exult from directory containing original Ultima VII data.
Please, read %%DOCSDIR%%/README for additional information.
EOM
}
diff --git a/games/exult/pkg-descr b/games/exult/pkg-descr
index 6c0248c1689e..13374afc307b 100644
--- a/games/exult/pkg-descr
+++ b/games/exult/pkg-descr
@@ -3,4 +3,4 @@ you can play both "The Black Gate" and "Serpent Isle" parts of the game.
However, the original ORIGIN's Ultima VII data is required as Exult is
just the engine. Refer to README file for details.
-WWW: http://exult.sourceforge.net
+WWW: http://exult.info
diff --git a/games/exult/pkg-plist b/games/exult/pkg-plist
index e8958340278a..5cecac851f81 100644
--- a/games/exult/pkg-plist
+++ b/games/exult/pkg-plist
@@ -1,12 +1,16 @@
+bin/cmanip
bin/expack
bin/exult
-%%STUDIO%%bin/exult_studio
-%%THUMBNAILER%%bin/gnome_shp_thumbnailer
+bin/exult_studio
bin/ipack
+bin/mklink
+bin/rip
bin/shp2pcx
bin/splitshp
bin/textpack
+bin/u7voice2syx
bin/ucxt
+bin/wuc
man/man1/expack.1.gz
man/man1/exult_studio.1.gz
man/man1/ipack.1.gz
@@ -15,35 +19,54 @@ man/man1/splitshp.1.gz
man/man1/textpack.1.gz
man/man1/ucc.1.gz
man/man6/exult.6.gz
-%%GIMP%%libexec/gimp/2.2/plug-ins/u7shp
share/applications/exult.desktop
%%PORTDOCS%%%%DOCSDIR%%/FAQ
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/README
-%%DATADIR%%/bg_mr_faces.vga
-%%DATADIR%%/bg_paperdol.vga
-%%STUDIO%%%%DATADIR%%/estudio/new/blends.dat
-%%STUDIO%%%%DATADIR%%/estudio/new/combos.flx
-%%STUDIO%%%%DATADIR%%/estudio/new/faces.vga
-%%STUDIO%%%%DATADIR%%/estudio/new/fonts.vga
-%%STUDIO%%%%DATADIR%%/estudio/new/gumps.vga
-%%STUDIO%%%%DATADIR%%/estudio/new/palettes.flx
-%%STUDIO%%%%DATADIR%%/estudio/new/paperdol.vga
-%%STUDIO%%%%DATADIR%%/estudio/new/pointers.shp
-%%STUDIO%%%%DATADIR%%/estudio/new/shapes.vga
-%%STUDIO%%%%DATADIR%%/estudio/new/sprites.vga
-%%STUDIO%%%%DATADIR%%/estudio/new/text.flx
+%%PORTDOCS%%%%DOCSDIR%%/ReadMe.html
+%%PORTDOCS%%%%DOCSDIR%%/exult_studio.html
+%%PORTDOCS%%%%DOCSDIR%%/faq.html
+%%PORTDOCS%%%%DOCSDIR%%/images/back.gif
+%%PORTDOCS%%%%DOCSDIR%%/images/docs01.png
+%%PORTDOCS%%%%DOCSDIR%%/images/docs02.png
+%%PORTDOCS%%%%DOCSDIR%%/images/docs03.png
+%%PORTDOCS%%%%DOCSDIR%%/images/docs04.png
+%%PORTDOCS%%%%DOCSDIR%%/images/docs05.png
+%%PORTDOCS%%%%DOCSDIR%%/images/docs06.png
+%%PORTDOCS%%%%DOCSDIR%%/images/exult_logo.gif
+%%PORTDOCS%%%%DOCSDIR%%/images/studio01.png
+%%PORTDOCS%%%%DOCSDIR%%/images/studio02.png
+%%PORTDOCS%%%%DOCSDIR%%/images/studio03.png
+%%PORTDOCS%%%%DOCSDIR%%/images/studio04.png
+%%PORTDOCS%%%%DOCSDIR%%/images/studio05.png
+%%PORTDOCS%%%%DOCSDIR%%/images/studio06.png
+%%PORTDOCS%%%%DOCSDIR%%/images/studio07.png
+%%PORTDOCS%%%%DOCSDIR%%/images/studio08.png
+%%PORTDOCS%%%%DOCSDIR%%/images/studio09.png
+%%PORTDOCS%%%%DOCSDIR%%/images/studio10.png
+%%PORTDOCS%%%%DOCSDIR%%/images/studiobgiregs.png
+%%PORTDOCS%%%%DOCSDIR%%/images/studiosiiregs.png
+%%DATADIR%%/estudio/new/avatar_data.txt
+%%DATADIR%%/estudio/new/blends.dat
+%%DATADIR%%/estudio/new/combos.flx
+%%DATADIR%%/estudio/new/faces.vga
+%%DATADIR%%/estudio/new/fonts.vga
+%%DATADIR%%/estudio/new/gumps.vga
+%%DATADIR%%/estudio/new/palettes.flx
+%%DATADIR%%/estudio/new/paperdol.vga
+%%DATADIR%%/estudio/new/pointers.shp
+%%DATADIR%%/estudio/new/shapes.vga
+%%DATADIR%%/estudio/new/sprites.vga
+%%DATADIR%%/estudio/new/text.flx
%%DATADIR%%/exult.flx
%%DATADIR%%/exult_bg.flx
-%%DATADIR%%/exult_iphone.flx
%%DATADIR%%/exult_si.flx
-%%STUDIO%%%%DATADIR%%/exult_studio.glade
+%%DATADIR%%/exult_studio.glade
%%DATADIR%%/exultmsg.txt
%%DATADIR%%/midisfx.flx
%%DATADIR%%/u7bgintrinsics.data
%%DATADIR%%/u7misc.data
%%DATADIR%%/u7opcodes.data
+%%DATADIR%%/u7sibetaintrinsics.data
%%DATADIR%%/u7siintrinsics.data
-%%THUMBNAILER%%share/mime/packages/x-shapefile.xml
share/pixmaps/exult.png
-%%THUMBNAILER%%share/thumbnailers/gnome_u7shapes.thumbnailer