aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorMaxim Sobolev <sobomax@FreeBSD.org>2001-01-26 16:55:46 +0000
committerMaxim Sobolev <sobomax@FreeBSD.org>2001-01-26 16:55:46 +0000
commitd33af9f4f4d98011086e142f1630d939fa5e52ad (patch)
treec6911afa020e855f3213af3eae8425a844a29ee4 /games
parent543d2d37a0216a7b3e10eb3d482d79a7028bc7ba (diff)
downloadports-d33af9f4f4d98011086e142f1630d939fa5e52ad.tar.gz
ports-d33af9f4f4d98011086e142f1630d939fa5e52ad.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/quakeforge/Makefile8
-rw-r--r--games/quakeforge/files/patch-ab16
-rw-r--r--games/quakeforge/files/patch-common_cd__sdl.c14
-rw-r--r--games/quakeforge/files/patch-common_vid__sdl.c14
4 files changed, 47 insertions, 5 deletions
diff --git a/games/quakeforge/Makefile b/games/quakeforge/Makefile
index 6858a33eb7fb..2aa727ad9547 100644
--- a/games/quakeforge/Makefile
+++ b/games/quakeforge/Makefile
@@ -22,6 +22,8 @@ BUILD_DEPENDS= aclocal:${PORTSDIR}/devel/automake
LIB_DEPENDS= SDL-1.0.2:${PORTSDIR}/devel/sdl \
${GL_DEPENDS}
+SDL_CONFIG?= ${LOCALBASE}/bin/sdl-config
+
WADFILE= quakesw-1.0.6.tar.gz
USE_BZIP2= yes
USE_GMAKE= yes
@@ -32,9 +34,9 @@ AUTOCONF= ${WRKSRC}/bootstrap
BINARIES= quake-x11 quake-sdl qw-client-x11 qw-client-sdl qw-server
-CONFIGURE_ARGS= "--with-sdl=${LOCALBASE}"
-CONFIGURE_ENV= "SDL_LIBS=`sdl-config --libs`" \
- "SDL_CFLAGS=`sdl-config --cflags`"
+CONFIGURE_ARGS= "--with-sdl=${LOCALBASE}"
+CONFIGURE_ENV= "SDL_LIBS=`${SDL_CONFIG} --libs`" \
+ "SDL_CFLAGS=`${SDL_CONFIG} --cflags`"
.if defined(WITH_GLX)
GL_DEPENDS= GL.1:${PORTSDIR}/graphics/utah-glx
diff --git a/games/quakeforge/files/patch-ab b/games/quakeforge/files/patch-ab
index d34e5eafa190..3a94eff219a5 100644
--- a/games/quakeforge/files/patch-ab
+++ b/games/quakeforge/files/patch-ab
@@ -1,5 +1,17 @@
---- configure.in.orig Thu Mar 30 17:32:37 2000
-+++ configure.in Thu Mar 30 17:32:45 2000
+
+$FreeBSD$
+
+--- configure.in.orig Sun Feb 27 13:26:03 2000
++++ configure.in Wed Jan 24 23:42:29 2001
+@@ -210,7 +210,7 @@
+ fi
+ save_CPPFLAGS="$CPPFLAGS"
+ CPPFLAGS="$CPPFLAGS $SDL_CFLAGS"
+- AC_CHECK_HEADER(SDL/SDL.h, HAS_SDL=yes, HAS_SDL=no)
++ AC_CHECK_HEADER(SDL.h, HAS_SDL=yes, HAS_SDL=no)
+ CPPFLAGS="$save_CPPFLAGS"
+ fi
+
@@ -335,7 +335,7 @@
dnl Make sure -lpthread works (for SDL)
if test "x$HAS_SDL" = xyes; then
diff --git a/games/quakeforge/files/patch-common_cd__sdl.c b/games/quakeforge/files/patch-common_cd__sdl.c
new file mode 100644
index 000000000000..4936a2d47ad6
--- /dev/null
+++ b/games/quakeforge/files/patch-common_cd__sdl.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- common/cd_sdl.c 2001/01/24 21:40:56 1.1
++++ common/cd_sdl.c 2001/01/24 21:41:17
+@@ -24,7 +24,7 @@
+ // of podged this together from the SDL headers, and the other cd-rom code.
+ // -- Mark Baker <homer1@together.net>
+
+-#include <SDL/SDL.h>
++#include <SDL.h>
+
+ #include "quakedef.h"
+
diff --git a/games/quakeforge/files/patch-common_vid__sdl.c b/games/quakeforge/files/patch-common_vid__sdl.c
new file mode 100644
index 000000000000..ade3933985e5
--- /dev/null
+++ b/games/quakeforge/files/patch-common_vid__sdl.c
@@ -0,0 +1,14 @@
+
+$FreeBSD$
+
+--- common/vid_sdl.c 2001/01/24 21:40:56 1.1
++++ common/vid_sdl.c 2001/01/24 21:41:25
+@@ -21,7 +21,7 @@
+ */
+ // vid_sdl.h -- sdl video driver
+
+-#include <SDL/SDL.h>
++#include <SDL.h>
+ #include "quakedef.h"
+ #include "d_local.h"
+