aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2007-01-13 03:57:25 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2007-01-13 03:57:25 +0000
commitd7f59ea8de230bb289b02649cd575560e4c71e0d (patch)
treeeae797f7211f5c20b5be446f4fa649681b374597 /games
parent3aa9b484131b5835a7875ba57cac901593286b35 (diff)
downloadports-d7f59ea8de230bb289b02649cd575560e4c71e0d.tar.gz
ports-d7f59ea8de230bb289b02649cd575560e4c71e0d.zip
- update to use new bsd.gnustep.mk
Approved by: gurkan@linuks.mine.nu
Notes
Notes: svn path=/head/; revision=182275
Diffstat (limited to 'games')
-rw-r--r--games/gmastermind/Makefile2
-rw-r--r--games/gmines/Makefile3
-rw-r--r--games/gnustep-ladder/Makefile9
-rw-r--r--games/gomoku.app/Makefile2
-rw-r--r--games/gpuzzle/Makefile2
-rw-r--r--games/gridlock/Makefile7
-rw-r--r--games/grubik/Makefile3
-rw-r--r--games/gshisen/Makefile4
-rw-r--r--games/jigsaw/Makefile2
-rw-r--r--games/lapispuzzle/Makefile7
-rw-r--r--games/nextgo/Makefile2
-rw-r--r--games/stepbill/Makefile7
12 files changed, 14 insertions, 36 deletions
diff --git a/games/gmastermind/Makefile b/games/gmastermind/Makefile
index c7ca1355c8c9..fbf2529fe2a0 100644
--- a/games/gmastermind/Makefile
+++ b/games/gmastermind/Makefile
@@ -15,12 +15,10 @@ EXTRACT_SUFX= .tgz
MAINTAINER= dinoex@FreeBSD.org
COMMENT= The well-known mastermind game
-USE_GMAKE= yes
USE_GNUSTEP= yes
USE_GNUSTEP_PREFIX= yes
USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
-MAKEFILE=
.include <bsd.port.mk>
diff --git a/games/gmines/Makefile b/games/gmines/Makefile
index 4ed7584ced52..6680360f8af1 100644
--- a/games/gmines/Makefile
+++ b/games/gmines/Makefile
@@ -15,13 +15,10 @@ EXTRACT_SUFX= .tgz
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Well-known minesweeper game for GNUstep
-USE_GMAKE= yes
USE_GNUSTEP= yes
USE_GNUSTEP_PREFIX= yes
USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
-MAKEFILE=
-ALL_TARGET=
.include <bsd.port.mk>
diff --git a/games/gnustep-ladder/Makefile b/games/gnustep-ladder/Makefile
index 26c392ff2fe6..2f8c6b637139 100644
--- a/games/gnustep-ladder/Makefile
+++ b/games/gnustep-ladder/Makefile
@@ -1,4 +1,4 @@
-# New ports collection makefile for: ladder.app
+# New ports collection makefile for: ladder
# Date created: 11 Sep 2006
# Whom: gurkan@linuks.mine.nu
#
@@ -9,7 +9,7 @@ PORTNAME= ladder
PORTVERSION= 1.0
CATEGORIES= games
MASTER_SITES= http://download.savannah.gnu.org/releases/gap/ \
- http://io.debian.net/~tar/ports/distfiles/
+ ${MASTER_SITE_GNUSTEP_CH}
PKGNAMEPREFIX= gnustep-
DISTNAME= Ladder-${PORTVERSION}
@@ -18,13 +18,12 @@ COMMENT= GNU Go frontend for GNUstep
RUN_DEPENDS= gnugo:${PORTSDIR}/games/gnugo
-WRKSRC= ${WRKDIR}/${DISTNAME}
-USE_GMAKE= yes
USE_GNUSTEP= yes
USE_GNUSTEP_PREFIX= yes
USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
-MAKEFILE= GNUmakefile
+
+WRKSRC= ${WRKDIR}/${DISTNAME}
.include <bsd.port.mk>
diff --git a/games/gomoku.app/Makefile b/games/gomoku.app/Makefile
index c2f2fda7876c..99d272ebd7ee 100644
--- a/games/gomoku.app/Makefile
+++ b/games/gomoku.app/Makefile
@@ -14,12 +14,10 @@ DISTNAME= Gomoku-${PORTVERSION}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= GNUstep Gomoku game
-USE_GMAKE= yes
USE_GNUSTEP= yes
USE_GNUSTEP_PREFIX= yes
USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
-MAKEFILE= GNUmakefile
.include <bsd.port.mk>
diff --git a/games/gpuzzle/Makefile b/games/gpuzzle/Makefile
index 627723545b92..180752eb6977 100644
--- a/games/gpuzzle/Makefile
+++ b/games/gpuzzle/Makefile
@@ -15,12 +15,10 @@ EXTRACT_SUFX= .tgz
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Simulates a jigsaw puzzle and illustrates the use of clipping paths
-USE_GMAKE= yes
USE_GNUSTEP= yes
USE_GNUSTEP_PREFIX= yes
USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
-MAKEFILE=
.include <bsd.port.mk>
diff --git a/games/gridlock/Makefile b/games/gridlock/Makefile
index edf84b5e4dc9..32902e7a17ba 100644
--- a/games/gridlock/Makefile
+++ b/games/gridlock/Makefile
@@ -9,20 +9,19 @@ PORTNAME= gridlock
PORTVERSION= 1.10
CATEGORIES= games
MASTER_SITES= http://www.dozingcatsoftware.com/ \
- http://io.debian.net/~tar/ports/distfiles/
+ ${MASTER_SITE_GNUSTEP_CH}
DISTNAME= Gridlock-gnustep-${PORTVERSION}
MAINTAINER= gurkan@linuks.mine.nu
COMMENT= A collection of grid-based board games for GNUstep
-WRKSRC= ${WRKDIR}/Gridlock
-USE_GMAKE= yes
USE_GNUSTEP= yes
USE_GNUSTEP_PREFIX= yes
USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
-MAKEFILE= GNUmakefile
+
+WRKSRC= ${WRKDIR}/Gridlock
post-patch:
@${REINPLACE_CMD} -e 's|#import <netinet/ip_compat.h>|#import <net/if.h>\n#import <netinet/ip_compat.h>|g' ${WRKSRC}/osdep.h
diff --git a/games/grubik/Makefile b/games/grubik/Makefile
index 7c18301bcbe0..0f7b99e9b3df 100644
--- a/games/grubik/Makefile
+++ b/games/grubik/Makefile
@@ -15,14 +15,11 @@ EXTRACT_SUFX= .tgz
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Virtual 3D Rubiks cube for GNUstep
-USE_GMAKE= yes
USE_GNUSTEP= yes
USE_GNUSTEP_PREFIX= yes
USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
-MAKEFILE=
-ALL_TARGET=
post-patch:
${RMDIR} ${WRKSRC}/GRubik.app/ix86/linux-gnu
diff --git a/games/gshisen/Makefile b/games/gshisen/Makefile
index 91be99012703..fb70a77ad5e8 100644
--- a/games/gshisen/Makefile
+++ b/games/gshisen/Makefile
@@ -9,18 +9,16 @@ PORTNAME= gshisen
PORTVERSION= 1.2.1
CATEGORIES= games
MASTER_SITES= http://www.gnustep.it/enrico/gshisen/ \
- http://io.debian.net/~tar/ports/distfiles/
+ ${MASTER_SITE_GNUSTEP_CH}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Shisen-sho puzzle game for GNUstep
-USE_GMAKE= yes
USE_GNUSTEP= yes
USE_GNUSTEP_PREFIX= yes
USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
-MAKEFILE=
post-patch:
${REINPLACE_CMD} -e 's|)/Makefiles|)/Library/Makefiles|' \
diff --git a/games/jigsaw/Makefile b/games/jigsaw/Makefile
index 627723545b92..180752eb6977 100644
--- a/games/jigsaw/Makefile
+++ b/games/jigsaw/Makefile
@@ -15,12 +15,10 @@ EXTRACT_SUFX= .tgz
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Simulates a jigsaw puzzle and illustrates the use of clipping paths
-USE_GMAKE= yes
USE_GNUSTEP= yes
USE_GNUSTEP_PREFIX= yes
USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
-MAKEFILE=
.include <bsd.port.mk>
diff --git a/games/lapispuzzle/Makefile b/games/lapispuzzle/Makefile
index 30b6185c43b0..bee2057be1b1 100644
--- a/games/lapispuzzle/Makefile
+++ b/games/lapispuzzle/Makefile
@@ -9,19 +9,18 @@ PORTNAME= lapispuzzle
PORTVERSION= 1.0
CATEGORIES= games
MASTER_SITES= http://download.savannah.gnu.org/releases/gap/ \
- http://io.debian.net/~tar/ports/distfiles/
+ ${MASTER_SITE_GNUSTEP_CH}
DISTNAME= LapisPuzzle-${PORTVERSION}
MAINTAINER= gurkan@linuks.mine.nu
COMMENT= Tetris-like game for GNUstep
-WRKSRC= ${WRKDIR}/LapisPuzzle-${PORTVERSION}
-USE_GMAKE= yes
USE_GNUSTEP= yes
USE_GNUSTEP_PREFIX= yes
USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
-MAKEFILE= GNUmakefile
+
+WRKSRC= ${WRKDIR}/LapisPuzzle-${PORTVERSION}
.include <bsd.port.mk>
diff --git a/games/nextgo/Makefile b/games/nextgo/Makefile
index 5dca6c175269..ad62b8ea0897 100644
--- a/games/nextgo/Makefile
+++ b/games/nextgo/Makefile
@@ -14,13 +14,11 @@ DISTNAME= NeXTGo-${PORTVERSION}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= classic Go game for OPENSTEP/GNUstep
-USE_GMAKE= yes
USE_GNUSTEP= yes
USE_GNUSTEP_PREFIX= yes
USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
-MAKEFILE= GNUmakefile
post-patch:
${REINPLACE_CMD} -e 's|^GNUSTEP_INSTALLATION_DIR|#GNUSTEP_INSTALLATION_DIR|' \
diff --git a/games/stepbill/Makefile b/games/stepbill/Makefile
index 77f74f500f03..c05b8ae44441 100644
--- a/games/stepbill/Makefile
+++ b/games/stepbill/Makefile
@@ -9,18 +9,17 @@ PORTNAME= stepbill
PORTVERSION= 2.4
CATEGORIES= games
MASTER_SITES= http://www.linuks.mine.nu/stepbill/ \
- http://io.debian.net/~tar/ports/distfiles/
+ ${MASTER_SITE_GNUSTEP_CH}
MAINTAINER= gurkan@linuks.mine.nu
COMMENT= Get rid of those nasty Wingdows viruses
-WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
-USE_GMAKE= yes
USE_GNUSTEP= yes
USE_GNUSTEP_PREFIX= yes
USE_GNUSTEP_BACK= yes
USE_GNUSTEP_BUILD= yes
USE_GNUSTEP_INSTALL= yes
-MAKEFILE= GNUmakefile
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
.include <bsd.port.mk>