aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorGanael LAPLANCHE <martymac@FreeBSD.org>2020-09-24 10:37:54 +0000
committerGanael LAPLANCHE <martymac@FreeBSD.org>2020-09-24 10:37:54 +0000
commitdde71668c44497c28698341dd578264ab5914ae8 (patch)
tree0d61900b11adfb4842fcc35c3872934b3d02c938 /games
parent70a8113a1e48cbae12981392549f62c15ef4fe14 (diff)
downloadports-dde71668c44497c28698341dd578264ab5914ae8.tar.gz
ports-dde71668c44497c28698341dd578264ab5914ae8.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/jfsw/Makefile26
-rw-r--r--games/jfsw/distinfo18
-rw-r--r--games/jfsw/files/patch-Makefile32
-rw-r--r--games/jfsw/files/patch-jfaudiolib-Makefile17
-rw-r--r--games/jfsw/files/patch-jfaudiolib-Makefile.shared26
-rw-r--r--games/jfsw/files/patch-jfaudiolib-src-driver_fluidsynth.c15
-rw-r--r--games/jfsw/files/patch-jfbuild-Makefile15
-rw-r--r--games/jfsw/files/patch-jfbuild-kenbuild-bstub.c17
-rw-r--r--games/jfsw/files/patch-jfbuild-kenbuild-game.c17
-rw-r--r--games/jfsw/files/patch-jfbuild-src-kplib.c13
-rw-r--r--games/jfsw/files/patch-jfbuild-src-sdlayer.c21
-rw-r--r--games/jfsw/files/patch-jfbuild-src-sdlayer2.c13
-rw-r--r--games/jfsw/files/patch-src-game.c7
-rw-r--r--games/jfsw/files/patch-src-gamedefs.h14
-rw-r--r--games/jfsw/files/patch-src-grpscan.h13
-rw-r--r--games/jfsw/files/patch-src-jnstub.c15
16 files changed, 82 insertions, 197 deletions
diff --git a/games/jfsw/Makefile b/games/jfsw/Makefile
index 4b85996f41aa..46f824f99e9a 100644
--- a/games/jfsw/Makefile
+++ b/games/jfsw/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= jfsw
-PORTVERSION= 20131019
-PORTREVISION= 3
+PORTVERSION= 20200116
CATEGORIES= games
MAINTAINER= martymac@FreeBSD.org
@@ -15,30 +14,30 @@ LICENSE_NAME_BuildLic= Build source code license
LICENSE_FILE_BuildLic= ${WRKSRC}/jfbuild/buildlic.txt
LICENSE_PERMS_BuildLic= dist-mirror no-dist-sell pkg-mirror no-pkg-sell auto-accept
-LIB_DEPENDS= libvorbisfile.so:audio/libvorbis
+LIB_DEPENDS= libvorbisfile.so:audio/libvorbis \
+ libfluidsynth.so:audio/fluidsynth
USES= alias compiler:c++11-lang dos2unix gl gmake gnome \
- pkgconfig:build sdl
+ perl5 pkgconfig:build sdl
USE_GL= gl
USE_GNOME= gtk20
-USE_SDL= mixer sdl
+USE_SDL= mixer2 sdl2
+USE_PERL5= build
DOS2UNIX_REGEX= .*(\.(c|h)|Makefile)(\.deps)?
USE_GITHUB= yes
GH_ACCOUNT= jonof
GH_PROJECT= jfbuild:build jfaudiolib:audio jfmact:mact
-GH_TAGNAME= 5cff6a81708ff053b569ba4400fba073afe207fe \
- a73583184aca466cebde152db2ce1020591d7049:build \
- a39ccf5e95961952d27754a255940be1d76ce85e:audio \
- b1071da75cd465f59257240e5dbc60a014580190:mact
+GH_TAGNAME= 282b31a2335b2b5cac91d30044ff6b92053d1094 \
+ 31e2b842629f52227fd1291f5228a806704b0cbc:build \
+ 8e28fe3bc41bf809391461697cd0ecb7027cb7f6:audio \
+ dbbf346d78334c6907ad9014958305309d4df7a0:mact
GH_SUBDIR= jfbuild:build jfaudiolib:audio jfmact:mact
NO_CDROM= Must be distributed only through the Internet and free of charge
-MAKE_ENV+= DATADIR="${DATADIR}" \
- NOASM=1 \
- LINKED_GTK=1
+MAKE_ENV+= DATADIR="${DATADIR}"
SUB_FILES= pkg-message
@@ -49,9 +48,6 @@ OPTIONS_DEFINE= DOCS
post-patch:
@${REINPLACE_CMD} 's|/usr/X11R6|${LOCALBASE}|' \
${WRKSRC}/jfbuild/Makefile
- @${REINPLACE_CMD} 's|sdl-config|${SDL_CONFIG}|' \
- ${WRKSRC}/Makefile \
- ${WRKSRC}/jfbuild/Makefile.shared
@${REINPLACE_CMD} 's|/usr|${LOCALBASE}|' \
${WRKSRC}/jfaudiolib/src/driver_fluidsynth.c
diff --git a/games/jfsw/distinfo b/games/jfsw/distinfo
index 27e236b74b9f..88951a1d8444 100644
--- a/games/jfsw/distinfo
+++ b/games/jfsw/distinfo
@@ -1,9 +1,9 @@
-TIMESTAMP = 1505332960
-SHA256 (jonof-jfsw-20131019-5cff6a81708ff053b569ba4400fba073afe207fe_GH0.tar.gz) = 605a84a06de4c5f1ea5e0603e39a55c9eaa4421f9d8138fe0fa49c2059a59b48
-SIZE (jonof-jfsw-20131019-5cff6a81708ff053b569ba4400fba073afe207fe_GH0.tar.gz) = 1393801
-SHA256 (jonof-jfbuild-a73583184aca466cebde152db2ce1020591d7049_GH0.tar.gz) = 1a9669d5fc8940c20d7169f524a6e3b99944ff0fd4c75479bbf98e4f2b1a94e2
-SIZE (jonof-jfbuild-a73583184aca466cebde152db2ce1020591d7049_GH0.tar.gz) = 1434766
-SHA256 (jonof-jfaudiolib-a39ccf5e95961952d27754a255940be1d76ce85e_GH0.tar.gz) = 92d82f904df2f9cd546fafce9cea3462f6b092baa8a4f79426413fed3a426bcf
-SIZE (jonof-jfaudiolib-a39ccf5e95961952d27754a255940be1d76ce85e_GH0.tar.gz) = 1041181
-SHA256 (jonof-jfmact-b1071da75cd465f59257240e5dbc60a014580190_GH0.tar.gz) = 61f98c885995d5d7c1f7bb7315eed118f95b53312ad7dfbd190006ba3446ee24
-SIZE (jonof-jfmact-b1071da75cd465f59257240e5dbc60a014580190_GH0.tar.gz) = 25410
+TIMESTAMP = 1600721184
+SHA256 (jonof-jfsw-20200116-282b31a2335b2b5cac91d30044ff6b92053d1094_GH0.tar.gz) = 77d3fb88e479b91c13dfcf6a3f9e5ba5366f1aee0da0092aff161fe7f6b5aad5
+SIZE (jonof-jfsw-20200116-282b31a2335b2b5cac91d30044ff6b92053d1094_GH0.tar.gz) = 988265
+SHA256 (jonof-jfbuild-31e2b842629f52227fd1291f5228a806704b0cbc_GH0.tar.gz) = 5f953fcb3744a6cea61186cf8bfc99ac1c3794fbc8de4f083ad6e7d593ae1225
+SIZE (jonof-jfbuild-31e2b842629f52227fd1291f5228a806704b0cbc_GH0.tar.gz) = 1535215
+SHA256 (jonof-jfaudiolib-8e28fe3bc41bf809391461697cd0ecb7027cb7f6_GH0.tar.gz) = 836efc3d49d3e32d6d8f136fa380de03f42760130b8073fe1f27a2e96e9112a5
+SIZE (jonof-jfaudiolib-8e28fe3bc41bf809391461697cd0ecb7027cb7f6_GH0.tar.gz) = 210132
+SHA256 (jonof-jfmact-dbbf346d78334c6907ad9014958305309d4df7a0_GH0.tar.gz) = 08b8ca80a76103e2ac86ee258f058dd79a4c9f6ffe43e4a1772698ea0ea518a4
+SIZE (jonof-jfmact-dbbf346d78334c6907ad9014958305309d4df7a0_GH0.tar.gz) = 25342
diff --git a/games/jfsw/files/patch-Makefile b/games/jfsw/files/patch-Makefile
index b605b29941b6..da2f0dce688e 100644
--- a/games/jfsw/files/patch-Makefile
+++ b/games/jfsw/files/patch-Makefile
@@ -1,8 +1,9 @@
-Rename PREFIX to DATADIR as its purpose is only to find data files (avoids
-conflicts with our PREFIX, which has another meaning).
-Do not enforce compilers.
+Rename PREFIX to DATADIR as its only purpose is to access data files
+(and avoid conflict with FreeBSD PREFIX, which has another meaning)
---- Makefile.orig 2020-09-03 06:19:21 UTC
+Tune GAMELIBS for FreeBSD platform
+
+--- Makefile.orig 2020-09-22 22:08:35 UTC
+++ Makefile
@@ -14,7 +14,7 @@
RELEASE ?= 1
@@ -11,32 +12,21 @@ Do not enforce compilers.
-PREFIX ?= /usr/local/share/games/jfsw
+DATADIR ?= /usr/local/share/games/jfsw
- # DirectX SDK location
- DXROOT ?= $(USERPROFILE)/sdks/directx/dx81
-@@ -61,8 +61,8 @@ endif
-
- include $(AUDIOLIBROOT)/Makefile.shared
-
--CC=gcc
--CXX=g++
-+CC?=gcc
-+CXX?=g++
- OURCFLAGS=$(debug) -W -Wall -Wimplicit -Wno-unused \
- -fno-pic -fno-strict-aliasing -DNO_GCC_BUILTINS \
- -I$(INC) -I$(EINC) -I$(MACTROOT) -I$(AUDIOLIBROOT)/include
-@@ -165,6 +165,10 @@ ifeq ($(PLATFORM),LINUX)
+ # Engine source code path
+ EROOT ?= jfbuild
+@@ -168,6 +168,10 @@ ifeq ($(PLATFORM),LINUX)
NASMFLAGS+= -f elf
GAMELIBS+= $(JFAUDIOLIB_LDFLAGS)
endif
+ifeq ($(PLATFORM),BSD)
+ NASMFLAGS+= -f elf
-+ GAMELIBS+= $(JFAUDIOLIB_LDFLAGS)
++ GAMELIBS+= $(JFAUDIOLIB_LDFLAGS) -pthread
+endif
ifeq ($(PLATFORM),WINDOWS)
OURCFLAGS+= -I$(DXROOT)/include
NASMFLAGS+= -f win32 --prefix _
-@@ -192,7 +196,7 @@ endif
- OURCFLAGS+= $(BUILDCFLAGS)
+@@ -207,7 +211,7 @@ OURCFLAGS+= $(BUILDCFLAGS)
+ LIBS+= $(BUILDLIBS)
ifneq ($(PLATFORM),WINDOWS)
- OURCFLAGS+= -DPREFIX=\"$(PREFIX)\"
diff --git a/games/jfsw/files/patch-jfaudiolib-Makefile b/games/jfsw/files/patch-jfaudiolib-Makefile
deleted file mode 100644
index effc2c65fc3e..000000000000
--- a/games/jfsw/files/patch-jfaudiolib-Makefile
+++ /dev/null
@@ -1,17 +0,0 @@
-Do not enforce compilers / flags
-
---- jfaudiolib/Makefile.orig 2020-09-03 06:19:21 UTC
-+++ jfaudiolib/Makefile
-@@ -8,9 +8,9 @@ else
- OPTLEVEL=-O2
- endif
-
--CC=gcc
--CFLAGS=-g $(OPTLEVEL) -Wall
--CPPFLAGS=-Iinclude -Isrc
-+CC?=gcc
-+CFLAGS+=-Wall
-+CPPFLAGS+=-Iinclude -Isrc
-
- SOURCES=src/drivers.c \
- src/fx_man.c \
diff --git a/games/jfsw/files/patch-jfaudiolib-Makefile.shared b/games/jfsw/files/patch-jfaudiolib-Makefile.shared
deleted file mode 100644
index a679336591fe..000000000000
--- a/games/jfsw/files/patch-jfaudiolib-Makefile.shared
+++ /dev/null
@@ -1,26 +0,0 @@
-Disable ALSA and FluidSynth (MIDI) support : use SDL for PCM/CD/Music support.
-See jfaudiolib/src/drivers.c for the exact role of each driver.
-
---- jfaudiolib/Makefile.shared.orig 2013-06-01 00:16:56 UTC
-+++ jfaudiolib/Makefile.shared
-@@ -18,12 +18,12 @@ else
- JFAUDIOLIB_HAVE_SDL=1
- JFAUDIOLIB_LDFLAGS+= $(shell pkg-config --libs sdl)
- endif
-- ifeq (yes,$(shell pkg-config --exists alsa && echo yes))
-- JFAUDIOLIB_HAVE_ALSA=1
-- JFAUDIOLIB_LDFLAGS+= $(shell pkg-config --libs alsa)
-- endif
-- ifeq (yes,$(shell pkg-config --exists fluidsynth && echo yes))
-- JFAUDIOLIB_HAVE_FLUIDSYNTH=1
-- JFAUDIOLIB_LDFLAGS+= $(shell pkg-config --libs fluidsynth)
-- endif
-+# ifeq (yes,$(shell pkg-config --exists alsa && echo yes))
-+# JFAUDIOLIB_HAVE_ALSA=1
-+# JFAUDIOLIB_LDFLAGS+= $(shell pkg-config --libs alsa)
-+# endif
-+# ifeq (yes,$(shell pkg-config --exists fluidsynth && echo yes))
-+# JFAUDIOLIB_HAVE_FLUIDSYNTH=1
-+# JFAUDIOLIB_LDFLAGS+= $(shell pkg-config --libs fluidsynth)
-+# endif
- endif
diff --git a/games/jfsw/files/patch-jfaudiolib-src-driver_fluidsynth.c b/games/jfsw/files/patch-jfaudiolib-src-driver_fluidsynth.c
deleted file mode 100644
index 6513909bc0f2..000000000000
--- a/games/jfsw/files/patch-jfaudiolib-src-driver_fluidsynth.c
+++ /dev/null
@@ -1,15 +0,0 @@
-Allow definition of clockid_t from within time.h, included by pthread.h
-
---- jfaudiolib/src/driver_fluidsynth.c.orig 2020-09-03 06:19:21 UTC
-+++ jfaudiolib/src/driver_fluidsynth.c
-@@ -29,7 +29,10 @@
- #include <string.h>
- #include <stdio.h>
- #include <stdlib.h>
-+
-+#define __POSIX_VISIBLE 199309
- #include <pthread.h>
-+
- #include <sys/select.h>
- #include <math.h>
- #include <unistd.h>
diff --git a/games/jfsw/files/patch-jfbuild-Makefile b/games/jfsw/files/patch-jfbuild-Makefile
deleted file mode 100644
index 91a4b4775dde..000000000000
--- a/games/jfsw/files/patch-jfbuild-Makefile
+++ /dev/null
@@ -1,15 +0,0 @@
-Do not enforce compilers
-
---- jfbuild/Makefile.orig 2020-09-03 06:19:21 UTC
-+++ jfbuild/Makefile
-@@ -55,8 +55,8 @@ else
- debug=-ggdb -O0 -DDEBUGGINGAIDS -DNOSDLPARACHUTE
- endif
-
--CC=gcc
--CXX=g++
-+CC?=gcc
-+CXX?=g++
- AS=nasm
- RC=windres
- AR=ar
diff --git a/games/jfsw/files/patch-jfbuild-kenbuild-bstub.c b/games/jfsw/files/patch-jfbuild-kenbuild-bstub.c
new file mode 100644
index 000000000000..fba8d5860747
--- /dev/null
+++ b/games/jfsw/files/patch-jfbuild-kenbuild-bstub.c
@@ -0,0 +1,17 @@
+Rename PREFIX to DATADIR as its only purpose is to access data files
+(and avoid conflict with FreeBSD PREFIX, which has another meaning)
+
+--- jfbuild/kenbuild/bstub.c.orig 2020-09-22 22:08:35 UTC
++++ jfbuild/kenbuild/bstub.c
+@@ -73,9 +73,9 @@ int ExtInit(void)
+ getch();
+ */
+
+-#if defined(PREFIX)
++#if defined(DATADIR)
+ {
+- const char *prefixdir = PREFIX;
++ const char *prefixdir = DATADIR;
+ if (prefixdir && prefixdir[0]) {
+ addsearchpath(prefixdir);
+ }
diff --git a/games/jfsw/files/patch-jfbuild-kenbuild-game.c b/games/jfsw/files/patch-jfbuild-kenbuild-game.c
new file mode 100644
index 000000000000..e3eb0eefe86c
--- /dev/null
+++ b/games/jfsw/files/patch-jfbuild-kenbuild-game.c
@@ -0,0 +1,17 @@
+Rename PREFIX to DATADIR as its only purpose is to access data files
+(and avoid conflict with FreeBSD PREFIX, which has another meaning)
+
+--- jfbuild/kenbuild/game.c.orig 2020-09-22 22:08:35 UTC
++++ jfbuild/kenbuild/game.c
+@@ -405,9 +405,9 @@ int app_main(int argc, char const * const argv[])
+ int startretval = STARTWIN_RUN;
+ struct startwin_settings settings;
+
+-#if defined(PREFIX)
++#if defined(DATADIR)
+ {
+- const char *prefixdir = PREFIX;
++ const char *prefixdir = DATADIR;
+ if (prefixdir && prefixdir[0]) {
+ addsearchpath(prefixdir);
+ }
diff --git a/games/jfsw/files/patch-jfbuild-src-kplib.c b/games/jfsw/files/patch-jfbuild-src-kplib.c
deleted file mode 100644
index 2479127a6fa2..000000000000
--- a/games/jfsw/files/patch-jfbuild-src-kplib.c
+++ /dev/null
@@ -1,13 +0,0 @@
-Make return-free function void
-
---- jfbuild/src/kplib.c.orig 2020-09-03 06:19:21 UTC
-+++ jfbuild/src/kplib.c
-@@ -2495,7 +2495,7 @@ static int kddsrend (const char *buf, int leng,
- //=============================== DDS ends ==================================
- //=================== External picture interface begins ======================
-
--int kpgetdim (const char *buf, int leng, int *xsiz, int *ysiz)
-+void kpgetdim (const char *buf, int leng, int *xsiz, int *ysiz)
- {
- int *lptr;
- const unsigned char *cptr;
diff --git a/games/jfsw/files/patch-jfbuild-src-sdlayer.c b/games/jfsw/files/patch-jfbuild-src-sdlayer.c
deleted file mode 100644
index 329cab41073b..000000000000
--- a/games/jfsw/files/patch-jfbuild-src-sdlayer.c
+++ /dev/null
@@ -1,21 +0,0 @@
-Ensure jfsw and build files get created within $HOME/.jfsw
-
---- jfbuild/src/sdlayer.c.orig 2020-09-03 06:19:21 UTC
-+++ jfbuild/src/sdlayer.c
-@@ -152,6 +152,16 @@ int main(int argc, char *argv[])
- {
- int r;
-
-+#ifdef __FreeBSD__
-+ /* XXX Ensure every jfsw file gets created within $HOME/.jfsw */
-+ if (chdir(getenv("HOME")) != 0)
-+ err(1, "cannot cd to $HOME");
-+ if (mkdir(".jfsw", 0755) != 0 && errno != EEXIST)
-+ err(1, "cannot mkdir $HOME/.jfsw");
-+ if (chdir(".jfsw") != 0)
-+ err(1, "cannot cd to $HOME/.jfsw");
-+#endif
-+
- buildkeytranslationtable();
-
- #ifdef HAVE_GTK2
diff --git a/games/jfsw/files/patch-jfbuild-src-sdlayer2.c b/games/jfsw/files/patch-jfbuild-src-sdlayer2.c
new file mode 100644
index 000000000000..4486d3441675
--- /dev/null
+++ b/games/jfsw/files/patch-jfbuild-src-sdlayer2.c
@@ -0,0 +1,13 @@
+Fix include for FreeBSD
+
+--- jfbuild/src/sdlayer2.c.orig 2020-09-22 22:08:35 UTC
++++ jfbuild/src/sdlayer2.c
+@@ -22,7 +22,7 @@
+ # define _GNU_SOURCE 1
+ #endif
+
+-#if defined __APPLE__
++#if defined __APPLE__ || __FreeBSD__
+ # include <SDL2/SDL.h>
+ #else
+ # include "SDL.h"
diff --git a/games/jfsw/files/patch-src-game.c b/games/jfsw/files/patch-src-game.c
index 379920bf1bda..b951654d6cd8 100644
--- a/games/jfsw/files/patch-src-game.c
+++ b/games/jfsw/files/patch-src-game.c
@@ -1,8 +1,9 @@
-Rename PREFIX to DATADIR as its purpose is only to find data files.
+Rename PREFIX to DATADIR as its only purpose is to access data files
+(and avoid conflict with FreeBSD PREFIX, which has another meaning)
---- src/game.c.orig 2020-09-03 06:19:21 UTC
+--- src/game.c.orig 2020-09-22 22:08:35 UTC
+++ src/game.c
-@@ -3470,9 +3470,9 @@ int app_main(int argc, char const * const argv[])
+@@ -3405,9 +3405,9 @@ int app_main(int argc, char const * const argv[])
}
#endif
diff --git a/games/jfsw/files/patch-src-gamedefs.h b/games/jfsw/files/patch-src-gamedefs.h
deleted file mode 100644
index 59f155889b80..000000000000
--- a/games/jfsw/files/patch-src-gamedefs.h
+++ /dev/null
@@ -1,14 +0,0 @@
-Avoid buffer overflow @src/config.c:255 where JoystickDigitalAxes[6] overrides
-RTSName.
-
---- src/gamedefs.h.orig 2020-09-03 06:19:21 UTC
-+++ src/gamedefs.h
-@@ -125,7 +125,7 @@ extern "C" {
-
- // Number of JOY axes
-
--#define MAXJOYAXES 6
-+#define MAXJOYAXES 12
-
- // Number of GAMEPAD axes
-
diff --git a/games/jfsw/files/patch-src-grpscan.h b/games/jfsw/files/patch-src-grpscan.h
deleted file mode 100644
index 17df31e16f92..000000000000
--- a/games/jfsw/files/patch-src-grpscan.h
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/grpscan.h.orig 2020-09-03 06:19:21 UTC
-+++ src/grpscan.h
-@@ -31,7 +31,9 @@ struct grpfile {
- int crcval;
- int size;
- struct grpfile *next;
--} grpfiles[numgrpfiles], *foundgrps;
-+};
-+
-+extern struct grpfile grpfiles[numgrpfiles], *foundgrps;
-
- int ScanGroups(void);
- void FreeGroups(void);
diff --git a/games/jfsw/files/patch-src-jnstub.c b/games/jfsw/files/patch-src-jnstub.c
deleted file mode 100644
index ca631fc0843c..000000000000
--- a/games/jfsw/files/patch-src-jnstub.c
+++ /dev/null
@@ -1,15 +0,0 @@
-Do not hardcode data directory (available as DATADIR)
-
---- src/jnstub.c.orig 2020-09-03 06:19:21 UTC
-+++ src/jnstub.c
-@@ -699,7 +699,9 @@ ExtInit(void)
-
- #if defined(__linux) || defined(__FreeBSD__) || defined(__NetBSD__) || defined(__OpenBSD__)
- addsearchpath("/usr/share/games/jfsw");
-- addsearchpath("/usr/local/share/games/jfsw");
-+#if defined(DATADIR)
-+ addsearchpath(DATADIR);
-+#endif
- #elif defined(__APPLE__)
- addsearchpath("/Library/Application Support/JFShadowWarrior");
- #endif