aboutsummaryrefslogtreecommitdiff
path: root/games
diff options
context:
space:
mode:
authorMichael Nottebrock <lofi@FreeBSD.org>2004-05-23 00:08:43 +0000
committerMichael Nottebrock <lofi@FreeBSD.org>2004-05-23 00:08:43 +0000
commitf0bf08ec0ce13302c04c077cfe0e15f760a7f118 (patch)
tree9aec9c83c68744e3a7b8886fa3374fc8155dd66e /games
parentc17d43b70819f28a5ae07968b35473bb00696bc0 (diff)
downloadports-f0bf08ec0ce13302c04c077cfe0e15f760a7f118.tar.gz
ports-f0bf08ec0ce13302c04c077cfe0e15f760a7f118.zip
Notes
Diffstat (limited to 'games')
-rw-r--r--games/spacehulk/Makefile9
-rw-r--r--games/spacehulk/files/patch-src_Makefile.in11
2 files changed, 17 insertions, 3 deletions
diff --git a/games/spacehulk/Makefile b/games/spacehulk/Makefile
index 718d350b77a1..b162b2845dae 100644
--- a/games/spacehulk/Makefile
+++ b/games/spacehulk/Makefile
@@ -17,7 +17,10 @@ COMMENT= Science-fiction board game in the world of Warhammer 40000
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_KDELIBS_VER=3
+USE_REINPLACE= yes
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/x11/kde3/Makefile.kde"
-.include <bsd.port.post.mk>
+post-patch:
+ @${REINPLACE_CMD} -e 's|-O2||g' -e 's|-lpthread|${PTHREAD_LIBS}|g' \
+ ${WRKSRC}/${CONFIGURE_SCRIPT}
+
+.include <bsd.port.mk>
diff --git a/games/spacehulk/files/patch-src_Makefile.in b/games/spacehulk/files/patch-src_Makefile.in
new file mode 100644
index 000000000000..298d7043de22
--- /dev/null
+++ b/games/spacehulk/files/patch-src_Makefile.in
@@ -0,0 +1,11 @@
+--- src/Makefile.in.orig Sun May 23 01:55:27 2004
++++ src/Makefile.in Sun May 23 01:56:42 2004
+@@ -259,7 +259,7 @@
+ INCLUDES = $(all_includes) -Wall -DQT_THREAD_SUPPORT -DDATA_DIR=\"$(pkgdatadir)\"
+
+ #qspacehulk_LDADD = $(LIB_QPE) $(LIB_QT) $(LIBSOCKET) -lqt-mt
+-qspacehulk_LDADD = -lqt-mt
++qspacehulk_LDADD = -lqt-mt $(LIBPTHREAD)
+ #qspacehulk_METASOURCES = AUTO
+
+ # the library search path.