aboutsummaryrefslogtreecommitdiff
path: root/graphics/Coin
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2018-12-15 20:21:07 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2018-12-15 20:21:07 +0000
commit143212e7981fa2996d747a84201d3755b093a4d0 (patch)
treecf0136a4b18dfa8dc1e2f0673a1aae743797b2cc /graphics/Coin
parentb597fd95ce88a9a4c76ba7c4308b19fe12848384 (diff)
downloadports-143212e7981fa2996d747a84201d3755b093a4d0.tar.gz
ports-143212e7981fa2996d747a84201d3755b093a4d0.zip
graphics/Coin: Add USES=gl; Fix USE_GL; Add LICENSE_FILE
Notes
Notes: svn path=/head/; revision=487543
Diffstat (limited to 'graphics/Coin')
-rw-r--r--graphics/Coin/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/graphics/Coin/Makefile b/graphics/Coin/Makefile
index e9654339fb78..d00c7bcb8094 100644
--- a/graphics/Coin/Makefile
+++ b/graphics/Coin/Makefile
@@ -11,11 +11,12 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= C++ 3D graphics library based on the Open Inventor 2.1 API
LICENSE= GPLv2
+LICENSE_FILE= ${WRKSRC}/LICENSE.GPL
LIB_DEPENDS= libsimage.so:graphics/simage
-USES= openal:al libtool pathfix
-USE_GL= yes
+USES= gl openal:al libtool pathfix
+USE_GL= gl
USE_XORG= ice sm x11 xext xt
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-pthread=yes --enable-threadsafe \
@@ -32,7 +33,7 @@ pre-configure:
${REINPLACE_CMD} 's/<stdlib.h>/<cstdlib>/g'
post-build:
- ${REINPLACE_CMD} -e '/^ldflags=/s|-R|-Wl,-rpath,|' \
+ @${REINPLACE_CMD} -e '/^ldflags=/s|-R|-Wl,-rpath,|' \
${WRKSRC}/coin-default.cfg
.include <bsd.port.mk>