aboutsummaryrefslogtreecommitdiff
path: root/graphics/Coin
diff options
context:
space:
mode:
authorGerald Pfeifer <gerald@FreeBSD.org>2014-08-26 07:16:21 +0000
committerGerald Pfeifer <gerald@FreeBSD.org>2014-08-26 07:16:21 +0000
commit4145f4ffe05f649300396624bfdc3fe6974bc7b4 (patch)
treec828072c7083cbeb45a5c06e89b1e7ec3550b9d2 /graphics/Coin
parenta57552ddb62188306a58ef4c824783b991799975 (diff)
downloadports-4145f4ffe05f649300396624bfdc3fe6974bc7b4.tar.gz
ports-4145f4ffe05f649300396624bfdc3fe6974bc7b4.zip
Fix the build with GCC 4.8. Coin mixes stdlib.h (the C header) and cstdlib
(the C++ header) quite freely, which results in conflicts and fails with recent compilers. Address this via a post-patch substitution to avoid some 70 individual patches. PR: 192133 Submitted by: Christoph Moench-Tegeder <cmt@burggraben.net>
Notes
Notes: svn path=/head/; revision=366193
Diffstat (limited to 'graphics/Coin')
-rw-r--r--graphics/Coin/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/graphics/Coin/Makefile b/graphics/Coin/Makefile
index c1538c3c37d5..366895c5d3bd 100644
--- a/graphics/Coin/Makefile
+++ b/graphics/Coin/Makefile
@@ -28,6 +28,7 @@ MAKE_ENV= LANG=C
post-patch:
@${REINPLACE_CMD} -e 's|DATA install-data-local|DATA|g' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e 's|-pthread|${PTHREAD_LIBS}|g' ${WRKSRC}/configure
+ @${FIND} ${WRKSRC} \( -name \*.cpp -o -name \*.h -a \! -name expat.h \) -a -print0 | ${XARGS} -0 ${REINPLACE_CMD} 's/<stdlib.h>/<cstdlib>/g'
post-build:
@${REINPLACE_CMD} -e '/^ldflags=/s|-R|-Wl,-rpath,|' ${WRKSRC}/coin-default.cfg