aboutsummaryrefslogtreecommitdiff
path: root/graphics/ImageMagick7
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2018-11-20 16:56:57 +0000
committerKoop Mast <kwm@FreeBSD.org>2018-11-20 16:56:57 +0000
commitc76f570dba4285027939889e7aec9c7d88479d61 (patch)
tree1a3e66a226e83e6d5bf66afc01982de9333751f5 /graphics/ImageMagick7
parent6c68e91ddc99b45b1763d5ae9be10e31f72bc177 (diff)
downloadports-c76f570dba4285027939889e7aec9c7d88479d61.tar.gz
ports-c76f570dba4285027939889e7aec9c7d88479d61.zip
* Fix a bug in the icon coder
* Fix a bug in configure that resulted in a string being inserted in the Libs.private field of the pkg-config files. Remove broken from 3 ports that where broken by the above bugs. Reported by: jbeich@ Obtained from: upstream
Notes
Notes: svn path=/head/; revision=485437
Diffstat (limited to 'graphics/ImageMagick7')
-rw-r--r--graphics/ImageMagick7/Makefile2
-rw-r--r--graphics/ImageMagick7/files/patch-coders_icon.c24
-rw-r--r--graphics/ImageMagick7/files/patch-configure11
3 files changed, 36 insertions, 1 deletions
diff --git a/graphics/ImageMagick7/Makefile b/graphics/ImageMagick7/Makefile
index 6af4a7dd9763..67ebfcebd49c 100644
--- a/graphics/ImageMagick7/Makefile
+++ b/graphics/ImageMagick7/Makefile
@@ -2,7 +2,7 @@
PORTNAME= ImageMagick
DISTVERSION= 7.0.8-14
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= graphics perl5
MASTER_SITES= http://www.imagemagick.org/download/ \
http://www.imagemagick.org/download/legacy/ \
diff --git a/graphics/ImageMagick7/files/patch-coders_icon.c b/graphics/ImageMagick7/files/patch-coders_icon.c
new file mode 100644
index 000000000000..320444f6112b
--- /dev/null
+++ b/graphics/ImageMagick7/files/patch-coders_icon.c
@@ -0,0 +1,24 @@
+From 08761138f4b3ee4d174ee4297983839c55382349 Mon Sep 17 00:00:00 2001
+From: Cristy <urban-warrior@imagemagick.org>
+Date: Sun, 18 Nov 2018 17:39:53 -0500
+Subject: [PATCH] https://github.com/ImageMagick/ImageMagick/issues/1386
+
+---
+ coders/icon.c | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/coders/icon.c b/coders/icon.c
+index fa35021cd5..e32c7392f8 100644
+--- coders/icon.c
++++ coders/icon.c
+@@ -367,8 +367,8 @@ static Image *ReadICONImage(const ImageInfo *image_info,
+ png[13]=(unsigned char) (icon_info.planes >> 8);
+ png[14]=(unsigned char) icon_info.bits_per_pixel;
+ png[15]=(unsigned char) (icon_info.bits_per_pixel >> 8);
+- count=ReadBlob(image,length,png+16);
+- if (count != (ssize_t) length)
++ count=ReadBlob(image,length-16,png+16);
++ if (count != (ssize_t) (length-16))
+ {
+ png=(unsigned char *) RelinquishMagickMemory(png);
+ ThrowReaderException(CorruptImageError,
diff --git a/graphics/ImageMagick7/files/patch-configure b/graphics/ImageMagick7/files/patch-configure
new file mode 100644
index 000000000000..d9e75f1e149b
--- /dev/null
+++ b/graphics/ImageMagick7/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2018-11-20 17:30:38.038076000 +0100
++++ configure 2018-11-20 17:30:45.393294000 +0100
+@@ -36948,7 +36948,7 @@
+ MAGICK_CPPFLAGS=`echo $MAGICK_CPPFLAGS | sed -e 's/ */ /g'`
+ MAGICK_PCFLAGS=`echo $MAGICK_PCFLAGS | sed -e 's/ */ /g'`
+ MAGICK_LDFLAGS="-L$LIB_DIR $LDFLAGS"
+-MAGICK_LIBS="$MAGICK_DEP_LIBS MAGICK_EXTRA_DEP_LIBS"
++MAGICK_LIBS="$MAGICK_DEP_LIBS $MAGICK_EXTRA_DEP_LIBS"
+
+
+