aboutsummaryrefslogtreecommitdiff
path: root/graphics/Makefile
diff options
context:
space:
mode:
authorDiane Bruce <db@FreeBSD.org>2020-03-20 22:45:05 +0000
committerDiane Bruce <db@FreeBSD.org>2020-03-20 22:45:05 +0000
commit34c7101ea5ac9aeedf7706ceb3f9659230516494 (patch)
tree54dcf5a0ca42c02eebd38a0628ca338308aa2767 /graphics/Makefile
parenta82adc010b5c9ccfac5fc44e5aafd07faf20f522 (diff)
downloadports-34c7101ea5ac9aeedf7706ceb3f9659230516494.tar.gz
ports-34c7101ea5ac9aeedf7706ceb3f9659230516494.zip
Every game needs a user interface that matches its look and feel. The purpose
of glooey is to help you make such an interface. Towards this end, glooey provides 7 powerful placement widgets, a label widget, an image widget, 3 different button widgets, a text entry widget, a variety of scroll boxes and bars, 4 different dialog box widgets, and a variety of other miscellaneous widgets. The appearance of any widget can be trivially customized, and glooey comes with built-in fantasy, puzzle, and 8-bit themes to prove it (and to help you hit the ground running if your game fits one of those genres). The philosophy behind glooey is that deriving subclasses from a basic set of widgets with no default style is the most elegant way to control how widgets look. This approach is flexible because subclasses can customize or override most aspects of the basic widgets. But it's also surprisingly succinct and powerful: specifying a style is usually as simple as setting a class variable, and styles can be easily composed using either inner classes or previously defined widgets. This philosophy makes glooey easy to get started with, and powerful enough to support even the most complicated games. WWW: https://pypi.org/project/glooey
Notes
Notes: svn path=/head/; revision=528807
Diffstat (limited to 'graphics/Makefile')
-rw-r--r--graphics/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 343adc94e3dd..cafe11b11d49 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -806,6 +806,7 @@
SUBDIR += py-gizeh
SUBDIR += py-glewpy
SUBDIR += py-glfw
+ SUBDIR += py-glooey
SUBDIR += py-gphoto2
SUBDIR += py-graph-core
SUBDIR += py-graphviz