aboutsummaryrefslogtreecommitdiff
path: root/graphics/Makefile
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-01-24 18:10:14 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2016-01-24 18:10:14 +0000
commit4c67812e0161cb63098ede0c2645e53c5060ecd9 (patch)
tree66663b28c2c298161be86b00114ab18d6fad8670 /graphics/Makefile
parent7b72d170ba3c89c7e408c333297d8ecfa3ba72f1 (diff)
downloadports-4c67812e0161cb63098ede0c2645e53c5060ecd9.tar.gz
ports-4c67812e0161cb63098ede0c2645e53c5060ecd9.zip
Update Qt5 to 5.5.1.
This is the latest stable release at time of writing. Release announcement: http://blog.qt.io/blog/2015/07/01/qt-5-5-released/ New features in Qt 5.5: https://wiki.qt.io/New_Features_in_Qt_5.5 As usual, huge thanks to Tobias Berner (tcberner@gmail.com) for all his work on these ports in kde@'s experimental area51 repository. He's the one who started the update and did a lot of the initial work on Qt 5.5. Ralf Nolden (nolden@kde.org) has contributed the initial version of most of our new Qt5 ports. Also thanks to Yuri Victorovich (yuri@rawbw.com) for contributing PR 205805 with his own patch for the 5.5.1 update. Some of his changes there prompted additional fixes and changes present in the final patch generated from our experimental repository. New ports: - comms/qt5-connectivity, comms/qt5-sensors, devel/qt5-location, graphics/qt5-3d, net/qt5-enginio, x11-toolkits/qt5-canvas3d, x11-toolkits/qt5-uiplugin. General changes in all Qt5 ports: - All Qt5 ports are now built with -Wl,--as-needed to avoid overlinking, which is a problem with qmake-based because the libraries passed to the linker come from the modules .pri files and many are not necessary. - With this change, several ports had their USE_QT5 lines adjusted to explicitly include some libraries that were pulled in implicitly, and to exclude libraries no longer required with -Wl,--as-needed. Changes in specific ports: - devel/qt5: Drop the SQL_PLUGINS and TOOLS options and depend on all Qt5 ports by default. It makes the Makefile much simpler, and those options were already on by default. - devel/qt5-core: The clang+base libstdc++ workaround has been expanded and more C++11 features have been disabled when that combination is used by a port (basically, FreeBSD 9 with USES=compiler:c++11-lang). The disabled features have explanations for why they were disabled in the patched header itself. - devel/qt5-designer: uiplugins has been split out following a similar change upstream. By depending on qt5-uiplugin, qt5-uitools avoids having to depend on the big qt5-designer port. - multimedia/qt5-multimedia: The port now uses GStreamer 1.0 instead of 0.10. - net/qt5-network: The port now depends on libproxy for proxy settings. Using libproxy allows proxy settings to be read from different sources, and also allows .pac files to work with Qt. - www/qt5-webkit: The port now uses GStreamer 1.0 instead of 0.10. PR: 205805 PR: 206435
Notes
Notes: svn path=/head/; revision=407169
Diffstat (limited to 'graphics/Makefile')
-rw-r--r--graphics/Makefile1
1 files changed, 1 insertions, 0 deletions
diff --git a/graphics/Makefile b/graphics/Makefile
index 8fa512734158..0cb09c2441cf 100644
--- a/graphics/Makefile
+++ b/graphics/Makefile
@@ -891,6 +891,7 @@
SUBDIR += qt4-opengl
SUBDIR += qt4-pixeltool
SUBDIR += qt4-svg
+ SUBDIR += qt5-3d
SUBDIR += qt5-graphicaleffects
SUBDIR += qt5-imageformats
SUBDIR += qt5-opengl