aboutsummaryrefslogtreecommitdiff
path: root/graphics/OpenEXR
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2015-11-20 08:02:26 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2015-11-20 08:02:26 +0000
commit976b3538bd2d621a7dfb6414e0f825c7d39379c3 (patch)
tree6a552c53e19de942f69f0a0cefad8b226dde8a11 /graphics/OpenEXR
parent0962fbef574bd81aca5ac292ee98dd90015e25a0 (diff)
downloadports-976b3538bd2d621a7dfb6414e0f825c7d39379c3.tar.gz
ports-976b3538bd2d621a7dfb6414e0f825c7d39379c3.zip
Notes
Diffstat (limited to 'graphics/OpenEXR')
-rw-r--r--graphics/OpenEXR/Makefile21
-rw-r--r--graphics/OpenEXR/files/extra-patch-IlmImfExamples__Makefile.in33
2 files changed, 10 insertions, 44 deletions
diff --git a/graphics/OpenEXR/Makefile b/graphics/OpenEXR/Makefile
index f974d624e510..f4dd72ee4981 100644
--- a/graphics/OpenEXR/Makefile
+++ b/graphics/OpenEXR/Makefile
@@ -23,10 +23,11 @@ WRKSRC= ${WRKDIR}/${DISTNAME}
USES= compiler:features gmake libtool pathfix pkgconfig
GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--disable-ilmbasetest --enable-imfexamples
+CONFIGURE_ARGS= --disable-ilmbasetest --enable-imfexamples
USE_LDCONFIG= yes
-CPPFLAGS+= -I. -I../IlmImf
+TEST_TARGET= check
+CPPFLAGS+= -I. -I../IlmImf
# must be linked with -l{thr|pthread} explicitly
LDFLAGS+= -lpthread
@@ -49,6 +50,10 @@ LARGE_STACK_CONFIGURE_ENABLE= large-stack
.include <bsd.port.pre.mk>
+.if ${ARCH} == powerpc
+USE_GCC= yes
+.endif
+
MAJORVER= 2_2
VER= 22
@@ -75,17 +80,11 @@ pre-configure:
${ECHO_CMD} "*** same C++ std. library before trying to build OpenEXR. Abort. ***" ; \
exit 1; }
-.if ! ${PORT_OPTIONS:MEXAMPLES}
-EXTRA_PATCHES+=${FILESDIR}/extra-patch-IlmImfExamples__Makefile.in
-.endif
-
-regression-test regression test check: build
- @(cd ${WRKSRC}; ${SETENV} ${MAKE_ENV} ${MAKE} ${MAKE_FLAGS} ${MAKEFILE} ${MAKE_ARGS} ${_MAKE_JOBS} check)
-
post-install:
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libIlmImf-${MAJORVER}.so.${VER}
- ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libIlmImfUtil-${MAJORVER}.so.${VER}
+ ${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libIlmImf-${MAJORVER}.so.${VER} \
+ ${STAGEDIR}${PREFIX}/lib/libIlmImfUtil-${MAJORVER}.so.${VER}
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${INSTALL_DATA} ${DOC_FILES1:S|^|${DOCSRCDIR1}/|} ${STAGEDIR}${DOCSDIR}
@${MKDIR} ${STAGEDIR}${DOCSDIR2}
diff --git a/graphics/OpenEXR/files/extra-patch-IlmImfExamples__Makefile.in b/graphics/OpenEXR/files/extra-patch-IlmImfExamples__Makefile.in
deleted file mode 100644
index 2f984b895fdf..000000000000
--- a/graphics/OpenEXR/files/extra-patch-IlmImfExamples__Makefile.in
+++ /dev/null
@@ -1,33 +0,0 @@
---- ./IlmImfExamples/Makefile.in.orig 2014-03-24 18:28:37.886449236 +0100
-+++ ./IlmImfExamples/Makefile.in 2014-03-24 18:33:52.637113427 +0100
-@@ -356,18 +356,18 @@
-
- clean-libtool:
- -rm -rf .libs _libs
--install-examplesDATA: $(examples_DATA)
-- @$(NORMAL_INSTALL)
-- test -z "$(examplesdir)" || $(MKDIR_P) "$(DESTDIR)$(examplesdir)"
-- @list='$(examples_DATA)'; test -n "$(examplesdir)" || list=; \
-- for p in $$list; do \
-- if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
-- echo "$$d$$p"; \
-- done | $(am__base_list) | \
-- while read files; do \
-- echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(examplesdir)'"; \
-- $(INSTALL_DATA) $$files "$(DESTDIR)$(examplesdir)" || exit $$?; \
-- done
-+#install-examplesDATA: $(examples_DATA)
-+# @$(NORMAL_INSTALL)
-+# test -z "$(examplesdir)" || $(MKDIR_P) "$(DESTDIR)$(examplesdir)"
-+# @list='$(examples_DATA)'; test -n "$(examplesdir)" || list=; \
-+# for p in $$list; do \
-+# if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
-+# echo "$$d$$p"; \
-+# done | $(am__base_list) | \
-+# while read files; do \
-+# echo " $(INSTALL_DATA) $$files '$(DESTDIR)$(examplesdir)'"; \
-+# $(INSTALL_DATA) $$files "$(DESTDIR)$(examplesdir)" || exit $$?; \
-+# done
-
- uninstall-examplesDATA:
- @$(NORMAL_UNINSTALL)