aboutsummaryrefslogtreecommitdiff
path: root/graphics/a2png/Makefile
diff options
context:
space:
mode:
authorDirk Meyer <dinoex@FreeBSD.org>2020-07-24 10:05:45 +0000
committerDirk Meyer <dinoex@FreeBSD.org>2020-07-24 10:05:45 +0000
commitd49fcf66ab5db9488129c665712f88b585817c2e (patch)
tree8836f96cefc80db7b80133b16479565f8aca990a /graphics/a2png/Makefile
parent60b2de010f266526f4d1e16f3ff7587ec1bb62ca (diff)
downloadports-d49fcf66ab5db9488129c665712f88b585817c2e.tar.gz
ports-d49fcf66ab5db9488129c665712f88b585817c2e.zip
Notes
Diffstat (limited to 'graphics/a2png/Makefile')
-rw-r--r--graphics/a2png/Makefile18
1 files changed, 11 insertions, 7 deletions
diff --git a/graphics/a2png/Makefile b/graphics/a2png/Makefile
index ee3a0feefdbf..6efb8ea715b1 100644
--- a/graphics/a2png/Makefile
+++ b/graphics/a2png/Makefile
@@ -3,7 +3,7 @@
PORTNAME= a2png
PORTVERSION= 0.1.5
-PORTREVISION= 9
+PORTREVISION= 10
CATEGORIES= graphics
MASTER_SITES= SF
@@ -13,20 +13,24 @@ COMMENT= Converts plain ASCII text into PNG bitmap images
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
-LIB_DEPENDS= libgd.so:graphics/gd
+BROKEN_armv6= fails to build: parse.c:(.text+0x174): undefined reference to 'fgettok'
+BROKEN_armv7= fails to build: parse.c:(.text+0x174): undefined reference to 'fgettok'
+BROKEN_i386= fails to build: parse.c:(.text+0x135): undefined reference to 'fgettok'
-BROKEN_armv6 = fails to build: parse.c:(.text+0x174): undefined reference to 'fgettok'
-BROKEN_armv7 = fails to build: parse.c:(.text+0x174): undefined reference to 'fgettok'
-BROKEN_i386= fails to build: parse.c:(.text+0x135): undefined reference to 'fgettok'
+LIB_DEPENDS= libgd.so:graphics/gd
-USES= tar:bzip2
+USES= tar:bzip2 localbase
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --enable-gd
+CONFIGURE_ARGS= --enable-gd --with-gdlib-config-path=${WRKDIR}
CFLAGS+= -DDEFAULT_FONTPATH='\"${FONTROOTDIR}/TTF:${FONTROOTDIR}/Type1:${FONTROOTDIR}\"'
PLIST_FILES= bin/${PORTNAME} man/man1/${PORTNAME}.1.gz
FONTROOTDIR?= ${LOCALBASE}/share/fonts
+pre-configure:
+ ${ECHO_CMD} "#!/bin/sh" > ${WRKDIR}/gdlib-config
+ ${CHMOD} +x ${WRKDIR}/gdlib-config
+
do-install:
${INSTALL_PROGRAM} ${WRKSRC}/src/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
${INSTALL_MAN} ${WRKSRC}/man/${PORTNAME}.1 ${STAGEDIR}${MAN1PREFIX}/man/man1