aboutsummaryrefslogtreecommitdiff
path: root/graphics/agg
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2012-10-29 17:04:39 +0000
committerPawel Pekala <pawel@FreeBSD.org>2012-10-29 17:04:39 +0000
commite9f7e390c1eff9cdfde75ea23e17341510f57dfe (patch)
tree3809e68e26c6e94a5caa9a920eefae51fc665418 /graphics/agg
parenta3f0261fac2f36a3537d4e0832c6c64524d9c187 (diff)
downloadports-e9f7e390c1eff9cdfde75ea23e17341510f57dfe.tar.gz
ports-e9f7e390c1eff9cdfde75ea23e17341510f57dfe.zip
Fix build with clang
PR: ports/172718 Submitted by: KATO Tsuguru <tkato432@yahoo.com> Feature safe: yes
Notes
Notes: svn path=/head/; revision=306623
Diffstat (limited to 'graphics/agg')
-rw-r--r--graphics/agg/Makefile9
-rw-r--r--graphics/agg/files/patch-include__agg_renderer_outline_aa.h11
2 files changed, 13 insertions, 7 deletions
diff --git a/graphics/agg/Makefile b/graphics/agg/Makefile
index 9e39dfee5c14..c511013f8e51 100644
--- a/graphics/agg/Makefile
+++ b/graphics/agg/Makefile
@@ -1,9 +1,5 @@
-# Ports collection makefile for: agg
-# Date created: Aug 3, 2004
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= agg
PORTVERSION= 2.5
@@ -17,9 +13,8 @@ COMMENT= A High Quality Rendering Engine for C++
LICENSE= GPLv2
-LIB_DEPENDS= freetype.9:${PORTSDIR}/print/freetype2
+LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2
-USE_GCC= any
USE_XORG= x11
USE_GNOME= gnomehack
USE_SDL= sdl
diff --git a/graphics/agg/files/patch-include__agg_renderer_outline_aa.h b/graphics/agg/files/patch-include__agg_renderer_outline_aa.h
new file mode 100644
index 000000000000..5ac3989eda58
--- /dev/null
+++ b/graphics/agg/files/patch-include__agg_renderer_outline_aa.h
@@ -0,0 +1,11 @@
+--- include/agg_renderer_outline_aa.h.orig 2006-10-09 13:07:08.000000000 +0900
++++ include/agg_renderer_outline_aa.h 2012-10-13 05:25:48.000000000 +0900
+@@ -1375,7 +1375,7 @@
+ //---------------------------------------------------------------------
+ void profile(const line_profile_aa& prof) { m_profile = &prof; }
+ const line_profile_aa& profile() const { return *m_profile; }
+- line_profile_aa& profile() { return *m_profile; }
++ const line_profile_aa& profile() { return *m_profile; }
+
+ //---------------------------------------------------------------------
+ int subpixel_width() const { return m_profile->subpixel_width(); } \ No newline at end of file