aboutsummaryrefslogtreecommitdiff
path: root/graphics/alembic/Makefile
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2015-11-06 06:29:12 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2015-11-06 06:29:12 +0000
commit851e3889453671c8c28a636009a3bf3096a32406 (patch)
tree62575f8f3ffd7f9d55285b70f09c3898b5f3a323 /graphics/alembic/Makefile
parentfc22a9e78062668d289f1005205e7dc52d482c81 (diff)
Notes
Diffstat (limited to 'graphics/alembic/Makefile')
-rw-r--r--graphics/alembic/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/graphics/alembic/Makefile b/graphics/alembic/Makefile
new file mode 100644
index 000000000000..432654f31e98
--- /dev/null
+++ b/graphics/alembic/Makefile
@@ -0,0 +1,27 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= alembic
+PORTVERSION= 1.5.8
+CATEGORIES= graphics
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Open framework for storing and sharing graphic scene data
+
+LICENSE= BSD3CLAUSE
+
+LIB_DEPENDS= libboost_thread.so:${PORTSDIR}/devel/boost-libs \
+ libImath-2_2.so:${PORTSDIR}/graphics/ilmbase \
+ libhdf5.so:${PORTSDIR}/science/hdf5
+
+BROKEN_FreeBSD_9= does not build (insufficient C++11 support)
+
+USE_GITHUB= yes
+
+USES= cmake compiler:c++11-lang
+USE_CXXSTD= c++11
+USE_GL= glew glut
+
+CMAKE_ARGS= -DBUILD_SHARED_LIBS:BOOL=ON -DUSE_PYALEMBIC:BOOL=OFF
+
+.include <bsd.port.mk>