aboutsummaryrefslogtreecommitdiff
path: root/graphics/anttweakbar
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2021-03-17 22:27:32 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2021-03-17 22:27:32 +0000
commita547753b9e0a8d8b6353fd4e160f0f4b71e489f6 (patch)
tree8cda051ef1c4d1b4f9ad73cf7a2ad6137375c9c3 /graphics/anttweakbar
parentfd3c0b2448711c5a0d3a43965cb2798355517b25 (diff)
downloadports-a547753b9e0a8d8b6353fd4e160f0f4b71e489f6.tar.gz
ports-a547753b9e0a8d8b6353fd4e160f0f4b71e489f6.zip
New port: graphics/anttweakbar: C library to add light and GUI into graphic apps
Notes
Notes: svn path=/head/; revision=568692
Diffstat (limited to 'graphics/anttweakbar')
-rw-r--r--graphics/anttweakbar/Makefile43
-rw-r--r--graphics/anttweakbar/distinfo3
-rw-r--r--graphics/anttweakbar/files/patch-Makefile11
-rw-r--r--graphics/anttweakbar/pkg-descr6
4 files changed, 63 insertions, 0 deletions
diff --git a/graphics/anttweakbar/Makefile b/graphics/anttweakbar/Makefile
new file mode 100644
index 000000000000..1bb4d8dfe2d6
--- /dev/null
+++ b/graphics/anttweakbar/Makefile
@@ -0,0 +1,43 @@
+# $FreeBSD$
+
+PORTNAME= anttweakbar
+DISTVERSION= 1.16
+CATEGORIES= graphics
+MASTER_SITES= SF/${PORTNAME}/
+DISTNAME= AntTweakBar_${DISTVERSION:S/.//}
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= C library to add light and GUI into graphic apps
+
+LICENSE= ZLIB
+LICENSE_FILE= ${WRKSRC}/../License.txt
+
+USES= dos2unix gl xorg zip
+USE_GL= gl glu
+USE_XORG= x11
+USE_LDCONFIG= yes
+
+WRKSRC= ${WRKDIR}/AntTweakBar
+WRKSRC_SUBDIR= src
+
+DOS2UNIX_FILES= Makefile
+
+LDFLAGS+= -L${LOCALBASE}/lib -lX11
+
+BINARY_ALIAS= gcc=${CC}
+
+PLIST_FILES= include/AntTweakBar.h \
+ lib/libAntTweakBar.a \
+ lib/libAntTweakBar.so \
+ lib/libAntTweakBar.so.${DISTVERSION:R} \
+ lib/libAntTweakBar.so.${DISTVERSION}
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/../include/AntTweakBar.h ${STAGEDIR}${PREFIX}/include
+ ${INSTALL_DATA} ${WRKSRC}/../lib/libAntTweakBar.a ${STAGEDIR}${PREFIX}/lib
+ ${INSTALL_LIB} ${WRKSRC}/../lib/libAntTweakBar.so ${STAGEDIR}${PREFIX}/lib/libAntTweakBar.so.${DISTVERSION}
+ cd ${STAGEDIR}${PREFIX}/lib && \
+ ${LN} -s libAntTweakBar.so.${DISTVERSION} libAntTweakBar.so.${DISTVERSION:R} && \
+ ${LN} -s libAntTweakBar.so.${DISTVERSION} libAntTweakBar.so
+
+.include <bsd.port.mk>
diff --git a/graphics/anttweakbar/distinfo b/graphics/anttweakbar/distinfo
new file mode 100644
index 000000000000..11ab49d109c6
--- /dev/null
+++ b/graphics/anttweakbar/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1616015883
+SHA256 (AntTweakBar_116.zip) = fbceb719c13ceb13b9fd973840c2c950527b6e026f9a7a80968c14f76fcf6e7c
+SIZE (AntTweakBar_116.zip) = 4492138
diff --git a/graphics/anttweakbar/files/patch-Makefile b/graphics/anttweakbar/files/patch-Makefile
new file mode 100644
index 000000000000..ba4dc6f9b603
--- /dev/null
+++ b/graphics/anttweakbar/files/patch-Makefile
@@ -0,0 +1,11 @@
+--- Makefile.orig 2021-03-17 22:07:56 UTC
++++ Makefile
+@@ -66,7 +66,7 @@ all: Makefile $(TARGET)
+
+ $(TARGET): $(OBJS)
+ @echo "===== Link $@ ====="
+- $(LINK) $(LFLAGS) -shared -Wl,-soname,lib$(TARGET)$(SO_EXT).$(SO_VERSION) -o $(OUT_DIR)/lib$(TARGET)$(SO_EXT) $(OBJS) $(LIBS)
++ $(LINK) $(LFLAGS) -shared -Wl,-soname,lib$(TARGET)$(SO_EXT).$(SO_VERSION) -o $(OUT_DIR)/lib$(TARGET)$(SO_EXT) $(OBJS) $(LIBS) $(LDFLAGS)
+ $(SYMLINK) $(OUT_DIR)/lib$(TARGET)$(SO_EXT) $(OUT_DIR)/lib$(TARGET)$(SO_EXT).$(SO_VERSION)
+ $(AR) $(OUT_DIR)/lib$(TARGET)$(AR_EXT) $(OBJS) $(LIBS)
+
diff --git a/graphics/anttweakbar/pkg-descr b/graphics/anttweakbar/pkg-descr
new file mode 100644
index 000000000000..b7e3d5a0020b
--- /dev/null
+++ b/graphics/anttweakbar/pkg-descr
@@ -0,0 +1,6 @@
+AntTweakBar is a small and easy-to-use C/C++ library that allows programmers to
+quickly add a light and intuitive graphical user interface into graphic
+applications based on OpenGL (compatibility and core profiles), DirectX 9,
+DirectX 10 or DirectX 11 to interactively tweak parameters on-screen.
+
+WWW: http://anttweakbar.sourceforge.net/doc/