aboutsummaryrefslogtreecommitdiff
path: root/graphics/apngasm
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2010-05-13 14:47:58 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2010-05-13 14:47:58 +0000
commita62adac27820d2baf130774f154bcb45015fb3e6 (patch)
treea57bfdd07341c4ec4990672ee443a844c1ba9c0d /graphics/apngasm
parent0e050d80bd605c6c5507b01cc7dd36dd0a6c8064 (diff)
downloadports-a62adac27820d2baf130774f154bcb45015fb3e6.tar.gz
ports-a62adac27820d2baf130774f154bcb45015fb3e6.zip
Notes
Diffstat (limited to 'graphics/apngasm')
-rw-r--r--graphics/apngasm/Makefile32
-rw-r--r--graphics/apngasm/distinfo3
-rw-r--r--graphics/apngasm/files/patch-bswap13
-rw-r--r--graphics/apngasm/pkg-descr4
4 files changed, 52 insertions, 0 deletions
diff --git a/graphics/apngasm/Makefile b/graphics/apngasm/Makefile
new file mode 100644
index 000000000000..6c663523395a
--- /dev/null
+++ b/graphics/apngasm/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: apngasm
+# Date created: 02 May 2010
+# Whom: Anonymous <swell.k@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= apngasm
+PORTVERSION= 2.0
+DISTVERSIONSUFFIX=-src
+CATEGORIES= graphics
+MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}
+
+MAINTAINER= swell.k@gmail.com
+COMMENT= Create Animated PNG from a sequence of files
+
+LIB_DEPENDS= png.6:${PORTSDIR}/graphics/png
+
+USE_ZIP= yes
+USE_DOS2UNIX= yes
+NO_WRKSUBDIR= yes
+
+ALL_TARGET= ${PORTNAME}
+MAKEFILE= /dev/null
+CFLAGS+= -I${LOCALBASE}/include -lpng -lz -L${LOCALBASE}/lib
+
+PLIST_FILES= bin/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${PREFIX}/bin/
+
+.include <bsd.port.mk>
diff --git a/graphics/apngasm/distinfo b/graphics/apngasm/distinfo
new file mode 100644
index 000000000000..7d5e340a3ec9
--- /dev/null
+++ b/graphics/apngasm/distinfo
@@ -0,0 +1,3 @@
+MD5 (apngasm-2.0-src.zip) = eacbeb064219c6e7fe490abe788ab385
+SHA256 (apngasm-2.0-src.zip) = cc8c33c42115273dc63b7763f8c0b3ab5ec891420fb3ad794b44ade104118c19
+SIZE (apngasm-2.0-src.zip) = 6807
diff --git a/graphics/apngasm/files/patch-bswap b/graphics/apngasm/files/patch-bswap
new file mode 100644
index 000000000000..1b1ba20c2a4d
--- /dev/null
+++ b/graphics/apngasm/files/patch-bswap
@@ -0,0 +1,13 @@
+--- apngasm.c~
++++ apngasm.c
+@@ -39,6 +39,10 @@ inline unsigned int swap32(unsigned int
+ #include <byteswap.h>
+ inline unsigned short swap16(unsigned short data) {return(bswap_16(data));}
+ inline unsigned int swap32(unsigned int data) {return(bswap_32(data));}
++#elif defined(__FreeBSD__)
++#include <sys/endian.h>
++inline unsigned short swap16(unsigned short data) {return(bswap16(data));}
++inline unsigned int swap32(unsigned int data) {return(bswap32(data));}
+ #else
+ inline unsigned short swap16(unsigned short data) {return((data >> 8) | (data << 8));}
+ inline unsigned int swap32(unsigned int data) {return((swap16(data) << 16) | swap16(data >> 16));}
diff --git a/graphics/apngasm/pkg-descr b/graphics/apngasm/pkg-descr
new file mode 100644
index 000000000000..a5838bc276c1
--- /dev/null
+++ b/graphics/apngasm/pkg-descr
@@ -0,0 +1,4 @@
+Standalone version of the popular APNG Assembler. Simple command-line
+interface. No size limits.
+
+WWW: http://sourceforge.net/projects/apngasm/