aboutsummaryrefslogtreecommitdiff
path: root/graphics/appleseed
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2021-03-04 13:56:44 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2021-03-04 13:56:44 +0000
commit34b1a8d927141fa7703a65daa443e70e39da5ffa (patch)
tree0b44daf13a97dbbe9187325e606568d4462b878f /graphics/appleseed
parent6f5105de9564ca40c49a51dcbe74d6ea3e1282f5 (diff)
downloadports-34b1a8d927141fa7703a65daa443e70e39da5ffa.tar.gz
ports-34b1a8d927141fa7703a65daa443e70e39da5ffa.zip
- Resurrect, unbreak, and update to the latest version 2.1.0-beta
- Disable appleseed.studio for now: while it had been ported to Qt5, it still heavily relies on Python 2.x - Drop the options: C++11 is required now, and API examples are of little interest to end-users so just stop installing them - Add dependencies on `archivers/liblz4' and `graphics/openimageio' - GC no longer needed work-arounds for old versions of Clang
Notes
Notes: svn path=/head/; revision=567314
Diffstat (limited to 'graphics/appleseed')
-rw-r--r--graphics/appleseed/Makefile54
-rw-r--r--graphics/appleseed/distinfo3
-rw-r--r--graphics/appleseed/files/patch-CMakeLists.txt31
-rw-r--r--graphics/appleseed/files/patch-cmake_config_linux-gcc-clang.txt15
-rw-r--r--graphics/appleseed/files/patch-src_appleseed.studio_mainwindow_project_texturecollectionitem.cpp19
-rw-r--r--graphics/appleseed/files/patch-src_appleseed_foundation_platform_path.h10
-rw-r--r--graphics/appleseed/files/patch-src_appleseed_foundation_platform_system.cpp82
-rw-r--r--graphics/appleseed/files/patch-src_appleseed_foundation_utility_benchmark_benchmarkaggregator.cpp10
-rw-r--r--graphics/appleseed/files/pkg-message.in6
-rw-r--r--graphics/appleseed/pkg-descr11
-rw-r--r--graphics/appleseed/pkg-plist278
11 files changed, 519 insertions, 0 deletions
diff --git a/graphics/appleseed/Makefile b/graphics/appleseed/Makefile
new file mode 100644
index 000000000000..5579d82b4dd4
--- /dev/null
+++ b/graphics/appleseed/Makefile
@@ -0,0 +1,54 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= appleseed
+DISTVERSION= 2.1.0-beta
+CATEGORIES= graphics
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Modern, physically-based production renderer
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
+ liblz4.so:archivers/liblz4 \
+ libpng.so:graphics/png \
+ libIlmImf.so:graphics/openexr \
+ libOpenImageIO.so:graphics/openimageio \
+ libxerces-c.so:textproc/xerces-c3 \
+ liboslexec.so:graphics/openshadinglanguage
+
+USE_GITHUB= yes
+GH_ACCOUNT= ${PORTNAME}hq
+
+ONLY_FOR_ARCHS= i386 amd64
+ONLY_FOR_ARCHS_REASON= not ported to it yet
+
+USES= cmake compiler:c++11-lang
+
+CMAKE_ARGS= -DWITH_STUDIO:BOOL=OFF \
+ -DWITH_PYTHON2_BINDINGS:BOOL=OFF \
+ -DWITH_PYTHON3_BINDINGS:BOOL=OFF \
+ -DWITH_DOXYGEN:BOOL=OFF \
+ -DINSTALL_HEADERS:BOOL=OFF \
+ -DINSTALL_TESTS:BOOL=OFF \
+ -DINSTALL_API_EXAMPLES:BOOL=OFF \
+ -DWARNINGS_AS_ERRORS:BOOL=OFF
+
+.for lib in BOOST EMBREE EXR OCIO OIIO OSL
+CMAKE_ARGS+= -DUSE_STATIC_${lib}:BOOL=OFF
+.endfor
+
+# Not ready for hier(7)-conforming installation yet
+CMAKE_INSTALL_PREFIX= ${PREFIX}/${PKGBASE}
+PLIST_SUB= APPHOME=${CMAKE_INSTALL_PREFIX}
+
+SUB_FILES= pkg-message
+SUB_LIST:= ${PLIST_SUB}
+
+post-patch:
+ @${RMDIR} ${WRKSRC}/sandbox/docs/api
+ @${RM} ${WRKSRC}/sandbox/share/cmake/Modules/FindOpenImageIO.cmake
+
+.include <bsd.port.mk>
diff --git a/graphics/appleseed/distinfo b/graphics/appleseed/distinfo
new file mode 100644
index 000000000000..0cce5a17b714
--- /dev/null
+++ b/graphics/appleseed/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1567266541
+SHA256 (appleseedhq-appleseed-2.1.0-beta_GH0.tar.gz) = 5f8599c64a9c1dbdf0d8ee13a4d395b03e9bcba17fec731526109437ab760898
+SIZE (appleseedhq-appleseed-2.1.0-beta_GH0.tar.gz) = 203650426
diff --git a/graphics/appleseed/files/patch-CMakeLists.txt b/graphics/appleseed/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..e400f28c1464
--- /dev/null
+++ b/graphics/appleseed/files/patch-CMakeLists.txt
@@ -0,0 +1,31 @@
+--- CMakeLists.txt.orig 2019-08-31 15:49:01 UTC
++++ CMakeLists.txt
+@@ -732,9 +732,16 @@ install (
+ sandbox/share
+ sandbox/stylesheets
+ DESTINATION .
++ PATTERN "cmake" EXCLUDE
+ )
+
+ install (
++ DIRECTORY
++ sandbox/share/cmake
++ DESTINATION ../share
++)
++
++install (
+ FILES
+ scripts/cleanmany.py
+ scripts/convertmany.py
+@@ -754,11 +761,6 @@ install (
+ sandbox/schemas/settings.xsd
+ sandbox/schemas/project.xsd
+ DESTINATION schemas
+-)
+-
+-install (
+- CODE "FILE (MAKE_DIRECTORY ${CMAKE_INSTALL_PREFIX}/images)"
+- CODE "FILE (MAKE_DIRECTORY ${CMAKE_INSTALL_PREFIX}/images/autosave)"
+ )
+
+ if (INSTALL_HEADERS)
diff --git a/graphics/appleseed/files/patch-cmake_config_linux-gcc-clang.txt b/graphics/appleseed/files/patch-cmake_config_linux-gcc-clang.txt
new file mode 100644
index 000000000000..239885b5b40d
--- /dev/null
+++ b/graphics/appleseed/files/patch-cmake_config_linux-gcc-clang.txt
@@ -0,0 +1,15 @@
+--- cmake/config/linux-gcc-clang.txt.orig 2019-08-31 15:49:01 UTC
++++ cmake/config/linux-gcc-clang.txt
+@@ -150,12 +150,6 @@ if (HIDE_SYMBOLS)
+ )
+ endif ()
+
+-# Release configuration.
+-set (c_compiler_flags_release
+- -O3 # optimization level
+- -fgcse-las # Eliminates stores followed by a load to the same positions.
+- -fgcse-sm # Moves load/save instructions out of loops, if possible.
+-)
+
+
+ #--------------------------------------------------------------------------------------------------
diff --git a/graphics/appleseed/files/patch-src_appleseed.studio_mainwindow_project_texturecollectionitem.cpp b/graphics/appleseed/files/patch-src_appleseed.studio_mainwindow_project_texturecollectionitem.cpp
new file mode 100644
index 000000000000..b2ff1793384c
--- /dev/null
+++ b/graphics/appleseed/files/patch-src_appleseed.studio_mainwindow_project_texturecollectionitem.cpp
@@ -0,0 +1,19 @@
+--- src/appleseed.studio/mainwindow/project/texturecollectionitem.cpp.orig 2015-06-13 09:38:53 UTC
++++ src/appleseed.studio/mainwindow/project/texturecollectionitem.cpp
+@@ -108,11 +108,15 @@ namespace
+ texture_params.insert("filename", path);
+ texture_params.insert("color_space", "srgb");
+
++ // Workaround for GCC 4.2.1: we cannot construct object in .create() below
++ // because GCC will attempt to invoke copy ctor which is private of course.
++ SearchPaths paths;
++
+ return
+ DiskTexture2dFactory().create(
+ texture_name.c_str(),
+ texture_params,
+- SearchPaths());
++ paths);
+ }
+
+ auto_release_ptr<TextureInstance> create_texture_instance(const string& texture_name)
diff --git a/graphics/appleseed/files/patch-src_appleseed_foundation_platform_path.h b/graphics/appleseed/files/patch-src_appleseed_foundation_platform_path.h
new file mode 100644
index 000000000000..50af8e0ac84b
--- /dev/null
+++ b/graphics/appleseed/files/patch-src_appleseed_foundation_platform_path.h
@@ -0,0 +1,10 @@
+--- src/appleseed/foundation/platform/path.h.orig 2019-08-31 15:49:01 UTC
++++ src/appleseed/foundation/platform/path.h
+@@ -40,6 +40,7 @@
+ #include "main/dllsymbol.h"
+
+ // Boost headers.
++#include "boost/filesystem/exception.hpp"
+ #include "boost/filesystem/operations.hpp"
+ #include "boost/filesystem/path.hpp"
+
diff --git a/graphics/appleseed/files/patch-src_appleseed_foundation_platform_system.cpp b/graphics/appleseed/files/patch-src_appleseed_foundation_platform_system.cpp
new file mode 100644
index 000000000000..eba46ae41e78
--- /dev/null
+++ b/graphics/appleseed/files/patch-src_appleseed_foundation_platform_system.cpp
@@ -0,0 +1,82 @@
+--- src/appleseed/foundation/platform/system.cpp.orig 2019-08-31 15:49:01 UTC
++++ src/appleseed/foundation/platform/system.cpp
+@@ -548,6 +548,13 @@ namespace
+ "=d" (regs[edx]));
+ }
+
++ uint64 xgetbv(const int32 index)
++ {
++ uint32 eax, edx;
++ __asm__ __volatile__("xgetbv" : "=a"(eax), "=d"(edx) : "c"(index));
++ return (static_cast<uint64>(edx) << 32) | eax;
++ }
++
+ #define BIT(n) (1UL << (n))
+ #define BITMASK(h, l) ((BIT(h) | (BIT(h) - 1)) & ~(BIT(l) - 1))
+ #define BITFIELD(x, h, l) (((x) & BITMASK(h, l)) >> l)
+@@ -1077,7 +1084,8 @@ namespace
+ // Reference: http://stackoverflow.com/a/22521619/922184
+
+ uint32 cpuinfo[4];
+- cpuid(cpuinfo, 1);
++ cpuinfo[0] = 1;
++ cpuid(cpuinfo);
+
+ const bool os_uses_xsave_xrstor = (cpuinfo[2] & (1UL << 27)) != 0;
+ const bool cpu_avx_support = (cpuinfo[2] & (1UL << 28)) != 0;
+@@ -1105,7 +1113,8 @@ namespace
+ char vendor[13];
+
+ uint32 cpuinfo[4];
+- cpuid(cpuinfo, 0);
++ cpuinfo[0] = 0;
++ cpuid(cpuinfo);
+
+ memcpy(vendor + 0, &cpuinfo[1], 4);
+ memcpy(vendor + 4, &cpuinfo[3], 4);
+@@ -1134,13 +1143,15 @@ void System::detect_x86_cpu_features(X86CPUFeatures& f
+
+ // EAX=0: Get vendor ID.
+ uint32 cpuinfo[4];
+- cpuid(cpuinfo, 0x00000000);
++ cpuinfo[0] = 0;
++ cpuid(cpuinfo);
+ const uint32 highest_function_id = cpuinfo[0];
+
+ if (highest_function_id >= 0x00000001)
+ {
+ // EAX=1: Processor Info and Feature Bits.
+- cpuid(cpuinfo, 0x00000001);
++ cpuinfo[0] = 1;
++ cpuid(cpuinfo);
+ features.m_hw_mmx = (cpuinfo[3] & (1UL << 23)) != 0;
+ features.m_hw_sse = (cpuinfo[3] & (1UL << 25)) != 0;
+ features.m_hw_sse2 = (cpuinfo[3] & (1UL << 26)) != 0;
+@@ -1158,7 +1169,8 @@ void System::detect_x86_cpu_features(X86CPUFeatures& f
+ if (highest_function_id >= 0x00000007)
+ {
+ // EAX=7: Extended Features.
+- cpuid(cpuinfo, 0x00000007);
++ cpuinfo[0] = 7;
++ cpuid(cpuinfo);
+ features.m_hw_avx2 = (cpuinfo[1] & (1UL << 5)) != 0;
+ features.m_hw_bmi1 = (cpuinfo[1] & (1UL << 3)) != 0;
+ features.m_hw_bmi2 = (cpuinfo[1] & (1UL << 8)) != 0;
+@@ -1178,13 +1190,15 @@ void System::detect_x86_cpu_features(X86CPUFeatures& f
+ }
+
+ // EAX=0x80000000: Get Highest Extended Function Supported.
+- cpuid(cpuinfo, 0x80000000);
++ cpuinfo[0] = 0x80000000;
++ cpuid(cpuinfo);
+ const uint32 highest_ext_function_id = cpuinfo[0];
+
+ if (highest_ext_function_id >= 0x80000001)
+ {
+ // EAX=0x80000001: Extended Processor Info and Feature Bits.
+- cpuid(cpuinfo, 0x80000001);
++ cpuinfo[0] = 0x80000001;
++ cpuid(cpuinfo);
+ features.m_hw_x64 = (cpuinfo[3] & (1UL << 29)) != 0;
+ features.m_hw_abm = (cpuinfo[2] & (1UL << 5)) != 0;
+ features.m_hw_sse4a = (cpuinfo[2] & (1UL << 6)) != 0;
diff --git a/graphics/appleseed/files/patch-src_appleseed_foundation_utility_benchmark_benchmarkaggregator.cpp b/graphics/appleseed/files/patch-src_appleseed_foundation_utility_benchmark_benchmarkaggregator.cpp
new file mode 100644
index 000000000000..4cd37f37d946
--- /dev/null
+++ b/graphics/appleseed/files/patch-src_appleseed_foundation_utility_benchmark_benchmarkaggregator.cpp
@@ -0,0 +1,10 @@
+--- src/appleseed/foundation/utility/benchmark/benchmarkaggregator.cpp.orig 2019-08-31 15:49:01 UTC
++++ src/appleseed/foundation/utility/benchmark/benchmarkaggregator.cpp
+@@ -40,6 +40,7 @@
+
+ // Boost headers.
+ #include "boost/date_time/posix_time/posix_time.hpp"
++#include "boost/filesystem/directory.hpp"
+ #include "boost/filesystem/operations.hpp"
+ #include "boost/filesystem/path.hpp"
+ #include "boost/regex.hpp"
diff --git a/graphics/appleseed/files/pkg-message.in b/graphics/appleseed/files/pkg-message.in
new file mode 100644
index 000000000000..2cfd586ec48d
--- /dev/null
+++ b/graphics/appleseed/files/pkg-message.in
@@ -0,0 +1,6 @@
+appleseed currently requires itself to be installed under common prefix:
+%%APPHOME%%. To run CLI or GUI version, execute the following
+commands, respectively:
+
+ %%APPHOME%%/bin/appleseed.cli
+ %%APPHOME%%/bin/appleseed.studio
diff --git a/graphics/appleseed/pkg-descr b/graphics/appleseed/pkg-descr
new file mode 100644
index 000000000000..e26303322fb4
--- /dev/null
+++ b/graphics/appleseed/pkg-descr
@@ -0,0 +1,11 @@
+appleseed is modern, open source, physically-based rendering engine designed
+to produce photorealistic images, animations, and visual effects.
+
+It provides individuals and small studios with an efficient, reliable suite
+of tools built on robust foundations and open technologies.
+
+Started in 2009, it has grown into a robust production rendering toolset and
+has been battle-tested on several projects such as TV documentaries, ads,
+promotional videos, and animation shorts.
+
+WWW: https://appleseedhq.net/
diff --git a/graphics/appleseed/pkg-plist b/graphics/appleseed/pkg-plist
new file mode 100644
index 000000000000..cb44d6c44a41
--- /dev/null
+++ b/graphics/appleseed/pkg-plist
@@ -0,0 +1,278 @@
+share/cmake/Modules/FindAppleseed.cmake
+share/cmake/Modules/FindImath.cmake
+share/cmake/Modules/FindOSL.cmake
+share/cmake/Modules/FindOpenEXR.cmake
+share/cmake/Modules/FindPartio.cmake
+share/cmake/Modules/FindSeExpr.cmake
+share/cmake/Modules/FindSeExprEditor.cmake
+share/cmake/Modules/FindXerces.cmake
+@cwd %%APPHOME%%
+bin/animatecamera
+bin/appleseed.cli
+bin/cleanmany.py
+bin/convertmany.py
+bin/convertmeshfile
+bin/denoiser
+bin/dumpmetadata
+bin/idiff
+bin/makefluffy
+bin/maketx
+bin/oiiotool
+bin/oslc
+bin/oslinfo
+bin/projecttool
+bin/rendermanager.py
+bin/rendermany.py
+bin/rendernode.py
+docs/osl/osl-languagespec.pdf
+docs/seexpr/Se_voronoi_1.png
+docs/seexpr/Se_voronoi_2.png
+docs/seexpr/Se_voronoi_3.png
+docs/seexpr/Se_voronoi_4.png
+docs/seexpr/Se_voronoi_5.png
+docs/seexpr/userdoc.html
+icons/appleseed.png
+icons/disney_expression.png
+icons/disney_expression_hover.png
+icons/disney_texture.png
+icons/disney_texture_hover.png
+icons/lightpathstab_next_light_path.png
+icons/lightpathstab_next_light_path_disabled.png
+icons/lightpathstab_next_light_path_hover.png
+icons/lightpathstab_prev_light_path.png
+icons/lightpathstab_prev_light_path_disabled.png
+icons/lightpathstab_prev_light_path_hover.png
+icons/lightpathstab_save_light_paths.png
+icons/lightpathstab_save_light_paths_disabled.png
+icons/lightpathstab_save_light_paths_hover.png
+icons/lightpathstab_synchronize_camera.png
+icons/lightpathstab_synchronize_camera_hover.png
+icons/lightpathstab_toggle_backface_culling.png
+icons/lightpathstab_toggle_backface_culling_hover.png
+icons/project_monitor.png
+icons/project_monitor_disabled.png
+icons/project_monitor_hover.png
+icons/project_new.png
+icons/project_new_disabled.png
+icons/project_new_hover.png
+icons/project_open.png
+icons/project_open_disabled.png
+icons/project_open_hover.png
+icons/project_reload.png
+icons/project_reload_disabled.png
+icons/project_reload_hover.png
+icons/project_save.png
+icons/project_save_disabled.png
+icons/project_save_hover.png
+icons/python_clear_output.png
+icons/python_clear_output_hover.png
+icons/python_execute_all.png
+icons/python_execute_all_hover.png
+icons/python_execute_selection.png
+icons/python_execute_selection_disabled.png
+icons/python_execute_selection_hover.png
+icons/render_asMatte.png
+icons/rendering_pause_resume.png
+icons/rendering_pause_resume_disabled.png
+icons/rendering_pause_resume_hover.png
+icons/rendering_settings.png
+icons/rendering_settings_disabled.png
+icons/rendering_settings_hover.png
+icons/rendering_start_final.png
+icons/rendering_start_final_disabled.png
+icons/rendering_start_final_hover.png
+icons/rendering_start_interactive.png
+icons/rendering_start_interactive_disabled.png
+icons/rendering_start_interactive_hover.png
+icons/rendering_stop.png
+icons/rendering_stop_disabled.png
+icons/rendering_stop_hover.png
+icons/rendertab_clear_frame.png
+icons/rendertab_clear_frame_disabled.png
+icons/rendertab_clear_frame_hover.png
+icons/rendertab_clear_render_region.png
+icons/rendertab_clear_render_region_disabled.png
+icons/rendertab_clear_render_region_hover.png
+icons/rendertab_quicksave_all_aovs.png
+icons/rendertab_quicksave_all_aovs_hover.png
+icons/rendertab_reset_zoom.png
+icons/rendertab_reset_zoom_hover.png
+icons/rendertab_save_all_aovs.png
+icons/rendertab_save_all_aovs_hover.png
+icons/rendertab_set_render_region.png
+icons/rendertab_set_render_region_disabled.png
+icons/rendertab_set_render_region_hover.png
+icons/rendertab_toggle_pixel_inspector.png
+icons/rendertab_toggle_pixel_inspector_hover.png
+lib/libappleseed.shared.so
+lib/libappleseed.so
+schemas/project.xsd
+schemas/settings.xsd
+settings/appleseed.cli.xml
+settings/appleseed.studio.xml
+settings/appleseed.tools.xml
+shaders/appleseed/as_anisotropy_vector_field.oso
+shaders/appleseed/as_asc_cdl.oso
+shaders/appleseed/as_attributes.oso
+shaders/appleseed/as_blackbody.oso
+shaders/appleseed/as_blend_color.oso
+shaders/appleseed/as_blend_shader.oso
+shaders/appleseed/as_bump.oso
+shaders/appleseed/as_closure2surface.oso
+shaders/appleseed/as_color_transform.oso
+shaders/appleseed/as_composite_color.oso
+shaders/appleseed/as_create_mask.oso
+shaders/appleseed/as_disney_material.oso
+shaders/appleseed/as_double_shade.oso
+shaders/appleseed/as_falloff_angle.oso
+shaders/appleseed/as_fresnel.oso
+shaders/appleseed/as_glass.oso
+shaders/appleseed/as_globals.oso
+shaders/appleseed/as_id_manifold.oso
+shaders/appleseed/as_invert_color.oso
+shaders/appleseed/as_luminance.oso
+shaders/appleseed/as_manifold2d.oso
+shaders/appleseed/as_matte.oso
+shaders/appleseed/as_metal.oso
+shaders/appleseed/as_noise2d.oso
+shaders/appleseed/as_noise3d.oso
+shaders/appleseed/as_plastic.oso
+shaders/appleseed/as_ray_switch.oso
+shaders/appleseed/as_sbs_pbrmaterial.oso
+shaders/appleseed/as_space_transform.oso
+shaders/appleseed/as_standard_surface.oso
+shaders/appleseed/as_subsurface.oso
+shaders/appleseed/as_switch_surface.oso
+shaders/appleseed/as_switch_texture.oso
+shaders/appleseed/as_swizzle.oso
+shaders/appleseed/as_texture.oso
+shaders/appleseed/as_texture2surface.oso
+shaders/appleseed/as_texture3d.oso
+shaders/appleseed/as_texture_info.oso
+shaders/appleseed/as_toon.oso
+shaders/appleseed/as_triplanar.oso
+shaders/appleseed/as_vary_color.oso
+shaders/appleseed/as_voronoi2d.oso
+shaders/appleseed/as_voronoi3d.oso
+shaders/as_osl_extensions.h
+shaders/blenderseed/as_blender_areaLight.oso
+shaders/include/appleseed/color/as_chromatic_adaptation.h
+shaders/include/appleseed/color/as_color_blend_modes.h
+shaders/include/appleseed/color/as_color_helpers.h
+shaders/include/appleseed/color/as_color_transforms.h
+shaders/include/appleseed/color/as_colorimetry.h
+shaders/include/appleseed/color/as_transfer_functions.h
+shaders/include/appleseed/fractal/as_fractal_helpers.h
+shaders/include/appleseed/fractal/as_noise_helpers.h
+shaders/include/appleseed/material/as_material_helpers.h
+shaders/include/appleseed/math/as_math_complex.h
+shaders/include/appleseed/math/as_math_helpers.h
+shaders/include/appleseed/maya/as_maya_cms_syncolor_idt.h
+shaders/include/appleseed/maya/as_maya_fractal_helpers.h
+shaders/include/appleseed/maya/as_maya_helpers.h
+shaders/include/appleseed/maya/as_maya_layer_helpers.h
+shaders/include/appleseed/maya/as_maya_pattern_helpers.h
+shaders/include/appleseed/maya/as_maya_ramp_helpers.h
+shaders/include/appleseed/maya/as_maya_recurrence_helpers.h
+shaders/include/appleseed/maya/as_maya_recurrence_tables.h
+shaders/include/appleseed/maya/as_maya_transform_helpers.h
+shaders/include/appleseed/pattern/as_pattern_helpers.h
+shaders/include/appleseed/transform/as_transform_helpers.h
+shaders/max/as_max_blend_material.oso
+shaders/max/as_max_bump_map.oso
+shaders/max/as_max_closure2surface.oso
+shaders/max/as_max_color_balance.oso
+shaders/max/as_max_color_texture.oso
+shaders/max/as_max_disney_material.oso
+shaders/max/as_max_float_texture.oso
+shaders/max/as_max_glass_material.oso
+shaders/max/as_max_light_material.oso
+shaders/max/as_max_metal_material.oso
+shaders/max/as_max_normal_map.oso
+shaders/max/as_max_plastic_material.oso
+shaders/max/as_max_srgb_to_linear_rgb.oso
+shaders/max/as_max_sss_material.oso
+shaders/max/as_max_uv_transform.oso
+shaders/maya/as_maya_addDoubleLinear.oso
+shaders/maya/as_maya_addMatrix.oso
+shaders/maya/as_maya_anisotropic.oso
+shaders/maya/as_maya_areaLight.oso
+shaders/maya/as_maya_blendColors.oso
+shaders/maya/as_maya_blinn.oso
+shaders/maya/as_maya_brownian.oso
+shaders/maya/as_maya_bulge.oso
+shaders/maya/as_maya_bump2d.oso
+shaders/maya/as_maya_bump3d.oso
+shaders/maya/as_maya_checker.oso
+shaders/maya/as_maya_clamp.oso
+shaders/maya/as_maya_clearCoat.oso
+shaders/maya/as_maya_cloth.oso
+shaders/maya/as_maya_cloud.oso
+shaders/maya/as_maya_color2Components.oso
+shaders/maya/as_maya_components2Color.oso
+shaders/maya/as_maya_components2UV.oso
+shaders/maya/as_maya_components2Vector.oso
+shaders/maya/as_maya_condition.oso
+shaders/maya/as_maya_contrast.oso
+shaders/maya/as_maya_crater.oso
+shaders/maya/as_maya_distanceBetween.oso
+shaders/maya/as_maya_doubleShadingSwitch.oso
+shaders/maya/as_maya_envChrome.oso
+shaders/maya/as_maya_file.oso
+shaders/maya/as_maya_fourByFourMatrix.oso
+shaders/maya/as_maya_fractal.oso
+shaders/maya/as_maya_gammaCorrect.oso
+shaders/maya/as_maya_granite.oso
+shaders/maya/as_maya_grid.oso
+shaders/maya/as_maya_hsvToRgb.oso
+shaders/maya/as_maya_lambert.oso
+shaders/maya/as_maya_layeredTexture.oso
+shaders/maya/as_maya_luminance.oso
+shaders/maya/as_maya_mandelbrot.oso
+shaders/maya/as_maya_marble.oso
+shaders/maya/as_maya_matrixInverse.oso
+shaders/maya/as_maya_mountain.oso
+shaders/maya/as_maya_movie.oso
+shaders/maya/as_maya_multDoubleLinear.oso
+shaders/maya/as_maya_multMatrix.oso
+shaders/maya/as_maya_multiplyDivide.oso
+shaders/maya/as_maya_noise.oso
+shaders/maya/as_maya_phong.oso
+shaders/maya/as_maya_phongE.oso
+shaders/maya/as_maya_place2dTexture.oso
+shaders/maya/as_maya_place3dTexture.oso
+shaders/maya/as_maya_plusMinusAverage.oso
+shaders/maya/as_maya_psdFileTex.oso
+shaders/maya/as_maya_quadShadingSwitch.oso
+shaders/maya/as_maya_ramp.oso
+shaders/maya/as_maya_remapColor.oso
+shaders/maya/as_maya_remapHsv.oso
+shaders/maya/as_maya_remapValue.oso
+shaders/maya/as_maya_reverse.oso
+shaders/maya/as_maya_rgbToHsv.oso
+shaders/maya/as_maya_rock.oso
+shaders/maya/as_maya_samplerInfo.oso
+shaders/maya/as_maya_setRange.oso
+shaders/maya/as_maya_simplexNoise.oso
+shaders/maya/as_maya_singleShadingSwitch.oso
+shaders/maya/as_maya_snow.oso
+shaders/maya/as_maya_solidFractal.oso
+shaders/maya/as_maya_stencil.oso
+shaders/maya/as_maya_stucco.oso
+shaders/maya/as_maya_transposeMatrix.oso
+shaders/maya/as_maya_tripleShadingSwitch.oso
+shaders/maya/as_maya_uv2Components.oso
+shaders/maya/as_maya_vector2Components.oso
+shaders/maya/as_maya_vectorProduct.oso
+shaders/maya/as_maya_volumeNoise.oso
+shaders/maya/as_maya_water.oso
+shaders/maya/as_maya_wood.oso
+shaders/maya/as_maya_wtAddMatrix.oso
+shaders/oslutil.h
+shaders/stdosl.h
+share/aspaths2json.py
+share/mitsuba2appleseed.py
+share/rfmdisneypresets2appleseed.py
+share/substancepainter_presets/appleseed UDIM.spexp
+share/substancepainter_presets/appleseed.spexp
+stylesheets/default.qss