aboutsummaryrefslogtreecommitdiff
path: root/graphics/appleseed
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2015-09-01 15:17:07 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2015-09-01 15:17:07 +0000
commit3fcf73c327a77e577d54db73ffc75f50b941c921 (patch)
tree5022af80e854d3da8725e2fd98610837b003a448 /graphics/appleseed
parent42f6bafd91dc3e78c16302e806cbafc165b94630 (diff)
downloadports-3fcf73c327a77e577d54db73ffc75f50b941c921.tar.gz
ports-3fcf73c327a77e577d54db73ffc75f50b941c921.zip
Fix mysterious linking problems with bundled LZ4 code: it was due to the
fact that I had `archivers/liblz4' installed locally, and its header was picked up before the bundled one which has "static inline" definition of LZ4_compressBound() function vs. normal definition in system-wide header.
Notes
Notes: svn path=/head/; revision=395765
Diffstat (limited to 'graphics/appleseed')
-rw-r--r--graphics/appleseed/Makefile10
-rw-r--r--graphics/appleseed/files/patch-CMakeLists.txt24
2 files changed, 22 insertions, 12 deletions
diff --git a/graphics/appleseed/Makefile b/graphics/appleseed/Makefile
index a808df98fe15..d55d614b967f 100644
--- a/graphics/appleseed/Makefile
+++ b/graphics/appleseed/Makefile
@@ -40,15 +40,7 @@ PLIST_SUB= APPHOME=${CMAKE_INSTALL_PREFIX}
SUB_FILES= pkg-message
SUB_LIST:= ${PLIST_SUB}
-.include <bsd.port.pre.mk>
-
post-patch:
-.if ${OPSYS} == FreeBSD && ${OSVERSION} >= 1100074
-# Fix "undefined reference to `LZ4_compressBound'" upon linking with Clang
-# on -CURRENT (I'm not sure how it can be mapped to specific Clang version)
- @${REINPLACE_CMD} -e '/LZ4_compressBound/s,static inline ,,' \
- ${WRKSRC}/src/lz4/lz4.h
-.endif
@${REINPLACE_CMD} -e 's,Linux,${OPSYS},' \
${WRKSRC}/src/appleseed.cli/CMakeLists.txt \
${WRKSRC}/src/appleseed.studio/CMakeLists.txt \
@@ -59,4 +51,4 @@ post-patch:
${WRKSRC}/src/tools/updateprojectfile/CMakeLists.txt
@${RMDIR} ${WRKSRC}/sandbox/docs/api
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/graphics/appleseed/files/patch-CMakeLists.txt b/graphics/appleseed/files/patch-CMakeLists.txt
index f0bd1ad08cee..1dca4edca2bf 100644
--- a/graphics/appleseed/files/patch-CMakeLists.txt
+++ b/graphics/appleseed/files/patch-CMakeLists.txt
@@ -19,7 +19,25 @@
include (src/cmake/config/linux-gcc.txt)
else ()
message (FATAL_ERROR "Unsupported platform or compiler (CMAKE_SYSTEM_NAME is \"${CMAKE_SYSTEM_NAME}\"). "
-@@ -546,7 +549,7 @@ endif ()
+@@ -147,6 +150,9 @@ if (WITH_OSL)
+ ${PROJECT_SOURCE_DIR}/src/appleseed/renderer/kernel/shading/stdosl.h)
+ endif ()
+
++# XXX: avoid picking up lz4 headers from /usr/local/include == ${Boost_INCLUDE_DIRS}
++# if `archivers/liblz4' port is installed.
++include_directories (src/lz4)
+
+ #--------------------------------------------------------------------------------------------------
+ # Boost libraries.
+@@ -244,7 +250,6 @@ endif ()
+ # Common include paths.
+ include_directories (
+ src/appleseed
+- src/lz4
+ ${PYTHON_INCLUDE_DIRS}
+ )
+
+@@ -546,7 +551,7 @@ endif ()
find_package (Doxygen)
@@ -28,7 +46,7 @@
configure_file (${PROJECT_SOURCE_DIR}/scripts/appleseed.doxyfile.in ${PROJECT_BINARY_DIR}/appleseed.doxyfile @ONLY)
add_custom_target (
doc ${DOXYGEN_EXECUTABLE} ${PROJECT_BINARY_DIR}/appleseed.doxyfile
-@@ -596,22 +599,25 @@ install (
+@@ -596,22 +601,25 @@ install (
DIRECTORY
sandbox/docs
sandbox/samples
@@ -57,7 +75,7 @@
install (
DIRECTORY src/appleseed/foundation
DESTINATION include
-@@ -629,3 +635,4 @@ install (
+@@ -629,3 +637,4 @@ install (
DESTINATION include
FILES_MATCHING PATTERN "*.h"
)