aboutsummaryrefslogtreecommitdiff
path: root/graphics/appleseed
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2018-12-25 20:25:39 +0000
commit707c6bf295fc3955c86c9244533c1524bb7dea15 (patch)
tree5754f0a521127b72390a51a263bc6e84b5177927 /graphics/appleseed
parente3b5edc5e789bcd6057c4a01e4c618dbb1509756 (diff)
downloadports-707c6bf295fc3955c86c9244533c1524bb7dea15.tar.gz
ports-707c6bf295fc3955c86c9244533c1524bb7dea15.zip
Change cmake default behaviour to outsource.
Ports that build out of source now simply can use "USES=cmake" instead of "USES=cmake:outsource". Ports that fail to build out of source now need to specify "USES=cmake:insource". I tried to only set insource where explictely needed. PR: 232038 Exp-run by: antoine
Notes
Notes: svn path=/head/; revision=488341
Diffstat (limited to 'graphics/appleseed')
-rw-r--r--graphics/appleseed/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/graphics/appleseed/Makefile b/graphics/appleseed/Makefile
index 85631e5c3fd3..58bcd4e69664 100644
--- a/graphics/appleseed/Makefile
+++ b/graphics/appleseed/Makefile
@@ -26,7 +26,7 @@ GH_ACCOUNT= ${PORTNAME}hq
ONLY_FOR_ARCHS= i386 amd64
ONLY_FOR_ARCHS_REASON= not ported to it yet
-USES= cmake:outsource compiler:env
+USES= cmake compiler:env
LDFLAGS+= -lboost_atomic
CMAKE_ARGS= -DUSE_STATIC_BOOST:BOOL=OFF -DUSE_STATIC_OIIO:BOOL=OFF \