aboutsummaryrefslogtreecommitdiff
path: root/graphics/autopano-sift-c
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2009-07-16 17:34:03 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2009-07-16 17:34:03 +0000
commit735871d021b5ef9dae7ea047663c685d33f79422 (patch)
tree0dbf4eb9dc52bbeba042e371a00cbee3ef0822b7 /graphics/autopano-sift-c
parentb16dc471d796f89b196e13a21c0f688b01295539 (diff)
downloadports-735871d021b5ef9dae7ea047663c685d33f79422.tar.gz
ports-735871d021b5ef9dae7ea047663c685d33f79422.zip
This is autopano-sift-2.4 ported to plain "C"
The source is kept as close as possible to the original version. It should have the same inputs and outputs as the original "C#" version which is available in ports as graphics/autopano-sift WWW: http://hugin.sourceforge.net/docs/manual/Autopano-sift-C.html
Notes
Notes: svn path=/head/; revision=237942
Diffstat (limited to 'graphics/autopano-sift-c')
-rw-r--r--graphics/autopano-sift-c/Makefile44
-rw-r--r--graphics/autopano-sift-c/distinfo3
-rw-r--r--graphics/autopano-sift-c/pkg-descr7
3 files changed, 54 insertions, 0 deletions
diff --git a/graphics/autopano-sift-c/Makefile b/graphics/autopano-sift-c/Makefile
new file mode 100644
index 000000000000..b9c8d50393f3
--- /dev/null
+++ b/graphics/autopano-sift-c/Makefile
@@ -0,0 +1,44 @@
+# New ports collection makefile for: autopano-sift-c
+# Date created: 10 Jul 2009
+# Whom: Dmitry Marakasov <amdmi3@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= autopano-sift-C
+PORTVERSION= 2.5.0
+CATEGORIES= games
+MASTER_SITES= SF/hugin
+
+MAINTAINER= amdmi3@FreeBSD.org
+COMMENT= Automatic panorama control point generation tool, C port
+
+LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
+ jpeg.9:${PORTSDIR}/graphics/jpeg \
+ png.5:${PORTSDIR}/graphics/png \
+ pano13:${PORTSDIR}/graphics/libpano13
+
+CONFLICTS= autopano-sift-[0-9]*
+
+USE_GNOME= libxml2
+USE_CMAKE= yes
+MAKE_JOBS_SAFE= yes
+
+PLIST_FILES= bin/autopano bin/autopano-c-complete.sh \
+ bin/autopano-sift-c bin/generatekeys
+
+PORTDOCS= *
+
+MAN1= autopano-c-complete.1 autopano.1 generatekeys.1
+MAN7= autopano-sift-c.7
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|share/man|man|' ${WRKSRC}/CMakeLists.txt
+
+.if !defined(NOPORTDOCS)
+post-install:
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.1ST ${DOCSDIR}/
+.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/autopano-sift-c/distinfo b/graphics/autopano-sift-c/distinfo
new file mode 100644
index 000000000000..f9f0647b035f
--- /dev/null
+++ b/graphics/autopano-sift-c/distinfo
@@ -0,0 +1,3 @@
+MD5 (autopano-sift-C-2.5.0.tar.gz) = d4e6bfab53fe227a36eec4c94c0bbfe6
+SHA256 (autopano-sift-C-2.5.0.tar.gz) = 8362d963406953ba6c79402ef31c7a2a794a753c4cf250c293b3e1f3e455735f
+SIZE (autopano-sift-C-2.5.0.tar.gz) = 204300
diff --git a/graphics/autopano-sift-c/pkg-descr b/graphics/autopano-sift-c/pkg-descr
new file mode 100644
index 000000000000..7bc2d0ed2ac5
--- /dev/null
+++ b/graphics/autopano-sift-c/pkg-descr
@@ -0,0 +1,7 @@
+This is autopano-sift-2.4 ported to plain "C"
+The source is kept as close as possible to the original version.
+
+It should have the same inputs and outputs as the original "C#" version
+which is available in ports as graphics/autopano-sift
+
+WWW: http://hugin.sourceforge.net/docs/manual/Autopano-sift-C.html