aboutsummaryrefslogtreecommitdiff
path: root/graphics/autotrace
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2014-01-21 18:31:31 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2014-01-21 18:31:31 +0000
commit13eed426e340a41da25ee8e378797d265b33963e (patch)
treeb675ab53112327013fba4340c1454c27c9f7d330 /graphics/autotrace
parent956d3f91f06c6ce5fa94dc76be66e8728b47c18a (diff)
downloadports-13eed426e340a41da25ee8e378797d265b33963e.tar.gz
ports-13eed426e340a41da25ee8e378797d265b33963e.zip
Stage support
Notes
Notes: svn path=/head/; revision=340632
Diffstat (limited to 'graphics/autotrace')
-rw-r--r--graphics/autotrace/Makefile13
-rw-r--r--graphics/autotrace/pkg-plist1
2 files changed, 6 insertions, 8 deletions
diff --git a/graphics/autotrace/Makefile b/graphics/autotrace/Makefile
index fe09388acc8e..5679f381b842 100644
--- a/graphics/autotrace/Makefile
+++ b/graphics/autotrace/Makefile
@@ -13,39 +13,36 @@ COMMENT= Convert bitmap to vector graphics
LICENSE= GPLv2 LGPL21
LICENSE_COMB= multi
-LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
+LIB_DEPENDS= libpng15.so:${PORTSDIR}/graphics/png
OPTIONS_DEFINE= IMAGEMAGICK MING PSTOEDIT
OPTIONS_DEFAULT= IMAGEMAGICK PSTOEDIT
MING_DESC= Enable swf interface
PSTOEDIT_DESC= Convert postscript to other formats
-USES= pathfix pkgconfig
+USES= pathfix pkgconfig
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
CPPFLAGS+= $$(libpng-config --I_opts) ${PTHREAD_CFLAGS}
LDFLAGS+= $$(libpng-config --L_opts) ${PTHREAD_LIBS}
-MAN1= autotrace.1
-
-NO_STAGE= yes
.include <bsd.port.options.mk>
.if ${PORT_OPTIONS:MIMAGEMAGICK}
-LIB_DEPENDS+= MagickWand:${PORTSDIR}/graphics/ImageMagick
+LIB_DEPENDS+= libMagickWand.so:${PORTSDIR}/graphics/ImageMagick
.else
CONFIGURE_ARGS+= --without-magick
.endif
.if ${PORT_OPTIONS:MMING}
-LIB_DEPENDS+= ming:${PORTSDIR}/graphics/ming
+LIB_DEPENDS+= libming.so:${PORTSDIR}/graphics/ming
CPPFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/ming
.else
CONFIGURE_ENV+= ac_cv_header_ming_h=no
.endif
.if ${PORT_OPTIONS:MPSTOEDIT}
-LIB_DEPENDS+= pstoedit:${PORTSDIR}/graphics/pstoedit
+LIB_DEPENDS+= libpstoedit.so:${PORTSDIR}/graphics/pstoedit
.else
CONFIGURE_ARGS+= --without-pstoedit
.endif
diff --git a/graphics/autotrace/pkg-plist b/graphics/autotrace/pkg-plist
index 054c4659951d..597f0496e39d 100644
--- a/graphics/autotrace/pkg-plist
+++ b/graphics/autotrace/pkg-plist
@@ -10,5 +10,6 @@ lib/libautotrace.la
lib/libautotrace.so
lib/libautotrace.so.3
libdata/pkgconfig/autotrace.pc
+man/man1/autotrace.1.gz
share/aclocal/autotrace.m4
@dirrm include/autotrace