aboutsummaryrefslogtreecommitdiff
path: root/graphics/autotrace
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2008-09-26 13:59:08 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2008-09-26 13:59:08 +0000
commitc75d3786195c1eb54705d2426693eec1688990aa (patch)
tree7a480b7a3fedc31f5609f3e5eb78b0717a576d52 /graphics/autotrace
parent7c0b87d1d0d004156ec793906ce8694ab2d46291 (diff)
downloadports-c75d3786195c1eb54705d2426693eec1688990aa.tar.gz
ports-c75d3786195c1eb54705d2426693eec1688990aa.zip
- Fix ImageMagick libraries
Notes
Notes: svn path=/head/; revision=220840
Diffstat (limited to 'graphics/autotrace')
-rw-r--r--graphics/autotrace/Makefile2
-rw-r--r--graphics/autotrace/files/patch-configure11
2 files changed, 12 insertions, 1 deletions
diff --git a/graphics/autotrace/Makefile b/graphics/autotrace/Makefile
index b62c70eda119..f4fd7a98acf6 100644
--- a/graphics/autotrace/Makefile
+++ b/graphics/autotrace/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
USE_AUTOTOOLS= libtool:15
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib" \
+CONFIGURE_ENV= LIBS="-L${LOCALBASE}/lib ${PTHREAD_LIBS}" \
CPPFLAGS="-I${LOCALBASE}/include -I${LOCALBASE}/include/ming"
MAN1= autotrace.1
diff --git a/graphics/autotrace/files/patch-configure b/graphics/autotrace/files/patch-configure
new file mode 100644
index 000000000000..0b2ac58b06b3
--- /dev/null
+++ b/graphics/autotrace/files/patch-configure
@@ -0,0 +1,11 @@
+--- configure.orig 2008-09-26 15:52:26.000000000 +0200
++++ configure 2008-09-26 15:52:09.000000000 +0200
+@@ -7973,7 +7973,7 @@
+ MAGICK_CFLAGS=${CPPFLAGS}
+ CPPFLAGS=${CPPFLAGS_BACKUP}
+ if test "x${magick_header_found}" = xyes ; then
+- MAGICK_LDFLAGS="`Magick-config --ldflags` `Magick-config --libs`"
++ MAGICK_LDFLAGS="`Magick-config --ldflags` `Magick-config --libs` `MagickWand-config --ldflags` `MagickWand-config --libs`"
+ echo "$as_me:$LINENO: checking ImageMagick - version >= 5.2.1" >&5
+ echo $ECHO_N "checking ImageMagick - version >= 5.2.1... $ECHO_C" >&6
+ MAGICK_VERSION=`Magick-config --version`