aboutsummaryrefslogtreecommitdiff
path: root/graphics/azpainter
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2018-11-13 14:46:41 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2018-11-13 14:46:41 +0000
commit4f768e41340e883d8f735dd1cd97015faf76e14d (patch)
tree4c94632adfa369644cdff561013fbebe087d3f6e /graphics/azpainter
parentd81c978eaf3febd8016ecaeddd44336f923ff9ad (diff)
downloadports-4f768e41340e883d8f735dd1cd97015faf76e14d.tar.gz
ports-4f768e41340e883d8f735dd1cd97015faf76e14d.zip
Instead of requesting GCC explicitly, tentatively add `compiler:c11' to
the USES list as suggested by several people, even though the code does not really require C11 (e.g., it can be built with -std=c99 or with GCC 4.6 which does not support C11 standard).
Notes
Notes: svn path=/head/; revision=484875
Diffstat (limited to 'graphics/azpainter')
-rw-r--r--graphics/azpainter/Makefile11
1 files changed, 3 insertions, 8 deletions
diff --git a/graphics/azpainter/Makefile b/graphics/azpainter/Makefile
index abe0554c4c54..3641af40c01a 100644
--- a/graphics/azpainter/Makefile
+++ b/graphics/azpainter/Makefile
@@ -15,7 +15,8 @@ LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libfreetype.so:print/freetype2 \
libpng.so:graphics/png
-USES= desktop-file-utils jpeg localbase shared-mime-info tar:xz
+USES= compiler:c11 desktop-file-utils jpeg localbase \
+ shared-mime-info tar:xz
USE_XORG= x11 xext xi
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-freetype-dir=${LOCALBASE}/include/freetype2
@@ -25,12 +26,6 @@ PORTDOCS= AUTHORS ChangeLog NEWS README README_ja manual
OPTIONS_DEFINE= DOCS NLS
OPTIONS_SUB= yes
-.include <bsd.port.pre.mk>
-
-.if ${ARCH:Mpowerpc*} || ${ARCH} == sparc64
-USE_GCC= yes
-.endif
-
post-patch-NLS-off:
@${REINPLACE_CMD} -e 's, install-dist_trdataDATA$$,,' \
${WRKSRC}/data/Makefile.in
@@ -45,4 +40,4 @@ post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
${CP} -a ${PORTDOCS:S|^|${WRKSRC}/|} ${STAGEDIR}${DOCSDIR}
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>