aboutsummaryrefslogtreecommitdiff
path: root/graphics/batik
diff options
context:
space:
mode:
authorHerve Quiroz <hq@FreeBSD.org>2004-12-24 04:26:09 +0000
committerHerve Quiroz <hq@FreeBSD.org>2004-12-24 04:26:09 +0000
commit93a957b92b841d76f641c7d42efafb39f74c6253 (patch)
treee081c5e7e4b19fe25ccd9276a955e4b4d2dde382 /graphics/batik
parent83b062f45a86dd1350576a1f7c819214c3084d2c (diff)
downloadports-93a957b92b841d76f641c7d42efafb39f74c6253.tar.gz
ports-93a957b92b841d76f641c7d42efafb39f74c6253.zip
- Update to bsd.java.mk 2.0
- Use USE_ANT - Forbid the use of Jikes to build the port - Use INSTALL_DATA to install documentation and JAR files - Honor Porter's handbook guidelines for Java ports: install in DATADIR=${JAVASHAREDIR}/{PORTNAME} [1] - Build dynamic packing list from the distribution files (not from the installed files) to avoid inconsistencies - Bump PORTREVISION Approved by: ijliao [1]
Notes
Notes: svn path=/head/; revision=125032
Diffstat (limited to 'graphics/batik')
-rw-r--r--graphics/batik/Makefile35
1 files changed, 18 insertions, 17 deletions
diff --git a/graphics/batik/Makefile b/graphics/batik/Makefile
index c6108c4cc4f6..1fa48d2fb8dd 100644
--- a/graphics/batik/Makefile
+++ b/graphics/batik/Makefile
@@ -8,6 +8,7 @@
PORTNAME= batik
PORTVERSION= 1.5.1
+PORTREVISION= 1
CATEGORIES= graphics java
MASTER_SITES= ${MASTER_SITE_APACHE_XML}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -16,18 +17,18 @@ DISTNAME= ${PORTNAME}-src-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
COMMENT= SVG Toolkit
-BUILD_DEPENDS= ${ANT}:${PORTSDIR}/devel/apache-ant
-
USE_ZIP= yes
-USE_JAVA= 1.3+
-NEED_JAVAC= yes
+USE_JAVA= yes
+JAVA_VERSION= 1.3+
WRKSRC= ${WRKDIR}/xml-${PORTNAME}
-ANT?= /usr/local/bin/ant
-ANT_ALL_TARGET= jars
-BATIK_HOME= ${PREFIX}/batik
+USE_ANT= yes
+USE_JIKES= no
+ALL_TARGET= jars
+DATADIR= ${JAVASHAREDIR}/${PORTNAME}
+TARGET_DIR= ${WRKSRC}/${PORTNAME}-${PORTVERSION}
.if !defined(NOPORTDOCS)
-ANT_ALL_TARGET+= html
+ALL_TARGET+= html
.endif
.include <bsd.port.pre.mk>
@@ -36,15 +37,15 @@ ANT_ALL_TARGET+= html
BROKEN= "Does not compile on 4.x"
.endif
-do-build:
- @cd ${WRKSRC} && ${ANT} ${ANT_ALL_TARGET}
-
do-install:
- @${MKDIR} ${BATIK_HOME}
- @${CP} -R ${WRKSRC}/${PORTNAME}-${PORTVERSION} ${BATIK_HOME}
- @${FIND} ${BATIK_HOME} -type f | \
- ${SED} -e "s,^${PREFIX}/,," >> ${TMPPLIST}
- @${FIND} ${BATIK_HOME} -type d | ${SORT} -r | \
- ${SED} -e "s,^${PREFIX}/,@dirrm ," >> ${TMPPLIST}
+ cd ${TARGET_DIR} \
+ && ${FIND} . -type d -exec ${MKDIR} ${DATADIR}/{} \; \
+ && ${FIND} . -type f -exec ${INSTALL_DATA} {} ${DATADIR}/{} \;
+
+post-install:
+ @${FIND} -s ${TARGET_DIR} -type f | \
+ ${SED} -e 's,^${TARGET_DIR},${DATADIR:S,${PREFIX}/,,},' >> ${TMPPLIST}
+ @${FIND} -s -d ${TARGET_DIR} -type d | \
+ ${SED} -e 's,^${TARGET_DIR},@dirrm ${DATADIR:S,${PREFIX}/,,},' >> ${TMPPLIST}
.include <bsd.port.post.mk>