aboutsummaryrefslogtreecommitdiff
path: root/graphics/bitmap
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-05-27 18:12:25 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-05-27 18:12:25 +0000
commit31f470aebeefa30c41aa93b7a04335b2435ebc42 (patch)
tree6ea79a438677f1bcc115e9208f47d0057f6a25a5 /graphics/bitmap
parentea5e2c6a506bc453af207b97e611024fd119475a (diff)
downloadports-31f470aebeefa30c41aa93b7a04335b2435ebc42.tar.gz
ports-31f470aebeefa30c41aa93b7a04335b2435ebc42.zip
New port: graphics/bitmap: Minimalistic library manipulating 24-bit per pixel bitmap images
Notes
Notes: svn path=/head/; revision=502811
Diffstat (limited to 'graphics/bitmap')
-rw-r--r--graphics/bitmap/Makefile30
-rw-r--r--graphics/bitmap/distinfo3
-rw-r--r--graphics/bitmap/pkg-descr21
3 files changed, 54 insertions, 0 deletions
diff --git a/graphics/bitmap/Makefile b/graphics/bitmap/Makefile
new file mode 100644
index 000000000000..b86212cccfbf
--- /dev/null
+++ b/graphics/bitmap/Makefile
@@ -0,0 +1,30 @@
+# $FreeBSD$
+
+PORTNAME= bitmap
+DISTVERSION= g20181222
+CATEGORIES= graphics
+PKGNAMESUFFIX= -graphics-library
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Minimalistic library manipulating 24-bit per pixel bitmap images
+
+LICENSE= MIT
+
+USE_GITHUB= yes
+GH_ACCOUNT= ArashPartow
+GH_TAGNAME= b02297f
+
+NO_BUILD= yes
+NO_ARCH= yes
+
+PLIST_FILES= include/bitmap_image.hpp
+
+do-install:
+ ${INSTALL_DATA} ${WRKSRC}/bitmap_image.hpp ${STAGEDIR}${PREFIX}/include
+
+do-test: # tests failure reported to the author: Error - Failed to open 'image.bmp'
+ @cd ${WRKSRC} && \
+ ${SETENV} ${MAKE_ENV} ${MAKE_CMD} bitmap_test && \
+ ./bitmap_test
+
+.include <bsd.port.mk>
diff --git a/graphics/bitmap/distinfo b/graphics/bitmap/distinfo
new file mode 100644
index 000000000000..0eff37601b08
--- /dev/null
+++ b/graphics/bitmap/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1558979256
+SHA256 (ArashPartow-bitmap-g20181222-b02297f_GH0.tar.gz) = 9d6dd560d0bd01e78ebd08f7828249b96ad7b43e4a3589b54d62831d97c801f0
+SIZE (ArashPartow-bitmap-g20181222-b02297f_GH0.tar.gz) = 52230
diff --git a/graphics/bitmap/pkg-descr b/graphics/bitmap/pkg-descr
new file mode 100644
index 000000000000..a71b6dedec16
--- /dev/null
+++ b/graphics/bitmap/pkg-descr
@@ -0,0 +1,21 @@
+The C++ Bitmap Library consists of simple, robust, optimized and portable
+processing routines for the 24-bit per pixel bitmap image format.
+
+The library has the following capabilities:
+* Read/Write 24-bit Bitmap Images
+* Pixel, row or column level batch editing
+* Colour conversions (RGB,YCbCr) in byte and floating values
+* Highly optimized subsample and upsample (resizing)
+* Various colour maps (1000 levels - autumn, copper, gray, hot, hsv, jet, prism,
+ vga, yarg)
+* Texture generation (checkered pattern, plasma)
+* Graphics drawing interface (line, line-segment, rectangle, triangle, quadix,
+ horizontal and vertical line-segments, ellipse, circle, plot pixel, pen width,
+ pen colour)
+* Cartesian canvas and associated drawing interface
+* PSNR and Image comparisons
+* Simple nearest colour match from set of colours
+* Wavelength to RGB approximations
+* Single header file solution requires no installation or building
+
+WWW: http://www.partow.net/programming/bitmap/index.html