aboutsummaryrefslogtreecommitdiff
path: root/graphics/bmp2html
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2019-02-06 10:26:57 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2019-02-06 10:26:57 +0000
commita9530f7b9f6b48d7971504749297cd4fdf7aa3e3 (patch)
treece28611d4109463dbcb4ec6ef5717bef563fafcf /graphics/bmp2html
parentb1dc6e4da963c9bb65cfdd2b0ead1a379bc55ec6 (diff)
downloadports-a9530f7b9f6b48d7971504749297cd4fdf7aa3e3.tar.gz
ports-a9530f7b9f6b48d7971504749297cd4fdf7aa3e3.zip
- Add LICENSE
- Take compile/link flags from sdl_config, instead of hardcoding them, simplify the port - Remove bundled binary earlier, in post-extract PR: 235525 Submitted by: amdmi3
Notes
Notes: svn path=/head/; revision=492298
Diffstat (limited to 'graphics/bmp2html')
-rw-r--r--graphics/bmp2html/Makefile13
1 files changed, 5 insertions, 8 deletions
diff --git a/graphics/bmp2html/Makefile b/graphics/bmp2html/Makefile
index b70ed1c755bb..bd43fbbb6df6 100644
--- a/graphics/bmp2html/Makefile
+++ b/graphics/bmp2html/Makefile
@@ -11,22 +11,19 @@ DISTNAME= ${PORTNAME}
MAINTAINER= ehaupt@FreeBSD.org
COMMENT= BMP to HTML converter
-USE_SDL= sdl
+LICENSE= PD
-LDFLAGS+= -L${LOCALBASE}/lib
-SDL_FLAGS= -I${LOCALBASE}/include/SDL -I${LOCALBASE}/include
-EXTRA_LDFLAGS= -lSDL -pthread
-DEFINES= -D_REENTRANT
+USE_SDL= sdl
PLIST_FILES= bin/bmp2html
-post-patch:
+post-extract:
@${RM} ${WRKSRC}/${PORTNAME}
do-build:
- ${CC} ${CFLAGS} ${LDFLAGS} ${SDL_FLAGS} ${DEFINES} -c \
+ ${CC} ${CFLAGS} `${SDL_CONFIG} --cflags` -c \
-o ${WRKSRC}/${PORTNAME}.o ${WRKSRC}/${PORTNAME}.c
- ${CC} ${CFLAGS} ${LDFLAGS} ${SDL_FLAGS} ${EXTRA_LDFLAGS} \
+ ${CC} ${LDFLAGS} `${SDL_CONFIG} --libs` \
-o ${WRKSRC}/${PORTNAME} ${WRKSRC}/${PORTNAME}.o
do-install: