aboutsummaryrefslogtreecommitdiff
path: root/graphics/bugle
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-06-12 13:01:59 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-06-12 13:01:59 +0000
commit94ba3ea1d6c5331fbf90b0a3c81df657f11c0c3b (patch)
treec79e3b4bcca68488986f295c5e0e60eef533ac9d /graphics/bugle
parent9fd5dfabb2513b8f0a3c800ab00cdf010ff92968 (diff)
downloadports-94ba3ea1d6c5331fbf90b0a3c81df657f11c0c3b.tar.gz
ports-94ba3ea1d6c5331fbf90b0a3c81df657f11c0c3b.zip
Notes
Diffstat (limited to 'graphics/bugle')
-rw-r--r--graphics/bugle/Makefile24
-rw-r--r--graphics/bugle/distinfo2
-rw-r--r--graphics/bugle/pkg-descr4
-rw-r--r--graphics/bugle/pkg-plist22
4 files changed, 52 insertions, 0 deletions
diff --git a/graphics/bugle/Makefile b/graphics/bugle/Makefile
new file mode 100644
index 000000000000..39e21f2958b3
--- /dev/null
+++ b/graphics/bugle/Makefile
@@ -0,0 +1,24 @@
+# New ports collection makefile for: bugle
+# Date created: Jun 8, 2004
+# Whom: Erik Greenwald <erik@smluc.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= bugle
+PORTVERSION= 0.0.20040609
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= bugle
+
+MAINTAINER= erik@smluc.org
+COMMENT= A debugging library for OpenGL
+
+USE_GCC= 3.3
+USE_GL= yes
+GNU_CONFIGURE= yes
+CONFIGURE_TARGET=--build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
+CONFIGURE_ENV= CPPFLAGS="-I${X11BASE}/include" \
+ LIBS="-L${X11BASE}/lib"
+
+.include <bsd.port.mk>
diff --git a/graphics/bugle/distinfo b/graphics/bugle/distinfo
new file mode 100644
index 000000000000..cc43807e10c6
--- /dev/null
+++ b/graphics/bugle/distinfo
@@ -0,0 +1,2 @@
+MD5 (bugle-0.0.20040609.tar.gz) = 59b071b6b5b106c229aa16896ca69c58
+SIZE (bugle-0.0.20040609.tar.gz) = 311287
diff --git a/graphics/bugle/pkg-descr b/graphics/bugle/pkg-descr
new file mode 100644
index 000000000000..2cea4264d013
--- /dev/null
+++ b/graphics/bugle/pkg-descr
@@ -0,0 +1,4 @@
+BuGLe is a tool for OpenGL debugging, implemented as a wrapper
+library that sits between your program and OpenGL.
+
+WWW: http://bugle.sourceforge.net
diff --git a/graphics/bugle/pkg-plist b/graphics/bugle/pkg-plist
new file mode 100644
index 000000000000..6070eaf95232
--- /dev/null
+++ b/graphics/bugle/pkg-plist
@@ -0,0 +1,22 @@
+lib/bugle/common.a
+lib/bugle/common.la
+lib/bugle/common.so
+lib/bugle/common.so.0
+lib/bugle/debugger.a
+lib/bugle/debugger.la
+lib/bugle/debugger.so
+lib/bugle/modify.a
+lib/bugle/modify.la
+lib/bugle/modify.so
+lib/bugle/modify.so.0
+lib/bugle/tracker.a
+lib/bugle/tracker.la
+lib/bugle/tracker.so
+lib/bugle/validate.a
+lib/bugle/validate.la
+lib/bugle/validate.so
+lib/libbugle.a
+lib/libbugle.la
+lib/libbugle.so
+lib/libbugle.so.0
+@dirrm lib/bugle