aboutsummaryrefslogtreecommitdiff
path: root/graphics/cairo/Makefile
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-02-16 05:52:43 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-02-16 05:52:43 +0000
commit636327204cdbd4122f9154690f00e9125895a093 (patch)
tree4b276a7b6dd50438d6d9bd21731ac96d84fc411b /graphics/cairo/Makefile
parent267630c0bbc3750c4f42be53693b166c1d2c2941 (diff)
downloadports-636327204cdbd4122f9154690f00e9125895a093.tar.gz
ports-636327204cdbd4122f9154690f00e9125895a093.zip
Notes
Diffstat (limited to 'graphics/cairo/Makefile')
-rw-r--r--graphics/cairo/Makefile21
1 files changed, 11 insertions, 10 deletions
diff --git a/graphics/cairo/Makefile b/graphics/cairo/Makefile
index 4182b3ef20ba..ccf8d4995d9b 100644
--- a/graphics/cairo/Makefile
+++ b/graphics/cairo/Makefile
@@ -6,16 +6,14 @@
#
PORTNAME= cairo
-PORTVERSION= 0.2.0
+PORTVERSION= 0.3.0
CATEGORIES= graphics
-MASTER_SITES= ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= ahze
+MASTER_SITES= http://cairographics.org/snapshots/
MAINTAINER= ahze@FreeBSD.org
COMMENT= Cairo is a vector graphics library with cross-device output support
LIB_DEPENDS= pixman.1:${PORTSDIR}/graphics/libpixman \
- glitz-glx.1:${PORTSDIR}/graphics/glitz \
freetype.9:${PORTSDIR}/print/freetype2 \
png.5:${PORTSDIR}/graphics/png
@@ -26,12 +24,15 @@ INSTALLS_SHLIB= yes
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CLFAGS}" \
LDFLAGS="${PTHREAD_LDFLAGS}"
-PLIST_FILES= include/cairo-features.h \
- include/cairo.h \
- lib/libcairo.a \
- lib/libcairo.so \
- lib/libcairo.so.1 \
- libdata/pkgconfig/cairo.pc
+OPTIONS+= GLITZ "Enable Glitz OpenGL Support" Off
+
+.if defined(WITH_GLITZ)
+LIB_DEPENDS+= glitz-glx.1:${PORTSDIR}/graphics/glitz
+.endif
+
+.if !defined(WITHOUT_X11)
+USE_XLIB= yes
+.endif
.include <bsd.port.pre.mk>