aboutsummaryrefslogtreecommitdiff
path: root/graphics/cairo/Makefile
diff options
context:
space:
mode:
authorTijl Coosemans <tijl@FreeBSD.org>2022-05-04 14:29:21 +0000
committerTijl Coosemans <tijl@FreeBSD.org>2022-05-27 09:11:04 +0000
commit6fd90bd6606b1a8f648cf807b2f959e037505c66 (patch)
tree8933694f4e9974e964e80adc2d069c9103f0c388 /graphics/cairo/Makefile
parentdc1885926d4ab78d37303aac1d18f27058b7b313 (diff)
Diffstat (limited to 'graphics/cairo/Makefile')
-rw-r--r--graphics/cairo/Makefile28
1 files changed, 9 insertions, 19 deletions
diff --git a/graphics/cairo/Makefile b/graphics/cairo/Makefile
index 1bc9dc1fe9a1..520140f46d36 100644
--- a/graphics/cairo/Makefile
+++ b/graphics/cairo/Makefile
@@ -2,6 +2,7 @@
PORTNAME= cairo
DISTVERSION= 1.17.4
+PORTREVISION= 1
PORTEPOCH= 3
CATEGORIES= graphics
MASTER_SITES= https://cairographics.org/releases/ \
@@ -24,15 +25,14 @@ LIB_DEPENDS= libfreetype.so:print/freetype2 \
PORTSCOUT= skipv:5c-1.1,5c-1.2,5c-1.5
-USES= autoreconf cpe gnome libtool pathfix pkgconfig tar:xz xorg
+USES= autoreconf cpe gnome libtool pkgconfig tar:xz xorg
CPE_VENDOR= cairographics
USE_XORG= pixman
USE_LDCONFIG= yes
INSTALL_TARGET= install-strip
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-html-dir=${DOCSDIR} \
- --disable-directfb \
+CONFIGURE_ARGS= --disable-directfb \
--disable-gallium \
--disable-wgl \
--enable-tee
@@ -44,6 +44,9 @@ OPTIONS_DEFAULT=OPENGL XCB GLIB X11
OPTIONS_SLAVE= ${ARCH:tu}
OPTIONS_SUB= yes
+DOCS_BUILD_DEPENDS= gtkdocize:textproc/gtk-doc
+DOCS_CONFIGURE_ON= --with-html-dir=${DOCSDIR}
+
X11_USES= xorg
X11_USE= xorg=x11,xext,xorgproto,xrender
X11_CONFIGURE_ENABLE=xlib
@@ -75,22 +78,9 @@ MIPS_CONFIGURE_ENV= cairo_cv_atomic_primitives="libatomic-ops"
PLIST_SUB+= LIBVER=2.11704.0
-post-patch:
- @${REINPLACE_CMD} -e '/strings/s/ - / -a /' \
- -e '/test/s/==/=/g' \
- -e '/LIBS/s/-lrt//' -e '/LIBS/s|-ldld||' \
- -e '/LIBS/s|-ldl||' \
- ${WRKSRC}/configure
- @${REINPLACE_CMD} -e 's|-lcairo|-lcairo -lpthread|' \
- ${WRKSRC}/src/*.pc.in
- @${REINPLACE_CMD} -e '/@CAIRO_HAS_PNG_FUNCTIONS_TRUE@.*=/d' \
- ${WRKSRC}/Makefile.in
- @${REINPLACE_CMD} -e 's|-ldl||g' \
- ${WRKSRC}/util/*/Makefile.in \
- ${WRKSRC}/boilerplate/Makefile.in
-
post-patch-DOCS-off:
- @${REINPLACE_CMD} -e 's|public||g' \
- ${WRKSRC}/doc/Makefile.in
+ @${REINPLACE_CMD} '/^SUBDIRS/s/doc//' ${WRKSRC}/Makefile.am
+ @${REINPLACE_CMD} -e '/^GTK_DOC_CHECK/d' -e '/doc\/.*Makefile/d' \
+ ${WRKSRC}/configure.ac
.include <bsd.port.mk>