aboutsummaryrefslogtreecommitdiff
path: root/graphics/cairo/Makefile
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:35:50 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-14 08:35:50 +0000
commitf1bb12de8e50bf76ae21f37debda60994ec7fd99 (patch)
tree1671d4beef381f12d939e34b344eb385a3af4f19 /graphics/cairo/Makefile
parent29adee7bb42244f34736c5c24ed18a9b269d0925 (diff)
downloadports-f1bb12de8e50bf76ae21f37debda60994ec7fd99.tar.gz
ports-f1bb12de8e50bf76ae21f37debda60994ec7fd99.zip
Notes
Diffstat (limited to 'graphics/cairo/Makefile')
-rw-r--r--graphics/cairo/Makefile15
1 files changed, 8 insertions, 7 deletions
diff --git a/graphics/cairo/Makefile b/graphics/cairo/Makefile
index 9dfd56f5cec5..6cad3727cfbd 100644
--- a/graphics/cairo/Makefile
+++ b/graphics/cairo/Makefile
@@ -3,16 +3,14 @@
# Whom: Michael Johnson <ahze@FreeBSD.org>
#
# $FreeBSD$
-# $MCom: ports/graphics/cairo/Makefile,v 1.30 2005/10/04 04:35:57 ahze Exp $
+# $MCom: ports/graphics/cairo/Makefile,v 1.45 2006/08/19 16:29:11 marcus Exp $
#
PORTNAME= cairo
-PORTVERSION= 1.0.4
-PORTREVISION?= 1
+PORTVERSION= 1.2.4
+PORTREVISION?= 0
CATEGORIES= graphics
-MASTER_SITES= http://cairographics.org/releases/ \
- ${MASTER_SITE_LOCAL}
-MASTER_SITE_SUBDIR= ahze
+MASTER_SITES= http://cairographics.org/releases/
MAINTAINER= gnome@FreeBSD.org
COMMENT= Vector graphics library with cross-device output support
@@ -28,7 +26,7 @@ CONFIGURE_ARGS= --with-html-dir=${DOCSDIR} \
--enable-ps
USE_GNOME= gnometarget gnomehack ltverhack referencehack
USE_AUTOTOOLS= libtool:15
-INSTALLS_SHLIB= yes
+USE_LDCONFIG= yes
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS} -I${X11BASE}/include" \
LDFLAGS="${PTHREAD_LIBS}"
@@ -62,6 +60,9 @@ post-patch:
.endif
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|' \
${WRKSRC}/test/Makefile.in
+ @${REINPLACE_CMD} -e 's|src test doc|src doc|; \
+ s|@CAIRO_HAS_PNG_FUNCTIONS_TRUE@am__append_1 = test||' \
+ ${WRKSRC}/Makefile.in
.include <bsd.port.post.mk>