aboutsummaryrefslogtreecommitdiff
path: root/graphics/cairo
diff options
context:
space:
mode:
authorSean Bruno <sbruno@FreeBSD.org>2015-11-09 14:59:36 +0000
committerSean Bruno <sbruno@FreeBSD.org>2015-11-09 14:59:36 +0000
commitafd5b52ca0e4d77858d428a2fd80b156d5f94ac9 (patch)
tree1f2fd63bab98803f46615b90063c12505ce93659 /graphics/cairo
parent6010eb8d269781a8aad916d5dd5461f8645a2439 (diff)
downloadports-afd5b52ca0e4d77858d428a2fd80b156d5f94ac9.tar.gz
ports-afd5b52ca0e4d77858d428a2fd80b156d5f94ac9.zip
Update port Makefile to support mips build of cairo.
Add License Information PR: 201683 Submitted by: Carlos J Puga Medina <cpm@fbsd.es>
Notes
Notes: svn path=/head/; revision=401102
Diffstat (limited to 'graphics/cairo')
-rw-r--r--graphics/cairo/Makefile15
-rw-r--r--graphics/cairo/files/patch-src_cairo-gl.h10
-rw-r--r--graphics/cairo/files/patch-src_cairo-xlib-display.c6
-rw-r--r--graphics/cairo/files/patch-util_cairo-sphinx_sphinx.c6
-rw-r--r--graphics/cairo/pkg-descr2
5 files changed, 25 insertions, 14 deletions
diff --git a/graphics/cairo/Makefile b/graphics/cairo/Makefile
index 97949fa36358..42441caa0dc4 100644
--- a/graphics/cairo/Makefile
+++ b/graphics/cairo/Makefile
@@ -3,6 +3,7 @@
PORTNAME= cairo
PORTVERSION= 1.14.2
+PORTREVISION= 1
PORTEPOCH= 2
CATEGORIES= graphics
MASTER_SITES= http://cairographics.org/releases/
@@ -10,6 +11,9 @@ MASTER_SITES= http://cairographics.org/releases/
MAINTAINER= gnome@FreeBSD.org
COMMENT= Vector graphics library with cross-device output support
+LICENSE= LGPL21 MPL
+LICENSE_COMB= multi
+
USES= tar:xz
.if !defined(REFERENCE_PORT)
@@ -58,6 +62,13 @@ PLIST_SUB+= LIBVER=2.11400.2
.include <bsd.port.options.mk>
+.if ${ARCH} == "mips"
+BUILD_DEPENDS+= ${LOCALBASE}/include/atomic_ops.h:${PORTSDIR}/devel/libatomic_ops
+CPPFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= cairo_cv_atomic_primitives="libatomic-ops"
+.endif
+
.if ${PORT_OPTIONS:MOPENGL} && !${PORT_OPTIONS:MX11}
BROKEN= OpenGL option needs X11 support
.endif
@@ -76,6 +87,6 @@ post-patch:
${WRKSRC}/util/*/Makefile.in \
${WRKSRC}/boilerplate/Makefile.in
-.include <bsd.port.mk>
-
.endif
+
+.include <bsd.port.mk>
diff --git a/graphics/cairo/files/patch-src_cairo-gl.h b/graphics/cairo/files/patch-src_cairo-gl.h
index 68e1e930578f..ab45af9bc00d 100644
--- a/graphics/cairo/files/patch-src_cairo-gl.h
+++ b/graphics/cairo/files/patch-src_cairo-gl.h
@@ -1,6 +1,6 @@
---- src/cairo-gl.h.orig 2013-03-15 21:29:27.000000000 +0100
-+++ src/cairo-gl.h 2015-01-05 10:30:46.611768380 +0100
-@@ -92,7 +92,7 @@
+--- src/cairo-gl.h.orig 2015-03-10 22:21:07 UTC
++++ src/cairo-gl.h
+@@ -92,7 +92,7 @@ cairo_public void
cairo_gl_device_set_thread_aware (cairo_device_t *device,
cairo_bool_t thread_aware);
@@ -9,7 +9,7 @@
#include <GL/glx.h>
cairo_public cairo_device_t *
-@@ -110,7 +110,7 @@
+@@ -110,7 +110,7 @@ cairo_gl_surface_create_for_window (cair
int width, int height);
#endif
@@ -18,7 +18,7 @@
#include <windows.h>
cairo_public cairo_device_t *
-@@ -126,7 +126,7 @@
+@@ -126,7 +126,7 @@ cairo_gl_surface_create_for_dc (cairo_de
int height);
#endif
diff --git a/graphics/cairo/files/patch-src_cairo-xlib-display.c b/graphics/cairo/files/patch-src_cairo-xlib-display.c
index fce8103adfc1..2b31da881c26 100644
--- a/graphics/cairo/files/patch-src_cairo-xlib-display.c
+++ b/graphics/cairo/files/patch-src_cairo-xlib-display.c
@@ -1,6 +1,6 @@
---- src/cairo-xlib-display.c.orig 2010-11-21 14:41:31.000000000 -0500
-+++ src/cairo-xlib-display.c 2010-11-21 14:42:12.000000000 -0500
-@@ -353,11 +353,7 @@ _cairo_xlib_device_create (Display *dpy)
+--- src/cairo-xlib-display.c.orig 2015-03-10 22:21:07 UTC
++++ src/cairo-xlib-display.c
+@@ -263,11 +263,7 @@ _cairo_xlib_device_create (Display *dpy)
/* Prior to Render 0.10, there is no protocol support for gradients and
* we call function stubs instead, which would silently consume the drawing.
*/
diff --git a/graphics/cairo/files/patch-util_cairo-sphinx_sphinx.c b/graphics/cairo/files/patch-util_cairo-sphinx_sphinx.c
index ac6a15053d5a..47825296f3da 100644
--- a/graphics/cairo/files/patch-util_cairo-sphinx_sphinx.c
+++ b/graphics/cairo/files/patch-util_cairo-sphinx_sphinx.c
@@ -1,6 +1,6 @@
---- util/cairo-sphinx/sphinx.c.orig 2014-10-06 15:22:24.000000000 -0400
-+++ util/cairo-sphinx/sphinx.c 2014-10-06 15:23:04.000000000 -0400
-@@ -1325,7 +1325,7 @@ client_shm (const char *shm_path)
+--- util/cairo-sphinx/sphinx.c.orig 2015-03-10 22:21:07 UTC
++++ util/cairo-sphinx/sphinx.c
+@@ -1337,7 +1337,7 @@ client_shm (const char *shm_path)
base = mmap (NULL, DATA_SIZE,
PROT_READ | PROT_WRITE,
diff --git a/graphics/cairo/pkg-descr b/graphics/cairo/pkg-descr
index 4fd137a19bdd..874c5d87f08a 100644
--- a/graphics/cairo/pkg-descr
+++ b/graphics/cairo/pkg-descr
@@ -10,4 +10,4 @@ the PDF 1.4 imaging model. Cairo provides operations including stroking
and filling Bezier cubic splines, transforming and compositing translucent
images, and antialiased text rendering.
-WWW: http://www.cairographics.org
+WWW: http://www.cairographics.org