aboutsummaryrefslogtreecommitdiff
path: root/graphics/cal3d
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-07-13 08:33:57 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-07-13 08:33:57 +0000
commite2ca6bea49eef37b38c7d98b702dd449492b4b8e (patch)
tree2f117f6da1ebdb7dc6b8cfdccf8fa7a8fcfa5212 /graphics/cal3d
parent08f99179049da9f52c9b96d09f3b0a0e62551a43 (diff)
downloadports-e2ca6bea49eef37b38c7d98b702dd449492b4b8e.tar.gz
ports-e2ca6bea49eef37b38c7d98b702dd449492b4b8e.zip
Add cal3d 0.9.1,
Cal3D is a skeletal based 3D character animation library written in C++ in a way that is both platform-independent and graphics API-independent. It was originally designed to be used in a 3D client for Worldforge, but evolved into a stand-alone product which can be used in many different kinds of projects. Cal3D's essentials can be boiled down to 2 parts: the C++ library and the exporter. The exporter is what you would use to take your characters (built in a 3D modeling package) and create the Cal3D-format files that the library knows how to load. The exporters are actually plug-ins for 3D modeling packages. This allows 3D artists to use the modeling tools that they're already comfortable with. The C++ library is what you would actually use in your application, whether it's a game or a VR application. The library provides methods to load your exported files, build characters, run animations, and access the data necessary to render them with 3D graphics. PR: ports/68954 Submitted by: Stefan Walter <sw@gegenunendlich.de>
Notes
Notes: svn path=/head/; revision=113534
Diffstat (limited to 'graphics/cal3d')
-rw-r--r--graphics/cal3d/Makefile29
-rw-r--r--graphics/cal3d/distinfo2
-rw-r--r--graphics/cal3d/files/patch-Makefile.am12
-rw-r--r--graphics/cal3d/files/patch-src_cal3d_Makefile.am12
-rw-r--r--graphics/cal3d/files/patch-src_cal3d_buffersource.h11
-rw-r--r--graphics/cal3d/files/patch-src_cal3d_loader.h11
-rw-r--r--graphics/cal3d/files/patch-src_cal3d_streamsource.h11
-rw-r--r--graphics/cal3d/pkg-descr19
-rw-r--r--graphics/cal3d/pkg-plist45
9 files changed, 152 insertions, 0 deletions
diff --git a/graphics/cal3d/Makefile b/graphics/cal3d/Makefile
new file mode 100644
index 000000000000..74e9c65e7bb6
--- /dev/null
+++ b/graphics/cal3d/Makefile
@@ -0,0 +1,29 @@
+# New ports collection makefile for: cal3d
+# Date created: 12 Jul 2004
+# Whom: Stefan Walter <sw@gegenunendlich.de>
+#
+# $FreeBSD$
+#
+
+PORTNAME= cal3d
+PORTVERSION= 0.9.1
+CATEGORIES= graphics devel
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+
+MAINTAINER= sw@gegenunendlich.de
+COMMENT= Skeletal based 3d character animation library written in C++
+
+USE_BZIP2= yes
+USE_AUTOMAKE_VER= 18
+USE_AUTOHEADER_VER= 259
+USE_LIBTOOL_VER= 15
+INSTALLS_SHLIB= yes
+
+.include <bsd.port.pre.mk>
+
+pre-configure:
+ cd ${WRKSRC} && ${ACLOCAL}
+ cd ${WRKSRC} && ${AUTOHEADER}
+
+.include <bsd.port.post.mk>
diff --git a/graphics/cal3d/distinfo b/graphics/cal3d/distinfo
new file mode 100644
index 000000000000..92e6f085002f
--- /dev/null
+++ b/graphics/cal3d/distinfo
@@ -0,0 +1,2 @@
+MD5 (cal3d-0.9.1.tar.bz2) = 55023cf5b4063990f355629c57a175af
+SIZE (cal3d-0.9.1.tar.bz2) = 2871094
diff --git a/graphics/cal3d/files/patch-Makefile.am b/graphics/cal3d/files/patch-Makefile.am
new file mode 100644
index 000000000000..a018a42f5cd7
--- /dev/null
+++ b/graphics/cal3d/files/patch-Makefile.am
@@ -0,0 +1,12 @@
+--- Makefile.am.orig Mon Jul 12 19:40:09 2004
++++ Makefile.am Mon Jul 12 19:41:07 2004
+@@ -16,7 +16,8 @@
+
+ SUBDIRS = src docs
+
+-pkgconfigdir = $(libdir)/pkgconfig
++#pkgconfigdir = $(libdir)/pkgconfig
++pkgconfigdir = $(prefix)/libdata/pkgconfig
+ pkgconfig_DATA = cal3d.pc
+
+
diff --git a/graphics/cal3d/files/patch-src_cal3d_Makefile.am b/graphics/cal3d/files/patch-src_cal3d_Makefile.am
new file mode 100644
index 000000000000..af0cd89babb1
--- /dev/null
+++ b/graphics/cal3d/files/patch-src_cal3d_Makefile.am
@@ -0,0 +1,12 @@
+--- src/cal3d/Makefile.am.orig Mon Jul 12 17:34:29 2004
++++ src/cal3d/Makefile.am Mon Jul 12 17:35:04 2004
+@@ -13,7 +13,8 @@
+ INCLUDES = $(all_includes) -I$(top_srcdir)/src
+
+ all_libraries = @all_libraries@
+-LDFLAGS = @LDFLAGS@
++#LDFLAGS = @LDFLAGS@
++AM_LDFLAGS = @AM_LDFLAGS@
+
+ EXTRA_DIST = cal3d.rc cal3d.dsp SConscript
+
diff --git a/graphics/cal3d/files/patch-src_cal3d_buffersource.h b/graphics/cal3d/files/patch-src_cal3d_buffersource.h
new file mode 100644
index 000000000000..6cc393fdf3ed
--- /dev/null
+++ b/graphics/cal3d/files/patch-src_cal3d_buffersource.h
@@ -0,0 +1,11 @@
+--- src/cal3d/buffersource.h.orig Tue Jul 13 10:03:53 2004
++++ src/cal3d/buffersource.h Tue Jul 13 10:04:11 2004
+@@ -17,7 +17,7 @@
+
+ #include "cal3d/global.h"
+ #include "cal3d/datasource.h"
+-#include <istream>
++#include <istream.h>
+
+ /**
+ * CalBufferSource class.
diff --git a/graphics/cal3d/files/patch-src_cal3d_loader.h b/graphics/cal3d/files/patch-src_cal3d_loader.h
new file mode 100644
index 000000000000..8121123c1431
--- /dev/null
+++ b/graphics/cal3d/files/patch-src_cal3d_loader.h
@@ -0,0 +1,11 @@
+--- src/cal3d/loader.h.orig Tue Jul 13 10:04:57 2004
++++ src/cal3d/loader.h Tue Jul 13 10:05:09 2004
+@@ -17,7 +17,7 @@
+
+
+ #include <string>
+-#include <istream>
++#include <istream.h>
+ #include "cal3d/global.h"
+ #include "cal3d/datasource.h"
+
diff --git a/graphics/cal3d/files/patch-src_cal3d_streamsource.h b/graphics/cal3d/files/patch-src_cal3d_streamsource.h
new file mode 100644
index 000000000000..b2125b55736f
--- /dev/null
+++ b/graphics/cal3d/files/patch-src_cal3d_streamsource.h
@@ -0,0 +1,11 @@
+--- src/cal3d/streamsource.h.orig Tue Jul 13 10:05:35 2004
++++ src/cal3d/streamsource.h Tue Jul 13 10:05:47 2004
+@@ -17,7 +17,7 @@
+
+ #include "cal3d/global.h"
+ #include "cal3d/datasource.h"
+-#include <istream>
++#include <istream.h>
+
+ /**
+ * CalStreamSource class.
diff --git a/graphics/cal3d/pkg-descr b/graphics/cal3d/pkg-descr
new file mode 100644
index 000000000000..64470ac75479
--- /dev/null
+++ b/graphics/cal3d/pkg-descr
@@ -0,0 +1,19 @@
+Cal3D is a skeletal based 3D character animation library written in C++
+in a way that is both platform-independent and graphics API-independent.
+It was originally designed to be used in a 3D client for Worldforge, but
+evolved into a stand-alone product which can be used in many different
+kinds of projects.
+
+Cal3D's essentials can be boiled down to 2 parts: the C++ library and
+the exporter. The exporter is what you would use to take your characters
+(built in a 3D modeling package) and create the Cal3D-format files that
+the library knows how to load. The exporters are actually plug-ins for
+3D modeling packages. This allows 3D artists to use the modeling tools
+that they're already comfortable with.
+
+The C++ library is what you would actually use in your application,
+whether it's a game or a VR application. The library provides methods to
+load your exported files, build characters, run animations, and access
+the data necessary to render them with 3D graphics.
+
+WWW: http://cal3d.sourceforge.net/
diff --git a/graphics/cal3d/pkg-plist b/graphics/cal3d/pkg-plist
new file mode 100644
index 000000000000..54fc843ae4fc
--- /dev/null
+++ b/graphics/cal3d/pkg-plist
@@ -0,0 +1,45 @@
+include/cal3d/animation.h
+include/cal3d/animation_action.h
+include/cal3d/animation_cycle.h
+include/cal3d/bone.h
+include/cal3d/buffersource.h
+include/cal3d/cal3d.h
+include/cal3d/cal3d_wrapper.h
+include/cal3d/coreanimation.h
+include/cal3d/corebone.h
+include/cal3d/corekeyframe.h
+include/cal3d/corematerial.h
+include/cal3d/coremesh.h
+include/cal3d/coremodel.h
+include/cal3d/coremorphanimation.h
+include/cal3d/coreskeleton.h
+include/cal3d/coresubmesh.h
+include/cal3d/coresubmorphtarget.h
+include/cal3d/coretrack.h
+include/cal3d/datasource.h
+include/cal3d/error.h
+include/cal3d/global.h
+include/cal3d/loader.h
+include/cal3d/matrix.h
+include/cal3d/mesh.h
+include/cal3d/mixer.h
+include/cal3d/model.h
+include/cal3d/morphtargetmixer.h
+include/cal3d/physique.h
+include/cal3d/platform.h
+include/cal3d/quaternion.h
+include/cal3d/renderer.h
+include/cal3d/resource.h
+include/cal3d/saver.h
+include/cal3d/skeleton.h
+include/cal3d/springsystem.h
+include/cal3d/streamsource.h
+include/cal3d/submesh.h
+include/cal3d/tinystr.h
+include/cal3d/tinyxml.h
+include/cal3d/vector.h
+@dirrm include/cal3d
+lib/libcal3d-0.9.1.so
+lib/libcal3d.la
+lib/libcal3d.so
+libdata/pkgconfig/cal3d.pc