aboutsummaryrefslogtreecommitdiff
path: root/graphics/cbonsai
diff options
context:
space:
mode:
authorJoseph Mingrone <jrm@FreeBSD.org>2021-01-07 20:04:35 +0000
committerJoseph Mingrone <jrm@FreeBSD.org>2021-01-07 20:04:35 +0000
commitf972c72100cb01a6b9f0c689d27ae5a2202372ab (patch)
treeae91b2c951ee046130fa7f344a9af504c3e919cf /graphics/cbonsai
parentdf54ceca042e52bd2ee86ccf670ad647a937ebe3 (diff)
downloadports-f972c72100cb01a6b9f0c689d27ae5a2202372ab.tar.gz
ports-f972c72100cb01a6b9f0c689d27ae5a2202372ab.zip
New ports, graphics/cbonsai: Bonsai tree generator
Bonsai tree generator, written in C using ncurses. It intelligently creates, colors, and positions a bonsai tree, and is configurable. WWW: https://gitlab.com/jallbrit/cbonsai PR: 252412 Submitted by: Lewis Cook <vulcan@wired.sh> (maintainer) Reviewed by: daniel.engberg.lists@pyret.net
Notes
Notes: svn path=/head/; revision=560732
Diffstat (limited to 'graphics/cbonsai')
-rw-r--r--graphics/cbonsai/Makefile35
-rw-r--r--graphics/cbonsai/distinfo3
-rw-r--r--graphics/cbonsai/pkg-descr9
3 files changed, 47 insertions, 0 deletions
diff --git a/graphics/cbonsai/Makefile b/graphics/cbonsai/Makefile
new file mode 100644
index 000000000000..83e957521c10
--- /dev/null
+++ b/graphics/cbonsai/Makefile
@@ -0,0 +1,35 @@
+# $FreeBSD$
+
+PORTNAME= cbonsai
+DISTVERSION= g20210105
+CATEGORIES= graphics
+
+MAINTAINER= vulcan@wired.sh
+COMMENT= Bonsai tree generator, written in C using ncurses
+
+LICENSE= GPLv1
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= compiler:c11 localbase ncurses
+USE_GITLAB= yes
+GL_ACCOUNT= jallbrit
+GL_COMMIT= 9fe79e955b5d8f6dd7bdc85cbc4ac255934625d1
+
+LDFLAGS+= -lncurses -lpanel
+
+PLIST_FILES= bin/${PORTNAME}
+PORTDOCS= README.md
+
+OPTIONS_DEFINE= DOCS
+
+do-build:
+ ${CC} ${CFLAGS} ${LDFLAGS} ${WRKSRC}/${PORTNAME}.c -o ${WRKSRC}/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+
+post-install-DOCS-on:
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PORTDOCS} ${STAGEDIR}${DOCSDIR}
+
+.include <bsd.port.mk>
diff --git a/graphics/cbonsai/distinfo b/graphics/cbonsai/distinfo
new file mode 100644
index 000000000000..dc3dad6842c2
--- /dev/null
+++ b/graphics/cbonsai/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1610047634
+SHA256 (jallbrit-cbonsai-9fe79e955b5d8f6dd7bdc85cbc4ac255934625d1_GL0.tar.gz) = face063f1f3e13f12b6c6310621c48ec03bc90647f57813c4e98af2da9768dd2
+SIZE (jallbrit-cbonsai-9fe79e955b5d8f6dd7bdc85cbc4ac255934625d1_GL0.tar.gz) = 19767
diff --git a/graphics/cbonsai/pkg-descr b/graphics/cbonsai/pkg-descr
new file mode 100644
index 000000000000..46255912ea3b
--- /dev/null
+++ b/graphics/cbonsai/pkg-descr
@@ -0,0 +1,9 @@
+Bonsai tree generator, written in C
+using ncurses. It intelligently creates,
+colors, and positions a bonsai tree, and
+is entirely configurable via CLI options--
+see usage. There are 2 modes of operation:
+static (the default), and live. See modes
+for details.
+
+WWW: https://gitlab.com/jallbrit/cbonsai