aboutsummaryrefslogtreecommitdiff
path: root/graphics/cegui
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-09-02 12:59:54 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2014-09-02 12:59:54 +0000
commit68bc4af5c80eec76814f1f743dfc2c7bd4a356ef (patch)
tree67cd40943f0ef7eea725ecad6987a3d3cd88625d /graphics/cegui
parent5ead879a859c7215261464b4b594158d31c2da8f (diff)
downloadports-68bc4af5c80eec76814f1f743dfc2c7bd4a356ef.tar.gz
ports-68bc4af5c80eec76814f1f743dfc2c7bd4a356ef.zip
Update CMake to 3.0.1.
The 3.0 series is an incremental improvement over the previous 2.8 series despite the major version number change. A list of important changes is available at http://www.cmake.org/cmake/help/v3.0/release/3.0.0.html On the porting side * The minimum FreeBSD release we have to support in the ports tree is now recent enough that ports/168671 can finally be committed: instead of building and using CMake's own copies of bzip2, curl, expat, libarchive, liblzma and zlib, we use the versions in ports and/or the base system. * CMake's documentation system has been changed and vastly improved at the cost of now depending on Sphinx. We still generate only man pages, but can start generating the HTML documentation in the future if desired. * devel/cmake-gui now uses Qt5 instead of Qt4 and does not needlessly build the ncurses UI that is installed by devel/cmake itself. * CMake commit 3816cd2 fixes a longstanding issue in the detection of the Python interpreter and its libraries, but requires us to revert a workaround for that in Mk/Uses/python.mk itself, effectively reverting the patch introduced by ports/168159. * Similarly, a few ports had to be fixed manually due to CMake being stricter when parsing some files or the ports detecting Python the wrong way. Fortunately, they all had been fixed upstream so I just grabbed the appropriate commits and pointed to them in the patches. science/gnudatalanguage had to have its PORTREVISION bumped because switching to USES=cmake:outsource removed a few files from the plist that were not supposed to have been installed in the first place. PR: 168671 PR: 192644
Notes
Notes: svn path=/head/; revision=366996
Diffstat (limited to 'graphics/cegui')
-rw-r--r--graphics/cegui/files/patch-CMakeLists.txt23
-rw-r--r--graphics/cegui/files/patch-cmake__CEGUIMacros.cmake70
2 files changed, 93 insertions, 0 deletions
diff --git a/graphics/cegui/files/patch-CMakeLists.txt b/graphics/cegui/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..a2666afdd6c7
--- /dev/null
+++ b/graphics/cegui/files/patch-CMakeLists.txt
@@ -0,0 +1,23 @@
+This is part of a changeset required for the port to build with CMake 3.0.
+See patch-cmake__CEGUIMacros.cmake as well.
+
+# HG changeset patch
+# User Danduk82 <danduk82@hotmail.com>
+# Date 1390065964 -3600
+# Branch v0-8
+# Node ID 320ecd58eb1b3d673eee62a913041f643c50d483
+# Parent 83954df05b3b1b94ada2137ef5d028de54d11818
+A) fixed new CMAKE policy CMP0045 issue in CMakeLists.txt. This feature was introduced recently in this commit: https://gitorious.org/cmake/cmake/commit/73e93400e2efab2096618ff58a5ad68236cd04aa ... Bb) fixed CMAKE problem with cmake/CEGUIMacros.cmake when including the project with ExternalProject_Add() CMAKE feature in a project. I had to escape the '[' and ']' characters because in this way CMAKE was not recognizing those characters. CMAKE version: 2.8.12.
+--- ./CMakeLists.txt.orig 2013-12-07 11:37:07.000000000 +0200
++++ ./CMakeLists.txt 2014-08-29 00:28:26.000000000 +0300
+@@ -6,6 +6,10 @@
+ cmake_policy(SET CMP0017 OLD)
+ endif()
+
++if (POLICY CMP0045)
++ cmake_policy(SET CMP0045 OLD)
++endif()
++
+ set (CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake")
+ include(CEGUIMacros)
+ include(CMakeDependentOption)
diff --git a/graphics/cegui/files/patch-cmake__CEGUIMacros.cmake b/graphics/cegui/files/patch-cmake__CEGUIMacros.cmake
new file mode 100644
index 000000000000..8539a3150b4d
--- /dev/null
+++ b/graphics/cegui/files/patch-cmake__CEGUIMacros.cmake
@@ -0,0 +1,70 @@
+These two commits are required for the port to build with CMake 3.0.
+See patch-CMakeLists.txt as well.
+
+# HG changeset patch
+# User Danduk82 <danduk82@hotmail.com>
+# Date 1390065964 -3600
+# Branch v0-8
+# Node ID 320ecd58eb1b3d673eee62a913041f643c50d483
+# Parent 83954df05b3b1b94ada2137ef5d028de54d11818
+A) fixed new CMAKE policy CMP0045 issue in CMakeLists.txt. This feature was introduced recently in this commit: https://gitorious.org/cmake/cmake/commit/73e93400e2efab2096618ff58a5ad68236cd04aa ... Bb) fixed CMAKE problem with cmake/CEGUIMacros.cmake when including the project with ExternalProject_Add() CMAKE feature in a project. I had to escape the '[' and ']' characters because in this way CMAKE was not recognizing those characters. CMAKE version: 2.8.12.
+
+# HG changeset patch
+# User Paul Turner <paul@cegui.org.uk>
+# Date 1402736843 -3600
+# Branch v0-8
+# Node ID 72b84028e58fc307cb2c9749d5cd17fc71059e6a
+# Parent 243fc257b6c94452c13cceb65452a665509669dc
+FIX: switch to 'if test' syntax from 'if [' for shell commands (cmake issues)
+--- ./cmake/CEGUIMacros.cmake.orig 2014-08-29 00:28:26.000000000 +0300
++++ ./cmake/CEGUIMacros.cmake 2014-08-29 00:28:30.000000000 +0300
+@@ -309,33 +309,33 @@
+ endif()
+
+ add_custom_command(TARGET ${_TARGET_NAME} POST_BUILD
+- COMMAND if [ x${_CEGUI_BUILD_CONFIG} == xDebug ]\; then ce_ext=\"${CEGUI_BUILD_SUFFIX}\"\; else ce_ext=\"\"\; fi\; rm -rf \"${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/${_TARGET_NAME}$$ce_ext.app/Contents/Frameworks\"
++ COMMAND if test x${_CEGUI_BUILD_CONFIG} == xDebug \; then ce_ext=\"${CEGUI_BUILD_SUFFIX}\"\; else ce_ext=\"\"\; fi\; rm -rf \"${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/${_TARGET_NAME}$$ce_ext.app/Contents/Frameworks\"
+ COMMENT "Removing old Frameworks in ${_TARGET_NAME}.app")
+ add_custom_command(TARGET ${_TARGET_NAME} POST_BUILD
+- COMMAND if [ x${_CEGUI_BUILD_CONFIG} == xDebug ]\; then ce_ext=\"${CEGUI_BUILD_SUFFIX}\"\; else ce_ext=\"\"\; fi\; rm -rf \"${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/${_TARGET_NAME}$$ce_ext.app/Contents/Resources\"
++ COMMAND if test x${_CEGUI_BUILD_CONFIG} == xDebug \; then ce_ext=\"${CEGUI_BUILD_SUFFIX}\"\; else ce_ext=\"\"\; fi\; rm -rf \"${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/${_TARGET_NAME}$$ce_ext.app/Contents/Resources\"
+ COMMENT "Removing old Resources in ${_TARGET_NAME}.app")
+
+ add_custom_command(TARGET ${_TARGET_NAME} POST_BUILD
+- COMMAND if [ x${_CEGUI_BUILD_CONFIG} == xDebug ]\; then ce_ext=\"${CEGUI_BUILD_SUFFIX}\"\; else ce_ext=\"\"\; fi\; mkdir -p \"${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/${_TARGET_NAME}$$ce_ext.app/Contents/Frameworks\"
++ COMMAND if test x${_CEGUI_BUILD_CONFIG} == xDebug \; then ce_ext=\"${CEGUI_BUILD_SUFFIX}\"\; else ce_ext=\"\"\; fi\; mkdir -p \"${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/${_TARGET_NAME}$$ce_ext.app/Contents/Frameworks\"
+ COMMENT "Creating Frameworks directory ${_TARGET_NAME}.app")
+ add_custom_command(TARGET ${_TARGET_NAME} POST_BUILD
+- COMMAND if [ x${_CEGUI_BUILD_CONFIG} == xDebug ]\; then ce_ext=\"${CEGUI_BUILD_SUFFIX}\"\; else ce_ext=\"\"\; fi\; mkdir -p \"${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/${_TARGET_NAME}$$ce_ext.app/Contents/Resources\"
++ COMMAND if test x${_CEGUI_BUILD_CONFIG} == xDebug \; then ce_ext=\"${CEGUI_BUILD_SUFFIX}\"\; else ce_ext=\"\"\; fi\; mkdir -p \"${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/${_TARGET_NAME}$$ce_ext.app/Contents/Resources\"
+ COMMENT "Creating Resources directory ${_TARGET_NAME}.app")
+
+ if (NOT ${_STATIC})
+ if (NOT CEGUI_BUILD_SHARED_LIBS_WITH_STATIC_DEPENDENCIES)
+ add_custom_command(TARGET ${_TARGET_NAME} POST_BUILD
+- COMMAND if [ x${_CEGUI_BUILD_CONFIG} == xDebug ]\; then ce_ext=\"${CEGUI_BUILD_SUFFIX}\"\; ce_libglob=\"*${CEGUI_BUILD_SUFFIX}.dylib\"\; else ce_ext=\"\"\; shopt -s extglob\; ce_libglob=\"!\(*${CEGUI_BUILD_SUFFIX}\).dylib\"\; fi\; ${_ACTIONCMD} ${CMAKE_PREFIX_PATH}/lib/dynamic/$$ce_libglob \"${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/${_TARGET_NAME}$$ce_ext.app/Contents/Frameworks/\"
++ COMMAND if test x${_CEGUI_BUILD_CONFIG} == xDebug \; then ce_ext=\"${CEGUI_BUILD_SUFFIX}\"\; ce_libglob=\"*${CEGUI_BUILD_SUFFIX}.dylib\"\; else ce_ext=\"\"\; shopt -s extglob\; ce_libglob=\"!\(*${CEGUI_BUILD_SUFFIX}\).dylib\"\; fi\; ${_ACTIONCMD} ${CMAKE_PREFIX_PATH}/lib/dynamic/$$ce_libglob \"${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/${_TARGET_NAME}$$ce_ext.app/Contents/Frameworks/\"
+ COMMENT "Creating ${_ACTIONMSG} dependency libraries in ${_TARGET_NAME}.app")
+ endif()
+
+ add_custom_command(TARGET ${_TARGET_NAME} POST_BUILD
+- COMMAND if [ x${_CEGUI_BUILD_CONFIG} == xDebug ]\; then ce_ext=\"${CEGUI_BUILD_SUFFIX}\"\; ce_libglob=\"*${CEGUI_BUILD_SUFFIX}.dylib\"\; else ce_ext=\"\"\; shopt -s extglob\; ce_libglob=\"!\(*${CEGUI_BUILD_SUFFIX}\).dylib\"\; fi\; ${_ACTIONCMD} ${CMAKE_LIBRARY_OUTPUT_DIRECTORY}/$$ce_libglob \"${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/${_TARGET_NAME}$$ce_ext.app/Contents/Frameworks/\"
++ COMMAND if test x${_CEGUI_BUILD_CONFIG} == xDebug \; then ce_ext=\"${CEGUI_BUILD_SUFFIX}\"\; ce_libglob=\"*${CEGUI_BUILD_SUFFIX}.dylib\"\; else ce_ext=\"\"\; shopt -s extglob\; ce_libglob=\"!\(*${CEGUI_BUILD_SUFFIX}\).dylib\"\; fi\; ${_ACTIONCMD} ${CMAKE_LIBRARY_OUTPUT_DIRECTORY}/$$ce_libglob \"${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/${_TARGET_NAME}$$ce_ext.app/Contents/Frameworks/\"
+ COMMENT "Creating ${_ACTIONMSG} built cegui libraries in ${_TARGET_NAME}.app")
+ endif()
+
+ add_custom_command(TARGET ${_TARGET_NAME} POST_BUILD
+- COMMAND if [ x${_CEGUI_BUILD_CONFIG} == xDebug ]\; then ce_ext=\"${CEGUI_BUILD_SUFFIX}\"\; else ce_ext=\"\"\; fi\; ${_ACTIONCMD} ${CMAKE_SOURCE_DIR}/datafiles \"${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/${_TARGET_NAME}$$ce_ext.app/Contents/Resources/\"
++ COMMAND if test x${_CEGUI_BUILD_CONFIG} == xDebug \; then ce_ext=\"${CEGUI_BUILD_SUFFIX}\"\; else ce_ext=\"\"\; fi\; ${_ACTIONCMD} ${CMAKE_SOURCE_DIR}/datafiles \"${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/${_TARGET_NAME}$$ce_ext.app/Contents/Resources/\"
+ COMMENT "Creating ${_ACTIONMSG} sample datafiles ${_TARGET_NAME}.app")
+
+ # When CEGUI_APPLE_SYMLINK_DEPENDENCIES_TO_SAMPLE_APPS is TRUE, this
+@@ -345,7 +345,7 @@
+ # CEGUI_APPLE_SYMLINK_DEPENDENCIES_TO_SAMPLE_APPS to false and the thing
+ # will be copied to the output app bundle instead.
+ add_custom_command(TARGET ${_TARGET_NAME} POST_BUILD
+- COMMAND if [ x${_CEGUI_BUILD_CONFIG} == xDebug ]\; then ce_ext=\"${CEGUI_BUILD_SUFFIX}\"\; else ce_ext=\"\"\; fi\; ${_ACTIONCMD} ${CMAKE_BINARY_DIR}/datafiles/samples \"${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/${_TARGET_NAME}$$ce_ext.app/Contents/Resources/datafiles\"
++ COMMAND if test x${_CEGUI_BUILD_CONFIG} == xDebug \; then ce_ext=\"${CEGUI_BUILD_SUFFIX}\"\; else ce_ext=\"\"\; fi\; ${_ACTIONCMD} ${CMAKE_BINARY_DIR}/datafiles/samples \"${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/${_TARGET_NAME}$$ce_ext.app/Contents/Resources/datafiles\"
+ COMMENT "Creating ${_ACTIONMSG} samples.xml ${_TARGET_NAME}.app")
+ endmacro()
+