aboutsummaryrefslogtreecommitdiff
path: root/graphics/cinepaint
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2008-09-08 20:48:45 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2008-09-08 20:48:45 +0000
commit10416a2b6ee697e3b4df7b5b60d64f64e426b7bd (patch)
tree735dfd3edd58d3d1633bf1ef34c67a23357d4ee7 /graphics/cinepaint
parent32410765ec016fbc25f89834b35b01d5e9494262 (diff)
downloadports-10416a2b6ee697e3b4df7b5b60d64f64e426b7bd.tar.gz
ports-10416a2b6ee697e3b4df7b5b60d64f64e426b7bd.zip
Notes
Diffstat (limited to 'graphics/cinepaint')
-rw-r--r--graphics/cinepaint/Makefile17
-rw-r--r--graphics/cinepaint/files/patch-plug-ins-icc_examin-icc_examin_icc_helfer_fltk.cpp11
2 files changed, 22 insertions, 6 deletions
diff --git a/graphics/cinepaint/Makefile b/graphics/cinepaint/Makefile
index 180c6b0e02d4..82ed6fdf35d8 100644
--- a/graphics/cinepaint/Makefile
+++ b/graphics/cinepaint/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cinepaint
PORTVERSION= 0.22
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= graphics
MASTER_SITES= SF
DISTNAME= ${PORTNAME}-${PORTVERSION}-1
@@ -18,7 +18,8 @@ COMMENT= An editing tool used for painting and retouching of movies
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
lcms.1:${PORTSDIR}/graphics/lcms \
- tiff.4:${PORTSDIR}/graphics/tiff
+ tiff.4:${PORTSDIR}/graphics/tiff \
+ ftgl.2:${PORTSDIR}/graphics/ftgl
USE_AUTOTOOLS= libtool:15
GNU_CONFIGURE= yes
@@ -36,20 +37,24 @@ WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}-1
OPTIONS= OPENEXR "Use OpenEXR" on
-BROKEN= does not compile
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
.include <bsd.port.pre.mk>
.if defined(WITH_OPENEXR)
-LIB_DEPENDS+= IlmImf.6:${PORTSDIR}/graphics/OpenEXR \
- fltk.1:${PORTSDIR}/x11-toolkits/fltk-threads
+LIB_DEPENDS+= IlmImf.6:${PORTSDIR}/graphics/OpenEXR
+BUILD_DEPENDS+= fltk-threads>0:${PORTSDIR}/x11-toolkits/fltk-threads
+RUN_DEPENDS+= fltk-threads>0:${PORTSDIR}/x11-toolkits/fltk-threads
CONFIGURE_ARGS+= --with-openexr-prefix=${LOCALBASE}
-CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS} -I${LOCALBASE}/include/OpenEXR"
+CFLAGS+= -I${LOCALBASE}/include/openEXR
PLIST_SUB+= OPENEXR:=""
.else
PLIST_SUB+= OPENEXR:="@comment "
.endif
+CONFIGURE_ENV+= CPPFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
+
post-patch:
@${REINPLACE_CMD} -e \
's| -Wall||' \
diff --git a/graphics/cinepaint/files/patch-plug-ins-icc_examin-icc_examin_icc_helfer_fltk.cpp b/graphics/cinepaint/files/patch-plug-ins-icc_examin-icc_examin_icc_helfer_fltk.cpp
new file mode 100644
index 000000000000..f1d09fa27376
--- /dev/null
+++ b/graphics/cinepaint/files/patch-plug-ins-icc_examin-icc_examin_icc_helfer_fltk.cpp
@@ -0,0 +1,11 @@
+--- plug-ins/icc_examin/icc_examin/icc_helfer_fltk.cpp.orig 2008-09-03 02:07:08.000000000 +0200
++++ plug-ins/icc_examin/icc_examin/icc_helfer_fltk.cpp 2008-09-03 02:08:02.000000000 +0200
+@@ -226,7 +226,7 @@
+
+ int awake(void)
+ {
+- Fl::awake(0);
++ Fl::awake((void *)0);
+ return 0;
+ }
+ int leerWait(void) { return 0; }