aboutsummaryrefslogtreecommitdiff
path: root/graphics/cogl
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2017-06-09 09:28:08 +0000
committerKoop Mast <kwm@FreeBSD.org>2017-06-09 09:28:08 +0000
commit1f3fcf7ad00afd0337ab0966382eb634a00479bf (patch)
tree278c340466caaa7ded7214285051771842b68dda /graphics/cogl
parentebfd40b3d438ecf96896dc504f77e0255c2e19e5 (diff)
downloadports-1f3fcf7ad00afd0337ab0966382eb634a00479bf.tar.gz
ports-1f3fcf7ad00afd0337ab0966382eb634a00479bf.zip
Update cogl to 1.22.2.
* Review dependancies * Switch to USES=localbase Obtained from: gnome devel repo (based on)
Notes
Notes: svn path=/head/; revision=442974
Diffstat (limited to 'graphics/cogl')
-rw-r--r--graphics/cogl/Makefile15
-rw-r--r--graphics/cogl/distinfo5
-rw-r--r--graphics/cogl/files/patch-cogl_winsys_cogl-winsys-egl.c11
3 files changed, 20 insertions, 11 deletions
diff --git a/graphics/cogl/Makefile b/graphics/cogl/Makefile
index 0b5c7b5e90fd..6c3d177b5294 100644
--- a/graphics/cogl/Makefile
+++ b/graphics/cogl/Makefile
@@ -2,8 +2,7 @@
# $FreeBSD$
PORTNAME= cogl
-PORTVERSION= 1.22.0
-PORTREVISION= 1
+PORTVERSION= 1.22.2
CATEGORIES= graphics
MASTER_SITES= GNOME
@@ -15,18 +14,16 @@ LICENSE_FILE= ${WRKSRC}/COPYING
CONFLICTS= clutter-1.6.[0-9]*
-USES= gettext gmake gnome libtool pathfix pkgconfig tar:xz
+USES= gettext gmake gnome libtool localbase pathfix pkgconfig tar:xz
GNU_CONFIGURE= yes
-USE_GNOME= gdkpixbuf2 gnomeprefix atk pango introspection:build
-USE_GL= gl egl
-USE_XORG= x11 xfixes xdamage xcomposite xi xrandr
+USE_GNOME= cairo gdkpixbuf2 pango introspection:build
+USE_GL= egl
+USE_XORG= x11 xcomposite xext xdamage xfixes xrandr
USE_LDCONFIG= yes
CONFIGURE_ARGS= --with-x \
--enable-xlib-egl-platform=yes
-CPPFLAGS+= -I${LOCALBASE}/include
-LDFLAGS+= -L${LOCALBASE}/lib
INSTALL_TARGET= install-strip
-PLIST_SUB= LIBVER=20 LIBVERSION=20.4.1
+PLIST_SUB= LIBVER=20 LIBVERSION=20.4.2
.include <bsd.port.mk>
diff --git a/graphics/cogl/distinfo b/graphics/cogl/distinfo
index d75828039d26..ef5e1927873f 100644
--- a/graphics/cogl/distinfo
+++ b/graphics/cogl/distinfo
@@ -1,2 +1,3 @@
-SHA256 (cogl-1.22.0.tar.xz) = 689dfb5d14fc1106e9d2ded0f7930dcf7265d0bc84fa846b4f03941633eeaa91
-SIZE (cogl-1.22.0.tar.xz) = 1654120
+TIMESTAMP = 1495454213
+SHA256 (cogl-1.22.2.tar.xz) = 39a718cdb64ea45225a7e94f88dddec1869ab37a21b339ad058a9d898782c00d
+SIZE (cogl-1.22.2.tar.xz) = 1682360
diff --git a/graphics/cogl/files/patch-cogl_winsys_cogl-winsys-egl.c b/graphics/cogl/files/patch-cogl_winsys_cogl-winsys-egl.c
new file mode 100644
index 000000000000..21d85b7352d0
--- /dev/null
+++ b/graphics/cogl/files/patch-cogl_winsys_cogl-winsys-egl.c
@@ -0,0 +1,11 @@
+--- cogl/winsys/cogl-winsys-egl.c.orig 2016-08-26 16:18:16 UTC
++++ cogl/winsys/cogl-winsys-egl.c
+@@ -1029,7 +1029,7 @@ _cogl_egl_create_image (CoglContext *ctx,
+ egl_ctx = EGL_NO_CONTEXT;
+ else
+ #endif
+-#if COGL_HAS_WAYLAND_EGL_SERVER_SUPPORT
++#ifdef COGL_HAS_WAYLAND_EGL_SERVER_SUPPORT
+ /* The WL_bind_wayland_display spec states that EGL_NO_CONTEXT is to be used
+ * in conjunction with the EGL_WAYLAND_BUFFER_WL target */
+ if (target == EGL_WAYLAND_BUFFER_WL)