aboutsummaryrefslogtreecommitdiff
path: root/graphics/colmap
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-01-01 13:42:54 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-01-01 13:42:54 +0000
commit9d1dc2407c8c73dc5926948037e09b3d55402ec2 (patch)
tree38db9f1d8ee32af4ab5c52ef2f7c2b9aef2a174d /graphics/colmap
parent703d0747022749b4474a5ea5bda11e2ee9768aec (diff)
downloadports-9d1dc2407c8c73dc5926948037e09b3d55402ec2.tar.gz
ports-9d1dc2407c8c73dc5926948037e09b3d55402ec2.zip
Improve CMake style in my ports
- Convert to CMAKE_{ON,OFF} helpers - Convert to _CMAKE_BOOL option helpers - android-file-transfer: Share _CMAKE_BOOL via _IMPLIES - Annotate types
Notes
Notes: svn path=/head/; revision=457776
Diffstat (limited to 'graphics/colmap')
-rw-r--r--graphics/colmap/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/graphics/colmap/Makefile b/graphics/colmap/Makefile
index 406dee01ad8a..89443b2a5a27 100644
--- a/graphics/colmap/Makefile
+++ b/graphics/colmap/Makefile
@@ -30,7 +30,7 @@ USE_GL= gl glew
USE_QT5= qmake_build buildtools_build core gui opengl_build widgets
EXCLUDE= SQLite
EXTRACT_AFTER_ARGS= ${EXCLUDE:S,^,--exclude src/ext/,}
-CMAKE_ARGS= -DBOOST_STATIC=off -DCUDA_ENABLED=off
+CMAKE_OFF= BOOST_STATIC CUDA_ENABLED
CFLAGS+= -DVL_OS_LINUX=1
CXXFLAGS+= -D_GLIBCXX_USE_C99 -D_GLIBCXX_USE_C99_MATH_TR1 \
-D_DECLARE_C99_LDBL_MATH # XXX ports/193528