aboutsummaryrefslogtreecommitdiff
path: root/graphics/colmap
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-08-27 11:05:13 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-08-27 11:05:13 +0000
commiteef7996894e047798f7fee88a4ae1b00096eda8c (patch)
treeea30583684e1c821463208c54a7ec6462a0900c9 /graphics/colmap
parentde9496a230a2a7ab092eaadeb601fd097133b327 (diff)
downloadports-eef7996894e047798f7fee88a4ae1b00096eda8c.tar.gz
ports-eef7996894e047798f7fee88a4ae1b00096eda8c.zip
graphics/colmap: update to 3.5
Notes
Notes: svn path=/head/; revision=478190
Diffstat (limited to 'graphics/colmap')
-rw-r--r--graphics/colmap/Makefile50
-rw-r--r--graphics/colmap/distinfo6
-rw-r--r--graphics/colmap/files/patch-no-sse33
-rw-r--r--graphics/colmap/files/patch-src_ext_VLFeat_host.c20
-rw-r--r--graphics/colmap/files/patch-vlfeat-rtcpu59
-rw-r--r--graphics/colmap/pkg-plist300
6 files changed, 334 insertions, 134 deletions
diff --git a/graphics/colmap/Makefile b/graphics/colmap/Makefile
index 8510dbac6f94..c1991d61e837 100644
--- a/graphics/colmap/Makefile
+++ b/graphics/colmap/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= colmap
-DISTVERSION= 3.4
-PORTREVISION= 4
+DISTVERSION= 3.5
CATEGORIES= graphics
MAINTAINER= jbeich@FreeBSD.org
@@ -11,12 +10,12 @@ COMMENT= Structure from motion and multi-view stereo
LICENSE= BSD2CLAUSE BSD3CLAUSE CC-BY-3.0 GPLv3+ MIT SIFTGPU
LICENSE_COMB= multi
LICENSE_NAME_SIFTGPU= SiftGPU non-commercial license
-LICENSE_FILE_BSD2CLAUSE=${WRKSRC}/src/ext/VLFeat/LICENSE
-LICENSE_FILE_BSD3CLAUSE=${WRKSRC}/src/ext/FLANN/LICENSE
+LICENSE_FILE_BSD2CLAUSE=${WRKSRC}/lib/VLFeat/LICENSE
+LICENSE_FILE_BSD3CLAUSE=${WRKSRC}/COPYING.txt # also FLANN
LICENSE_FILE_CC-BY-3.0= ${WRKSRC}/src/ui/media/LICENSE
-LICENSE_FILE_GPLv3+ = ${WRKSRC}/COPYING.txt
-LICENSE_FILE_MIT= ${WRKSRC}/src/ext/PoissonRecon/LICENSE
-LICENSE_FILE_SIFTGPU= ${WRKSRC}/src/ext/SiftGPU/LICENSE
+LICENSE_FILE_GPLv3+ = ${WRKSRC}/lib/PBA/LICENSE # also Graclus, LSD
+LICENSE_FILE_MIT= ${WRKSRC}/lib/PoissonRecon/LICENSE
+LICENSE_FILE_SIFTGPU= ${WRKSRC}/lib/SiftGPU/LICENSE
LICENSE_PERMS_SIFTGPU= dist-mirror pkg-mirror auto-accept
LIB_DEPENDS= libboost_filesystem.so:devel/boost-libs \
@@ -29,17 +28,19 @@ USE_GITHUB= yes
USE_GL= gl glew
USE_QT= qmake_build buildtools_build core gui opengl_build widgets
EXCLUDE= SQLite
-EXTRACT_AFTER_ARGS= ${EXCLUDE:S,^,--exclude src/ext/,}
+EXTRACT_AFTER_ARGS= ${EXCLUDE:S,^,--exclude lib/,}
CMAKE_OFF= BOOST_STATIC CUDA_ENABLED
-CFLAGS+= -DVL_OS_LINUX=1
CXXFLAGS+= -D_GLIBCXX_USE_C99 -D_GLIBCXX_USE_C99_MATH_TR1 \
-D_DECLARE_C99_LDBL_MATH # XXX ports/193528
LDFLAGS+= -Wl,--as-needed # gflags, glu, xi, xmu
TEST_TARGET= test ARGS="-V"
-PLIST_FILES= bin/colmap
-OPTIONS_DEFINE= DOCS OPENMP SIMD TEST
-OPTIONS_DEFAULT= OPENMP SIMD
+OPTIONS_DEFINE= CGAL DOCS OPENMP SIMD TEST
+OPTIONS_DEFAULT= CGAL OPENMP SIMD
+
+CGAL_DESC= Graph-cut on Delaunay triangulation based meshing algorithm
+CGAL_LIB_DEPENDS= libCGAL.so:math/cgal
+CGAL_CMAKE_BOOL= CGAL_ENABLED
DOCS_BUILD_DEPENDS= sphinx-build:textproc/py-sphinx
DOCS_USES= gmake
@@ -55,14 +56,12 @@ SIMD_CMAKE_BOOL= SIMD_ENABLED
TEST_CMAKE_BOOL= TESTS_ENABLED
post-patch:
- @${REINPLACE_CMD} -e 's/Qt5OpenGL/Qt5Widgets/' \
- ${WRKSRC}/CMakeLists.txt
- @${REINPLACE_CMD} -e '/install.*test/d' \
- ${WRKSRC}/cmake/CMakeHelper.cmake
-# XXX Unbundle FLANN as it has more consumers
+# XXX math/flann has -DUSE_OPENMP=OFF and lacks tunning:
+# https://github.com/colmap/colmap/commit/4b594eb85c13
+# https://github.com/colmap/colmap/commit/1e9f1f3324cd
@${REINPLACE_CMD} -e '/SQLite/d' \
- ${WRKSRC}/src/ext/CMakeLists.txt
- @${REINPLACE_CMD} -e 's,ext/SQLite/,,' \
+ ${WRKSRC}/lib/CMakeLists.txt
+ @${REINPLACE_CMD} -e 's,SQLite/,,' \
${WRKSRC}/src/base/database.h \
${WRKSRC}/src/util/sqlite3_utils.h
.if !defined(DISPLAY) # QApplication
@@ -78,8 +77,21 @@ post-build-DOCS-on:
pre-install-TEST-on: do-test
+post-install:
+# XXX Clean up garbage after install(DIRECTORY)
+ @${FIND} ${STAGEDIR}${PREFIX}/include -type d -empty -delete
+
post-install-DOCS-on:
(cd ${WRKSRC}/doc/_build/html && ${COPYTREE_SHARE} \
"${PORTDOCS}" ${STAGEDIR}${DOCSDIR})
+.include <bsd.port.options.mk>
+
+post-patch: sincos-arm
+sincos-arm:
+.if ${OPSYS} == FreeBSD && ${OSVERSION} < 1101504 && ${MACHINE} == arm
+ @${REINPLACE_CMD} -e 's/-ffast-math/& -fno-unsafe-math-optimizations/' \
+ ${WRKSRC}/lib/PoissonRecon/CMakeLists.txt
+.endif
+
.include <bsd.port.mk>
diff --git a/graphics/colmap/distinfo b/graphics/colmap/distinfo
index c5992b9c7391..e9b2708d400d 100644
--- a/graphics/colmap/distinfo
+++ b/graphics/colmap/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1517292298
-SHA256 (colmap-colmap-3.4_GH0.tar.gz) = 6c1a20482f02f0ac57386e18350731bc569a40cbd9a92ee7b7e7d944fd4f650f
-SIZE (colmap-colmap-3.4_GH0.tar.gz) = 5690173
+TIMESTAMP = 1535031594
+SHA256 (colmap-colmap-3.5_GH0.tar.gz) = 7a23856a5662daf5466ef9cdf821eb139f2e1bd6f0d3a03d1558ace5bc49bc06
+SIZE (colmap-colmap-3.5_GH0.tar.gz) = 5872165
diff --git a/graphics/colmap/files/patch-no-sse b/graphics/colmap/files/patch-no-sse
deleted file mode 100644
index 6255f0ee4fca..000000000000
--- a/graphics/colmap/files/patch-no-sse
+++ /dev/null
@@ -1,33 +0,0 @@
-build: don't force SSE on i386
-
---- src/ext/PBA/CMakeLists.txt.orig 2017-06-15 14:32:01 UTC
-+++ src/ext/PBA/CMakeLists.txt
-@@ -1,5 +1,5 @@
- if(NOT IS_MSVC)
-- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fPIC -O3 -pthread -march=core2 -mfpmath=sse -Wno-c++11-narrowing")
-+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wno-c++11-narrowing")
- endif()
-
- if(CUDA_ENABLED)
---- src/ext/PBA/SparseBundleCPU.cpp.orig 2017-06-15 14:32:01 UTC
-+++ src/ext/PBA/SparseBundleCPU.cpp
-@@ -52,15 +52,16 @@ using std::max;
- #if defined(_M_ARM) && _M_ARM >= 7 && !defined(DISABLE_CPU_NEON)
- #include <arm_neon.h>
- #define CPUPBA_USE_NEON
--#elif defined(__ARM_NEON__) && !defined(DISABLE_CPU_NEON)
-+#elif defined(__ARM_NEON) && !defined(DISABLE_CPU_NEON)
- #include <arm_neon.h>
- #define CPUPBA_USE_NEON
- #endif
--#elif defined(CPUPBA_USE_AVX) // Using AVX
-+#elif defined(__AVX__) && !defined(DISABLE_CPU_AVX) // Using AVX
- #include <immintrin.h>
-+#define CPUPBA_USE_AVX
- #undef CPUPBA_USE_SSE
- #undef POINT_DATA_ALIGN4
--#elif !defined(DISABLE_CPU_SSE) // Using SSE
-+#elif defined(__SSE2__) && !defined(DISABLE_CPU_SSE) // Using SSE
- #define CPUPBA_USE_SSE
- #include <xmmintrin.h>
- #include <emmintrin.h>
diff --git a/graphics/colmap/files/patch-src_ext_VLFeat_host.c b/graphics/colmap/files/patch-src_ext_VLFeat_host.c
deleted file mode 100644
index 4d5386268a11..000000000000
--- a/graphics/colmap/files/patch-src_ext_VLFeat_host.c
+++ /dev/null
@@ -1,20 +0,0 @@
-vlfeat: don't try to use CPUID on non-x86
-
---- src/ext/VLFeat/host.c.orig 2017-06-15 14:32:01 UTC
-+++ src/ext/VLFeat/host.c
-@@ -441,6 +441,7 @@ _vl_cpuid (vl_int32* info, int function)
-
- #endif
-
-+#if defined(VL_ARCH_IX86) || defined(VL_ARCH_X64) || defined(VL_ARCH_IA64)
- void
- _vl_x86cpu_info_init (VlX86CpuInfo *self)
- {
-@@ -487,6 +488,7 @@ _vl_x86cpu_info_to_string_copy (VlX86CpuInfo const *se
- }
- return string ;
- }
-+#endif
-
- /** ------------------------------------------------------------------
- ** @brief Human readable static library configuration
diff --git a/graphics/colmap/files/patch-vlfeat-rtcpu b/graphics/colmap/files/patch-vlfeat-rtcpu
deleted file mode 100644
index 46288f4ab20b..000000000000
--- a/graphics/colmap/files/patch-vlfeat-rtcpu
+++ /dev/null
@@ -1,59 +0,0 @@
-build: don't force SSE2/AVX, enable at runtime instead
-
---- CMakeLists.txt.orig 2017-11-21 22:46:29 UTC
-+++ CMakeLists.txt
-@@ -17,8 +17,6 @@ include(CheckCXXCompilerFlag)
- # the CMake policies in this file
- include(${CMAKE_SOURCE_DIR}/cmake/CMakeHelper.cmake NO_POLICY_SCOPE)
-
--include(${CMAKE_SOURCE_DIR}/cmake/CheckSSEExtensions.cmake)
--
- if(EXISTS ${CMAKE_SOURCE_DIR}/LocalConfig.cmake)
- include(${CMAKE_SOURCE_DIR}/LocalConfig.cmake)
- endif()
-@@ -28,6 +26,7 @@ endif()
- # Options
- ################################################################################
-
-+option(SIMD_ENABLED "Whether to enable SIMD optimizations" ON)
- option(OPENMP_ENABLED "Whether to enable OpenMP" ON)
- option(IPO_ENABLED "Whether to enable interprocedural optimization" ON)
- option(CUDA_ENABLED "Whether to enable CUDA, if available" ON)
---- src/ext/VLFeat/CMakeLists.txt.orig 2017-11-21 22:46:29 UTC
-+++ src/ext/VLFeat/CMakeLists.txt
-@@ -70,16 +70,16 @@ set(VLFEAT_SOURCE_FILES
- vlad.h)
-
- if(IS_GNU OR IS_CLANG)
-- if(HAS_AVX_EXTENSION)
-- list(APPEND VLFEAT_SOURCE_FILES
-+ if(SIMD_ENABLED AND CMAKE_SYSTEM_PROCESSOR MATCHES "[ix].?86|amd64|AMD64")
-+ set(AVX_SOURCES
- mathop_avx.c
- mathop_avx.h)
- else()
- add_definitions(-DVL_DISABLE_AVX)
- endif()
-
-- if(HAS_SSE2_EXTENSION)
-- list(APPEND VLFEAT_SOURCE_FILES
-+ if(SIMD_ENABLED AND CMAKE_SYSTEM_PROCESSOR MATCHES "[ix].?86|amd64|AMD64")
-+ set(SSE2_SOURCES
- mathop_sse2.c
- mathop_sse2.h
- imopv_sse2.c
-@@ -88,8 +88,12 @@ if(IS_GNU OR IS_CLANG)
- add_definitions(-DVL_DISABLE_SSE2)
- endif()
-
-- set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} ${SSE_FLAGS}")
-- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} ${SSE_FLAGS}")
-+ list(APPEND VLFEAT_SOURCE_FILES ${AVX_SOURCES} ${SSE2_SOURCES})
-+
-+ set_source_files_properties(${AVX_SOURCES}
-+ PROPERTIES COMPILE_FLAGS "-mavx")
-+ set_source_files_properties(${SSE2_SOURCES}
-+ PROPERTIES COMPILE_FLAGS "-msse2")
- else()
- add_definitions(-DVL_DISABLE_AVX)
- add_definitions(-DVL_DISABLE_SSE2)
diff --git a/graphics/colmap/pkg-plist b/graphics/colmap/pkg-plist
new file mode 100644
index 000000000000..34025854adb5
--- /dev/null
+++ b/graphics/colmap/pkg-plist
@@ -0,0 +1,300 @@
+bin/colmap
+include/colmap/base/camera.h
+include/colmap/base/camera_database.h
+include/colmap/base/camera_models.h
+include/colmap/base/camera_rig.h
+include/colmap/base/correspondence_graph.h
+include/colmap/base/cost_functions.h
+include/colmap/base/database.h
+include/colmap/base/database_cache.h
+include/colmap/base/essential_matrix.h
+include/colmap/base/gps.h
+include/colmap/base/graph_cut.h
+include/colmap/base/homography_matrix.h
+include/colmap/base/image.h
+include/colmap/base/image_reader.h
+include/colmap/base/line.h
+include/colmap/base/point2d.h
+include/colmap/base/point3d.h
+include/colmap/base/polynomial.h
+include/colmap/base/pose.h
+include/colmap/base/projection.h
+include/colmap/base/reconstruction.h
+include/colmap/base/reconstruction_manager.h
+include/colmap/base/scene_clustering.h
+include/colmap/base/similarity_transform.h
+include/colmap/base/track.h
+include/colmap/base/triangulation.h
+include/colmap/base/undistortion.h
+include/colmap/base/visibility_pyramid.h
+include/colmap/base/warp.h
+include/colmap/controllers/automatic_reconstruction.h
+include/colmap/controllers/bundle_adjustment.h
+include/colmap/controllers/hierarchical_mapper.h
+include/colmap/controllers/incremental_mapper.h
+include/colmap/estimators/absolute_pose.h
+include/colmap/estimators/affine_transform.h
+include/colmap/estimators/coordinate_frame.h
+include/colmap/estimators/essential_matrix.h
+include/colmap/estimators/essential_matrix_coeffs.h
+include/colmap/estimators/essential_matrix_poly.h
+include/colmap/estimators/euclidean_transform.h
+include/colmap/estimators/fundamental_matrix.h
+include/colmap/estimators/generalized_absolute_pose.h
+include/colmap/estimators/generalized_absolute_pose_coeffs.h
+include/colmap/estimators/generalized_relative_pose.h
+include/colmap/estimators/homography_matrix.h
+include/colmap/estimators/pose.h
+include/colmap/estimators/similarity_transform.h
+include/colmap/estimators/translation_transform.h
+include/colmap/estimators/triangulation.h
+include/colmap/estimators/two_view_geometry.h
+include/colmap/estimators/utils.h
+include/colmap/feature/extraction.h
+include/colmap/feature/matching.h
+include/colmap/feature/sift.h
+include/colmap/feature/types.h
+include/colmap/feature/utils.h
+include/colmap/lib/FLANN/algorithms/all_indices.h
+include/colmap/lib/FLANN/algorithms/autotuned_index.h
+include/colmap/lib/FLANN/algorithms/center_chooser.h
+include/colmap/lib/FLANN/algorithms/composite_index.h
+include/colmap/lib/FLANN/algorithms/dist.h
+include/colmap/lib/FLANN/algorithms/hierarchical_clustering_index.h
+include/colmap/lib/FLANN/algorithms/kdtree_cuda_3d_index.h
+include/colmap/lib/FLANN/algorithms/kdtree_cuda_builder.h
+include/colmap/lib/FLANN/algorithms/kdtree_index.h
+include/colmap/lib/FLANN/algorithms/kdtree_single_index.h
+include/colmap/lib/FLANN/algorithms/kmeans_index.h
+include/colmap/lib/FLANN/algorithms/linear_index.h
+include/colmap/lib/FLANN/algorithms/lsh_index.h
+include/colmap/lib/FLANN/algorithms/nn_index.h
+include/colmap/lib/FLANN/config.h
+include/colmap/lib/FLANN/defines.h
+include/colmap/lib/FLANN/ext/lz4.h
+include/colmap/lib/FLANN/ext/lz4hc.h
+include/colmap/lib/FLANN/flann.h
+include/colmap/lib/FLANN/general.h
+include/colmap/lib/FLANN/io/hdf5.h
+include/colmap/lib/FLANN/mpi/client.h
+include/colmap/lib/FLANN/mpi/index.h
+include/colmap/lib/FLANN/mpi/matrix.h
+include/colmap/lib/FLANN/mpi/queries.h
+include/colmap/lib/FLANN/mpi/server.h
+include/colmap/lib/FLANN/nn/ground_truth.h
+include/colmap/lib/FLANN/nn/index_testing.h
+include/colmap/lib/FLANN/nn/simplex_downhill.h
+include/colmap/lib/FLANN/util/allocator.h
+include/colmap/lib/FLANN/util/any.h
+include/colmap/lib/FLANN/util/cuda/heap.h
+include/colmap/lib/FLANN/util/cuda/result_set.h
+include/colmap/lib/FLANN/util/cutil_math.h
+include/colmap/lib/FLANN/util/dynamic_bitset.h
+include/colmap/lib/FLANN/util/heap.h
+include/colmap/lib/FLANN/util/logger.h
+include/colmap/lib/FLANN/util/lsh_table.h
+include/colmap/lib/FLANN/util/matrix.h
+include/colmap/lib/FLANN/util/object_factory.h
+include/colmap/lib/FLANN/util/params.h
+include/colmap/lib/FLANN/util/random.h
+include/colmap/lib/FLANN/util/result_set.h
+include/colmap/lib/FLANN/util/sampling.h
+include/colmap/lib/FLANN/util/saving.h
+include/colmap/lib/FLANN/util/serialization.h
+include/colmap/lib/FLANN/util/timer.h
+include/colmap/lib/Graclus/metisLib/defs.h
+include/colmap/lib/Graclus/metisLib/macros.h
+include/colmap/lib/Graclus/metisLib/metis.h
+include/colmap/lib/Graclus/metisLib/proto.h
+include/colmap/lib/Graclus/metisLib/rename.h
+include/colmap/lib/Graclus/metisLib/struct.h
+include/colmap/lib/LSD/lsd.h
+include/colmap/lib/PBA/ConfigBA.h
+include/colmap/lib/PBA/CuTexImage.h
+include/colmap/lib/PBA/DataInterface.h
+include/colmap/lib/PBA/ProgramCU.h
+include/colmap/lib/PBA/SparseBundleCPU.h
+include/colmap/lib/PBA/SparseBundleCU.h
+include/colmap/lib/PBA/pba.h
+include/colmap/lib/PBA/util.h
+include/colmap/lib/PoissonRecon/Allocator.h
+include/colmap/lib/PoissonRecon/Array.h
+include/colmap/lib/PoissonRecon/BSplineData.h
+include/colmap/lib/PoissonRecon/BinaryNode.h
+include/colmap/lib/PoissonRecon/CmdLineParser.h
+include/colmap/lib/PoissonRecon/Factor.h
+include/colmap/lib/PoissonRecon/FunctionData.h
+include/colmap/lib/PoissonRecon/Geometry.h
+include/colmap/lib/PoissonRecon/Hash.h
+include/colmap/lib/PoissonRecon/MAT.h
+include/colmap/lib/PoissonRecon/MarchingCubes.h
+include/colmap/lib/PoissonRecon/MemoryUsage.h
+include/colmap/lib/PoissonRecon/MultiGridOctreeData.h
+include/colmap/lib/PoissonRecon/MyTime.h
+include/colmap/lib/PoissonRecon/Octree.h
+include/colmap/lib/PoissonRecon/PPolynomial.h
+include/colmap/lib/PoissonRecon/Ply.h
+include/colmap/lib/PoissonRecon/PointStream.h
+include/colmap/lib/PoissonRecon/PoissonRecon.h
+include/colmap/lib/PoissonRecon/Polynomial.h
+include/colmap/lib/PoissonRecon/SparseMatrix.h
+include/colmap/lib/PoissonRecon/SurfaceTrimmer.h
+include/colmap/lib/SiftGPU/CLTexImage.h
+include/colmap/lib/SiftGPU/CuTexImage.h
+include/colmap/lib/SiftGPU/FrameBufferObject.h
+include/colmap/lib/SiftGPU/GLTexImage.h
+include/colmap/lib/SiftGPU/GlobalUtil.h
+include/colmap/lib/SiftGPU/LiteWindow.h
+include/colmap/lib/SiftGPU/ProgramCG.h
+include/colmap/lib/SiftGPU/ProgramCL.h
+include/colmap/lib/SiftGPU/ProgramCU.h
+include/colmap/lib/SiftGPU/ProgramGLSL.h
+include/colmap/lib/SiftGPU/ProgramGPU.h
+include/colmap/lib/SiftGPU/PyramidCL.h
+include/colmap/lib/SiftGPU/PyramidCU.h
+include/colmap/lib/SiftGPU/PyramidGL.h
+include/colmap/lib/SiftGPU/ShaderMan.h
+include/colmap/lib/SiftGPU/SiftGPU.h
+include/colmap/lib/SiftGPU/SiftMatch.h
+include/colmap/lib/SiftGPU/SiftMatchCU.h
+include/colmap/lib/SiftGPU/SiftPyramid.h
+include/colmap/lib/VLFeat/aib.h
+include/colmap/lib/VLFeat/array.h
+include/colmap/lib/VLFeat/covdet.h
+include/colmap/lib/VLFeat/dsift.h
+include/colmap/lib/VLFeat/fisher.h
+include/colmap/lib/VLFeat/float.h
+include/colmap/lib/VLFeat/generic.h
+include/colmap/lib/VLFeat/getopt_long.h
+include/colmap/lib/VLFeat/gmm.h
+include/colmap/lib/VLFeat/heap-def.h
+include/colmap/lib/VLFeat/hikmeans.h
+include/colmap/lib/VLFeat/hog.h
+include/colmap/lib/VLFeat/homkermap.h
+include/colmap/lib/VLFeat/host.h
+include/colmap/lib/VLFeat/ikmeans.h
+include/colmap/lib/VLFeat/imopv.h
+include/colmap/lib/VLFeat/imopv_sse2.h
+include/colmap/lib/VLFeat/kdtree.h
+include/colmap/lib/VLFeat/kmeans.h
+include/colmap/lib/VLFeat/lbp.h
+include/colmap/lib/VLFeat/liop.h
+include/colmap/lib/VLFeat/mathop.h
+include/colmap/lib/VLFeat/mathop_avx.h
+include/colmap/lib/VLFeat/mathop_sse2.h
+include/colmap/lib/VLFeat/mser.h
+include/colmap/lib/VLFeat/pgm.h
+include/colmap/lib/VLFeat/qsort-def.h
+include/colmap/lib/VLFeat/quickshift.h
+include/colmap/lib/VLFeat/random.h
+include/colmap/lib/VLFeat/rodrigues.h
+include/colmap/lib/VLFeat/scalespace.h
+include/colmap/lib/VLFeat/shuffle-def.h
+include/colmap/lib/VLFeat/sift.h
+include/colmap/lib/VLFeat/slic.h
+include/colmap/lib/VLFeat/stringop.h
+include/colmap/lib/VLFeat/svm.h
+include/colmap/lib/VLFeat/svmdataset.h
+include/colmap/lib/VLFeat/vlad.h
+include/colmap/mvs/consistency_graph.h
+include/colmap/mvs/cuda_array_wrapper.h
+include/colmap/mvs/cuda_flip.h
+include/colmap/mvs/cuda_rotate.h
+include/colmap/mvs/cuda_transpose.h
+include/colmap/mvs/depth_map.h
+include/colmap/mvs/fusion.h
+include/colmap/mvs/gpu_mat.h
+include/colmap/mvs/gpu_mat_prng.h
+include/colmap/mvs/gpu_mat_ref_image.h
+include/colmap/mvs/image.h
+include/colmap/mvs/mat.h
+include/colmap/mvs/meshing.h
+include/colmap/mvs/model.h
+include/colmap/mvs/normal_map.h
+include/colmap/mvs/patch_match.h
+include/colmap/mvs/patch_match_cuda.h
+include/colmap/mvs/workspace.h
+include/colmap/optim/bundle_adjustment.h
+include/colmap/optim/combination_sampler.h
+include/colmap/optim/least_absolute_deviations.h
+include/colmap/optim/loransac.h
+include/colmap/optim/progressive_sampler.h
+include/colmap/optim/random_sampler.h
+include/colmap/optim/ransac.h
+include/colmap/optim/sampler.h
+include/colmap/optim/sprt.h
+include/colmap/optim/support_measurement.h
+include/colmap/retrieval/geometry.h
+include/colmap/retrieval/inverted_file.h
+include/colmap/retrieval/inverted_file_entry.h
+include/colmap/retrieval/inverted_index.h
+include/colmap/retrieval/utils.h
+include/colmap/retrieval/visual_index.h
+include/colmap/retrieval/vote_and_verify.h
+include/colmap/sfm/incremental_mapper.h
+include/colmap/sfm/incremental_triangulator.h
+include/colmap/ui/automatic_reconstruction_widget.h
+include/colmap/ui/bundle_adjustment_widget.h
+include/colmap/ui/colormaps.h
+include/colmap/ui/database_management_widget.h
+include/colmap/ui/dense_reconstruction_widget.h
+include/colmap/ui/feature_extraction_widget.h
+include/colmap/ui/feature_matching_widget.h
+include/colmap/ui/image_viewer_widget.h
+include/colmap/ui/license_widget.h
+include/colmap/ui/line_painter.h
+include/colmap/ui/log_widget.h
+include/colmap/ui/main_window.h
+include/colmap/ui/match_matrix_widget.h
+include/colmap/ui/model_viewer_widget.h
+include/colmap/ui/movie_grabber_widget.h
+include/colmap/ui/options_widget.h
+include/colmap/ui/point_painter.h
+include/colmap/ui/point_viewer_widget.h
+include/colmap/ui/project_widget.h
+include/colmap/ui/qt_utils.h
+include/colmap/ui/reconstruction_manager_widget.h
+include/colmap/ui/reconstruction_options_widget.h
+include/colmap/ui/reconstruction_stats_widget.h
+include/colmap/ui/render_options.h
+include/colmap/ui/render_options_widget.h
+include/colmap/ui/thread_control_widget.h
+include/colmap/ui/triangle_painter.h
+include/colmap/ui/undistortion_widget.h
+include/colmap/util/alignment.h
+include/colmap/util/bitmap.h
+include/colmap/util/cache.h
+include/colmap/util/camera_specs.h
+include/colmap/util/cuda.h
+include/colmap/util/cudacc.h
+include/colmap/util/endian.h
+include/colmap/util/logging.h
+include/colmap/util/math.h
+include/colmap/util/matrix.h
+include/colmap/util/misc.h
+include/colmap/util/opengl_utils.h
+include/colmap/util/option_manager.h
+include/colmap/util/ply.h
+include/colmap/util/random.h
+include/colmap/util/sqlite3_utils.h
+include/colmap/util/string.h
+include/colmap/util/testing.h
+include/colmap/util/threading.h
+include/colmap/util/timer.h
+include/colmap/util/types.h
+include/colmap/util/version.h
+lib/colmap/libcolmap.a
+lib/colmap/libflann.a
+lib/colmap/libgraclus.a
+lib/colmap/liblsd.a
+lib/colmap/libpba.a
+lib/colmap/libpoisson_recon.a
+lib/colmap/libsift_gpu.a
+lib/colmap/libvlfeat.a
+share/applications/COLMAP.desktop
+%%DATADIR%%/COLMAPConfig.cmake
+%%DATADIR%%/COLMAPConfigVersion.cmake
+%%DATADIR%%/cmake/FindEigen3.cmake
+%%DATADIR%%/cmake/FindFreeImage.cmake
+%%DATADIR%%/cmake/FindGlew.cmake
+%%DATADIR%%/cmake/FindGlog.cmake