aboutsummaryrefslogtreecommitdiff
path: root/graphics/darktable
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-09-30 20:44:19 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-12-31 00:37:05 +0000
commitbbab7f59e9630416397189df70ec133bdd690e38 (patch)
tree2ebb595d5a675fda686781b56ea08f80b933cb61 /graphics/darktable
parenta1bc4fbdf378334c7c39521ab236318c53f27441 (diff)
downloadports-bbab7f59e9630416397189df70ec133bdd690e38.tar.gz
ports-bbab7f59e9630416397189df70ec133bdd690e38.zip
*/*: Sunset 12.4-RELEASE/12-STABLE from ports tree
- Remove all references to defunct ARCH arm - Remove all references to defunct ARCH sparc64 - Remove x11-drivers/xf86-video-sunffb which requires defunct sparc64 ARCH - Remove sysutils/afbinit requires defunct sparc64 ARCH - Remove all references to bktr driver - Remove all references to defunct FreeBSD_12 - Remove all references to OSVERSION/OSREL corresponding to 12 - Remove conditionals in Mk/Uses/cabal.mk - Remove sparc reference from Mk/Uses/qt-dist.mk - Remove BROKEN_sparc64/NOT_FOR_ARCH=sparc64 - Remove BROKEN_FreeBSD_12* from: - Remove OpenSSL patches from: - Remove conditional flags for OSVERSION >= 1300000 to fixed flags. Also move conditional flags for non sparc64/arm ARCH to fixed flags. Reviewed by: brooks, jbeich, rene, salvadore Differential Revision: https://reviews.freebsd.org/D42068
Diffstat (limited to 'graphics/darktable')
-rw-r--r--graphics/darktable/Makefile27
1 files changed, 1 insertions, 26 deletions
diff --git a/graphics/darktable/Makefile b/graphics/darktable/Makefile
index 2660fae03d6d..a85b9ea58869 100644
--- a/graphics/darktable/Makefile
+++ b/graphics/darktable/Makefile
@@ -44,6 +44,7 @@ LIB_DEPENDS= libavif.so:graphics/libavif \
USES= cmake compiler:gcc-c++11-lib desktop-file-utils gl gnome jpeg \
llvm:15,build lua:54 perl5 pkgconfig sdl shebangfix sqlite \
tar:xz xorg
+USE_GCC= yes
USE_GL= gl
USE_GNOME= cairo gtk30 intltool librsvg2 libxml2
USE_LDCONFIG= ${PREFIX}/lib/${PORTNAME}
@@ -95,32 +96,6 @@ TOOLS_RUN_DEPENDS= exiftool:graphics/p5-Image-ExifTool
.include <bsd.port.options.mk>
-.if ${OPSYS}_${OSREL:R} == FreeBSD_12
-# Darktable fails to compile with GCC 13+ on FreeBSD 12.x with the following
-# error:
-#
-# In file included from /usr/include/c++/v1/__functional/weak_result_type.h:16,
-# from /usr/include/c++/v1/__functional/invoke.h:14,
-# from /usr/include/c++/v1/__functional_base:15,
-# from /usr/include/c++/v1/string:520,
-# from .../work/darktable-4.4.2/src/external/rawspeed/src/librawspeed/common/ChecksumFile.h:23,
-# from .../work/darktable-4.4.2/src/external/rawspeed/src/librawspeed/common/ChecksumFile.cpp:21:
-# /usr/include/c++/v1/type_traits:1770:8: error: expected identifier before '__is_convertible'
-# 1770 | struct __is_convertible
-# | ^~~~~~~~~~~~~~~~
-#
-# This seems to be an incompatibility between GCC 13+ and libcxx provided with
-# FreeBSD 12.x. The workarounbd is to force the use of GCC 12 on this version
-# of FreeBSD.
-#
-# See:
-# https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=273397
-# https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=273681
-USE_GCC= 12
-.else
-USE_GCC= yes
-.endif
-
.if ${ARCH} == aarch64 || ${ARCH} == powerpc64le
CMAKE_ARGS+= -DUSE_OPENCL:BOOL=OFF
CXXFLAGS+= -DGDK_DISABLE_DEPRECATED