aboutsummaryrefslogtreecommitdiff
path: root/graphics/darktable
diff options
context:
space:
mode:
authorJean-Sébastien Pédron <dumbbell@FreeBSD.org>2018-04-29 09:24:57 +0000
committerJean-Sébastien Pédron <dumbbell@FreeBSD.org>2018-04-29 09:24:57 +0000
commitf3197da792cf3f7db5d7e4b51e552d09265f39ff (patch)
tree5d70ea7245a88443619118190b4d52ccaa97ca02 /graphics/darktable
parent8c8a540c766a8c90a5e27010a715887b22be2a72 (diff)
downloadports-f3197da792cf3f7db5d7e4b51e552d09265f39ff.tar.gz
ports-f3197da792cf3f7db5d7e4b51e552d09265f39ff.zip
graphics/darktable: Build with LLVM 6.0
... instead of LLVM 5.0. The reason is to stay in sync with Mesa to keep the number of LLVM copies to build to the minimum. It looks like the hack to explicitely set `LDFLAGS` to have OpenMP support isn't necessary anymore. The last time it was revisited was with LLVM 3.9.1.
Notes
Notes: svn path=/head/; revision=468615
Diffstat (limited to 'graphics/darktable')
-rw-r--r--graphics/darktable/Makefile13
1 files changed, 3 insertions, 10 deletions
diff --git a/graphics/darktable/Makefile b/graphics/darktable/Makefile
index 188fbab729e9..9b8d085cf34d 100644
--- a/graphics/darktable/Makefile
+++ b/graphics/darktable/Makefile
@@ -3,7 +3,7 @@
PORTNAME= darktable
PORTVERSION= 2.4.3
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= https://github.com/darktable-org/${PORTNAME}/releases/download/release-${PORTVERSION:C/\.rc/rc/}/
@@ -98,21 +98,14 @@ WEBP_CMAKE_OFF= -DUSE_WEBP:BOOL=OFF
.include <bsd.port.pre.mk>
.if ${ARCH} == amd64 && ${CHOSEN_COMPILER_TYPE} == clang
-# Enable OpenMP support with Clang 5.0.
-LLVM_VER= 50
+# Enable OpenMP support with Clang 6.0.
+LLVM_VER= 60
BUILD_DEPENDS+= clang${LLVM_VER}:devel/llvm${LLVM_VER}
CPP= clang-cpp${LLVM_VER}
CC= clang${LLVM_VER}
CXX= clang++${LLVM_VER}
-# FIXME: At least in 3.7.0 and 3.7.1, Clang doesn't find libomp.so
-# itself. Furthermore, there may be a regression in 3.7.1 because we now
-# need to explicitly link to libm.so as well. This remains true with
-# Clang 3.9.1.
-OPENMP_FLAGS= -L${LOCALBASE}/llvm${LLVM_VER}/lib -lm -lomp
-LDFLAGS+= ${OPENMP_FLAGS}
-
# Depend on devel/openmp instead of the full LLVM at runtime. Required
# for a consistent libomp experience.
LIB_DEPENDS+= libomp.so.0:devel/openmp