aboutsummaryrefslogtreecommitdiff
path: root/graphics/darktable
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2020-11-17 15:24:00 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2020-11-17 15:24:00 +0000
commitfb67312520cb8ff3f2b65111b36eb810ef279ef0 (patch)
tree84f318b652756b7bf66ec27b5c532cf1e0c45a11 /graphics/darktable
parent860d7ad91dfad530d4d423e0542521ea5bcab38c (diff)
downloadports-fb67312520cb8ff3f2b65111b36eb810ef279ef0.tar.gz
ports-fb67312520cb8ff3f2b65111b36eb810ef279ef0.zip
graphics/darktable: fix build on powerpc64le, add aarch64 to the mix
powerpc64le needs already committed patch for opencl, aarch64 is untested because: [00:00:12] Finished lang/rust | rust-1.47.0: Ignored: fails to build with qemu-user-static It may need another fix.
Notes
Notes: svn path=/head/; revision=555560
Diffstat (limited to 'graphics/darktable')
-rw-r--r--graphics/darktable/Makefile4
-rw-r--r--graphics/darktable/files/patch-src_external_OpenCL_CL_cl__platform.h13
2 files changed, 15 insertions, 2 deletions
diff --git a/graphics/darktable/Makefile b/graphics/darktable/Makefile
index 7ed57d6c5504..a9c6c7866e47 100644
--- a/graphics/darktable/Makefile
+++ b/graphics/darktable/Makefile
@@ -12,8 +12,8 @@ COMMENT= Virtual lighttable and darkroom for photographers
LICENSE= GPLv3
-ONLY_FOR_ARCHS= amd64
-ONLY_FOR_ARCHS_REASON= uses SSE instructions and 64-bit address space
+ONLY_FOR_ARCHS= aarch64 amd64 powerpc64le
+ONLY_FOR_ARCHS_REASON= uses 64-bit address space
BUILD_DEPENDS= iso-codes>=0:misc/iso-codes \
p5-Pod-Parser>=0:textproc/p5-Pod-Parser \
diff --git a/graphics/darktable/files/patch-src_external_OpenCL_CL_cl__platform.h b/graphics/darktable/files/patch-src_external_OpenCL_CL_cl__platform.h
new file mode 100644
index 000000000000..1a918830fb24
--- /dev/null
+++ b/graphics/darktable/files/patch-src_external_OpenCL_CL_cl__platform.h
@@ -0,0 +1,13 @@
+--- src/external/OpenCL/CL/cl_platform.h.orig 2020-11-17 15:04:41 UTC
++++ src/external/OpenCL/CL/cl_platform.h
+@@ -355,7 +355,9 @@ typedef unsigned int cl_GLenum;
+
+ /* Define basic vector types */
+ #if defined( __VEC__ )
+- #include <altivec.h> /* may be omitted depending on compiler. AltiVec spec provides no way to detect whether the header is required. */
++ #if !defined(__clang__)
++ #include <altivec.h> /* may be omitted depending on compiler. AltiVec spec provides no way to detect whether the header is required. */
++ #endif
+ typedef __vector unsigned char __cl_uchar16;
+ typedef __vector signed char __cl_char16;
+ typedef __vector unsigned short __cl_ushort8;