aboutsummaryrefslogtreecommitdiff
path: root/graphics/dbow2
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2020-10-03 01:49:58 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2020-10-03 01:49:58 +0000
commitc0fc57f56c2051ab05eee245ca9bd4ca2ce48bcc (patch)
treeea3379d518576001a4bcd91fe5ccd2630ea4ba8b /graphics/dbow2
parent81d2ee7db29b747ff346cc091f5b1cf46274570e (diff)
downloadports-c0fc57f56c2051ab05eee245ca9bd4ca2ce48bcc.tar.gz
ports-c0fc57f56c2051ab05eee245ca9bd4ca2ce48bcc.zip
New port: graphics/dbow2: C++ Library for converting images into a bag-of-word representation
Notes
Notes: svn path=/head/; revision=551248
Diffstat (limited to 'graphics/dbow2')
-rw-r--r--graphics/dbow2/Makefile27
-rw-r--r--graphics/dbow2/distinfo3
-rw-r--r--graphics/dbow2/pkg-descr8
-rw-r--r--graphics/dbow2/pkg-plist14
4 files changed, 52 insertions, 0 deletions
diff --git a/graphics/dbow2/Makefile b/graphics/dbow2/Makefile
new file mode 100644
index 000000000000..9e2a3da06291
--- /dev/null
+++ b/graphics/dbow2/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= dbow2
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.1-free-23
+DISTVERSIONSUFFIX= -g3924753
+CATEGORIES= graphics
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= C++ Library for converting images into a bag-of-word representation
+
+LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+LIB_DEPENDS= libopencv_photo.so:graphics/opencv \
+ libopencv_core.so:graphics/opencv-core
+
+USES= cmake compiler:c++11-lang
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= dorian3d
+GH_PROJECT= DBoW2
+
+CMAKE_OFF= BUILD_Demo
+
+.include <bsd.port.mk>
diff --git a/graphics/dbow2/distinfo b/graphics/dbow2/distinfo
new file mode 100644
index 000000000000..cdf82de9c621
--- /dev/null
+++ b/graphics/dbow2/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1601689019
+SHA256 (dorian3d-DBoW2-v1.1-free-23-g3924753_GH0.tar.gz) = cc56a75fab644786f3caf72c50af7e3af731cec2d59ea4a8dbb8402282f469b1
+SIZE (dorian3d-DBoW2-v1.1-free-23-g3924753_GH0.tar.gz) = 581096
diff --git a/graphics/dbow2/pkg-descr b/graphics/dbow2/pkg-descr
new file mode 100644
index 000000000000..7267fab36015
--- /dev/null
+++ b/graphics/dbow2/pkg-descr
@@ -0,0 +1,8 @@
+DBoW2 is an improved version of the DBow library, an open source C++ library for
+indexing and converting images into a bag-of-word representation. It implements
+a hierarchical tree for approximating nearest neighbours in the image feature
+space and creating a visual vocabulary. DBoW2 also implements an image database
+with inverted and direct files to index images and enabling quick queries and
+feature comparisons.
+
+WWW: https://github.com/dorian3d/DBoW2
diff --git a/graphics/dbow2/pkg-plist b/graphics/dbow2/pkg-plist
new file mode 100644
index 000000000000..22b2d2887415
--- /dev/null
+++ b/graphics/dbow2/pkg-plist
@@ -0,0 +1,14 @@
+include/DBoW2/BowVector.h
+include/DBoW2/DBoW2.h
+include/DBoW2/DBoW2Config.cmake
+include/DBoW2/FBrief.h
+include/DBoW2/FClass.h
+include/DBoW2/FORB.h
+include/DBoW2/FSurf64.h
+include/DBoW2/FeatureVector.h
+include/DBoW2/QueryResults.h
+include/DBoW2/ScoringObject.h
+include/DBoW2/TemplatedDatabase.h
+include/DBoW2/TemplatedVocabulary.h
+lib/cmake/DBoW2/DBoW2Config.cmake
+lib/libDBoW2.so