aboutsummaryrefslogtreecommitdiff
path: root/graphics/dcraw-m
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2014-11-29 15:22:03 +0000
committerRene Ladan <rene@FreeBSD.org>2014-11-29 15:22:03 +0000
commitbb87df7ff61b6aa2df649105d5b4ca5211d6cdac (patch)
tree22b76373ae883dec272250c226bbfc166d591d5f /graphics/dcraw-m
parent479b4da944fe378b731c61b764668b2f85973e46 (diff)
downloadports-bb87df7ff61b6aa2df649105d5b4ca5211d6cdac.tar.gz
ports-bb87df7ff61b6aa2df649105d5b4ca5211d6cdac.zip
- Update to 9.22 and unexpire
- Change MASTER_SITES to GitHub - Add GPLv2 as license - Switch dependency from lcms to lcms2 - Drop -O3 and -O4 options From myself: - unmute do-build command - add USES=pkgconfig to fix build PR: 194775 Submitted by: maintainer <waitman@waitman.net>
Notes
Notes: svn path=/head/; revision=373628
Diffstat (limited to 'graphics/dcraw-m')
-rw-r--r--graphics/dcraw-m/Makefile45
-rw-r--r--graphics/dcraw-m/distinfo4
-rw-r--r--graphics/dcraw-m/pkg-descr7
3 files changed, 26 insertions, 30 deletions
diff --git a/graphics/dcraw-m/Makefile b/graphics/dcraw-m/Makefile
index 5d63feb463e5..78770fd21db4 100644
--- a/graphics/dcraw-m/Makefile
+++ b/graphics/dcraw-m/Makefile
@@ -2,48 +2,43 @@
# $FreeBSD$
PORTNAME= dcraw-m
-PORTVERSION= 9.17
-PORTREVISION= 1
+PORTVERSION= 9.22
CATEGORIES= graphics
-MASTER_SITES= https://dx.burplex.com/dcraw-m/ \
- http://www.waitman.net/dcraw-m/
+MASTER_SITES= GH
MAINTAINER= waitman@waitman.net
COMMENT= Modified Decoder for RAW files from digital cameras
-BROKEN= Unfetchable
-DEPRECATED= Broken for more than 6 months
-EXPIRATION_DATE= 2014-11-26
+LICENSE= GPLv2
LIB_DEPENDS= libjasper.so:${PORTSDIR}/graphics/jasper \
libjpeg.so:${PORTSDIR}/graphics/jpeg \
- liblcms.so:${PORTSDIR}/graphics/lcms \
+ liblcms2.so:${PORTSDIR}/graphics/lcms2 \
libMagickWand-6.Q16.so:${PORTSDIR}/graphics/ImageMagick
-PLIST_FILES= bin/dcraw-m
-
-OPTIONS_DEFINE= OPTIMIZE_O3 OPTIMIZE_O4
-OPTIMIZE_O3_DESC= Use O3 with clang (O4 not working)
-OPTIMIZE_O4_DESC= Use O4 with gcc
+USE_GITHUB= yes
+GH_ACCOUNT= waitman
+GH_PROJECT= dcraw-m
+GH_TAGNAME= ${GH_COMMIT}
+GH_COMMIT= 1392579
-.include <bsd.port.options.mk>
+USES= pkgconfig
-.if ${PORT_OPTIONS:MOPTIMIZE_O3}
-CFLAGS+= -O3
-.else
-.if ${PORT_OPTIONS:MOPTIMIZE_O4}
-CFLAGS+= -O4
-.endif
-.endif
+CFLAGS += -Wall -Werror -I${LOCALBASE}/include \
+ `MagickWand-config --cflags --cppflags` \
+ -DMAGICKCORE_HDRI_ENABLE=0 \
+ -DMAGICKCORE_QUANTUM_DEPTH=16
+LDFLAGS += `MagickWand-config --ldflags --libs` -lm -llcms2 -ljpeg \
+ -ljasper
+LIBS += -L${LOCALBASE}/lib
-CFLAGS+= -I${LOCALBASE}/include -I${LOCALBASE}/include/ImageMagick-6
-LDFLAGS+= -L${LOCALBASE}/lib -lm -ljasper -ljpeg -llcms -lMagickWand-6.Q16
+PLIST_FILES= bin/dcraw-m
do-build:
- cd ${WRKSRC}/ && ${CC} -o ${PORTNAME} ${CFLAGS} ${PORTNAME}.c ${LDFLAGS}
+ ( cd ${WRKSRC} ; \
+ ${CC} ${CFLAGS} ${LIBS} ${LDFLAGS} -o ${PORTNAME} ${PORTNAME}.c )
do-install:
- ${MKDIR} ${STAGEDIR}${PREFIX}/bin
${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
.include <bsd.port.mk>
diff --git a/graphics/dcraw-m/distinfo b/graphics/dcraw-m/distinfo
index b5f201aa490f..fcd03ee98370 100644
--- a/graphics/dcraw-m/distinfo
+++ b/graphics/dcraw-m/distinfo
@@ -1,2 +1,2 @@
-SHA256 (dcraw-m-9.17.tar.gz) = 1b727e9b51e9aacae3d0ce3bf7d805f014b43baf371715351ae46c46c2e90269
-SIZE (dcraw-m-9.17.tar.gz) = 88589
+SHA256 (dcraw-m-9.22.tar.gz) = 881c05540cc6ace3921c611f25c58e3c29a4f93133c1fdbded170fae4b5dce5e
+SIZE (dcraw-m-9.22.tar.gz) = 95427
diff --git a/graphics/dcraw-m/pkg-descr b/graphics/dcraw-m/pkg-descr
index 206de06094ba..ccdaf32d9ce1 100644
--- a/graphics/dcraw-m/pkg-descr
+++ b/graphics/dcraw-m/pkg-descr
@@ -6,8 +6,9 @@ when used skillfully, produces better-quality output than the tools provided by
the camera vendor.
This version is modified to add auto-rotate to exported thumbnails, and also
-add adjustment for camera timezone offset.
+add adjustment for camera timezone offset. If your thumbnails appear upside
+down, set DCRAW_RTC env var.
WWW: http://www.cybercom.net/~dcoffin/dcraw/
-WWW: https://dx.burplex.com/bin/autorot.html
-WWW: https://dx.burplex.com/bin/photohack.html
+WWW: https://dx.mehomi.com/autorot.html
+WWW: https://dx.mehomi.com/photohack.html